Esp32 sim800l ttgo t call .. not working

Hi everyone …
I recently bought one of these to test it out … but I’m stuck …
Integration with ESPHOME works (connect to WiFi) but not able to send or receive SMS …
I checked the sim on a 2g phone , it is able to send and receive SMS …
If anyone has any success with this I would be really grateful for any advice or working yaml …

Thanks in advance

1 Like

Can you post your yaml and your log please?

my esphome yaml

  name: sim800l
  platform: ESP32
  board: esp32dev

  ssid: "XXXXX"
  password: "XXXXXXX"

  # Enable fallback hotspot (captive portal) in case wifi connection fails
    ssid: "Sim800L Fallback Hotspot"
    password: "lBOnTtCvJmiP"


# Enable logging

# Enable Home Assistant API
  password: "XXXXXXX"
  - service: send_sms
      recipient: string
      message: string
    - sim800l.send_sms:
        recipient: !lambda 'return recipient;'
        message: !lambda 'return message;'

- platform: template
  id: sms_sender
  name: "Sms Sender"
- platform: template
  id: sms_message
  name: "Sms Message"

  baud_rate: 9600
  tx_pin: GPIO33
  rx_pin: GPIO27

  - lambda: |-

  password: "XXXXXXX"


INFO Reading configuration /config/esphome/sim800l.yaml…
INFO Starting log output from sim800l.local using esphome API
INFO Connecting to sim800l.local:6053 (192.168.1.XX)
INFO Successfully connected to sim800l.local
[16:35:39][I][app:100]: ESPHome version 1.14.3 compiled on Nov 20 2019, 18:11:00
[16:35:39][C][wifi:415]: WiFi:
[16:35:39][C][wifi:283]: SSID: [redacted]
[16:35:39][C][wifi:284]: IP Address: 192.168.1.XX
[16:35:39][C][wifi:286]: BSSID: [redacted]
[16:35:39][C][wifi:287]: Hostname: ‘sim800l’
[16:35:39][C][wifi:291]: Signal strength: -51 dB ▂▄▆█
[16:35:39][C][wifi:295]: Channel: 5
[16:35:39][C][wifi:296]: Subnet:
[16:35:39][C][wifi:297]: Gateway:
[16:35:39][C][wifi:298]: DNS1:
[16:35:39][C][wifi:299]: DNS2:
[16:35:39][C][uart:040]: UART Bus:
[16:35:39][C][uart:042]: TX Pin: GPIO33
[16:35:39][C][uart:045]: RX Pin: GPIO27
[16:35:39][C][uart:047]: Baud Rate: 9600 baud
[16:35:39][C][uart:048]: Stop bits: 1
[16:35:39][C][template.text_sensor:020]: Template Sensor ‘Sms Sender’
[16:35:39][C][template.text_sensor:020]: Template Sensor ‘Sms Message’
[16:35:39][C][logger:175]: Logger:
[16:35:39][C][logger:176]: Level: DEBUG
[16:35:39][C][logger:177]: Log Baud Rate: 115200
[16:35:39][C][logger:178]: Hardware UART: UART0
[16:35:39][C][sim800l:259]: SIM800L:
[16:35:39][C][sim800l:260]: RSSI: 0 dB
[16:35:39][C][captive_portal:169]: Captive Portal:
[16:35:39][C][ota:029]: Over-The-Air Updates:
[16:35:39][C][ota:030]: Address: sim800l.local:3232
[16:35:39][C][ota:032]: Using Password.
[16:35:39][C][api:095]: API Server:
[16:35:39][C][api:096]: Address: sim800l.local:6053
[16:36:38][I][ota:046]: Boot seems successful, resetting boot loop counter.

any thoughts ?

tx rx pinout

I cannot see any sign of you actually sending an sms message in that log.

I tried send 2 messages and receive 2 messages while the log was on … But nothing happened :pensive:

Well yes that is true, no sign of it. I bought one of those esp devices lately, but I don’t have a spare sim, and keep forgetting to get one so I have not tried it yet.

You could try bumping up the logging?

Haven’t tried different levels of logging… don’t know how to do it … :dizzy_face::blush:

SMS sensor inactive

Oh come on, straight off the esphome home page

Just received a T-Call as well and experiencing the same here. In both your and my output I do see “RSSI: 0 dB” which might be pointing in the direction of either the antenna being crappy or the wrong pinout is being used to let the ESP communicate with the SIM800L.

I’m more inclined to think it has something to do with the pinout … because I added a better antenna and still have the same issue …
I have the ttgo-t-call and the sim800l connected with d1 mini with a voltage regulator still same problem …

Driving me nuts … :joy::crazy_face:

Must be it. It is trying to send “AT” but never gets a response. I’ve tried a bunch of GPIO ports I found online but so far nothing…

You do realise these devices only do gsm/gprs. basically 2g. There are also specific power requirements including the ability to provide 2A.

This listing is quite specific

worth a read.

To initialize the sim800l, you need to bring some pins to a certain state.
Try it like this:

  - platform: gpio
    name: "SIM800_PWKEY"
    pin: 4
    restore_mode: ALWAYS_OFF
  - platform: gpio
    name: "SIM800_RST"
    pin: 5
    restore_mode: ALWAYS_ON
  - platform: gpio
    name: "SIM800_POWER"
    pin: 23
    restore_mode: ALWAYS_ON

It should be remembered that if the LED blinks frequently, then the module is not connected to the operator. If the LED blinks slowly, the module is connected to the service provider.


Awesome, now we’re getting somewhere! The LED wasn’t blinking before, it is now. It seems to register fine to the network, but it doesn’t appear to be reacting to text messages yet.

The logs are showing this so perhaps the wrong GPIO pins are being used since I assume the AT needs to be acknowledged.

[17:29:32][VV][sim800l:230]: Buffer pos: 3 10
[17:29:32][V][sim800l:048]: R: AT - 2
[17:29:32][W][sim800l:062]: Not ack. 2 AT

Edit. Got it!

This seems to work:

  baud_rate: 9600
  tx_pin: 27
  rx_pin: 26

i did both ,

but my loogin states

[16:34:29][W][sim800l:062]: Not ack. 2 ???
[16:34:32][D][sim800l:216]: Unhandled:  a?  - 0
[16:34:40][D][sim800l:216]: Unhandled: ?#??? - 0
[16:34:40][D][sim800l:216]: Unhandled: ? - 0
[16:34:45][I][ota:046]: Boot seems successful, resetting boot loop counter.

working solution here

thank you @reliable @bigstation

Hi, i tried ESPHOME script from @bigstation but it doesn’t work : Loop with “Registration fail”.
I removed pin code and simcard works fine on my phone

Any idea ?

[07:50:38][I][app:100]: ESPHome version 1.14.3 compiled on Feb 12 2020, 19:20:03
[07:50:38][C][wifi:415]: WiFi:
[07:50:38][C][wifi:283]: SSID: [redacted]
[07:50:38][C][wifi:284]: IP Address:
[07:50:38][C][wifi:286]: BSSID: [redacted]
[07:50:38][C][wifi:287]: Hostname: ‘gsm_esp32’
[07:50:38][C][wifi:291]: Signal strength: -41 dB ▂▄▆█
[07:50:38][C][wifi:295]: Channel: 1
[07:50:38][C][wifi:296]: Subnet:
[07:50:38][C][wifi:297]: Gateway:
[07:50:38][C][wifi:298]: DNS1:
[07:50:38][C][wifi:299]: DNS2:
[07:50:38][C][uart:040]: UART Bus:
[07:50:38][C][uart:042]: TX Pin: GPIO27
[07:50:38][C][uart:045]: RX Pin: GPIO26
[07:50:38][C][uart:047]: Baud Rate: 9600 baud
[07:50:38][C][uart:048]: Stop bits: 1
[07:50:39][C][switch.gpio:042]: GPIO Switch ‘key_pin’
[07:50:39][C][switch.gpio:043]: Pin: GPIO4 (Mode: OUTPUT)
[07:50:39][C][switch.gpio:059]: Restore Mode: Always OFF
[07:50:39][C][switch.gpio:042]: GPIO Switch ‘reset_pin’
[07:50:39][C][switch.gpio:043]: Pin: GPIO5 (Mode: OUTPUT)
[07:50:39][C][switch.gpio:059]: Restore Mode: Always ON
[07:50:39][C][switch.gpio:042]: GPIO Switch ‘power_pin’
[07:50:39][C][switch.gpio:043]: Pin: GPIO23 (Mode: OUTPUT)
[07:50:39][C][switch.gpio:059]: Restore Mode: Always ON
[07:50:39][C][template.text_sensor:020]: Template Sensor ‘Sms Sender’
[07:50:39][C][template.text_sensor:020]: Template Sensor ‘Sms Message’
[07:50:39][C][logger:175]: Logger:
[07:50:39][C][logger:176]: Level: DEBUG
[07:50:39][C][logger:177]: Log Baud Rate: 115200
[07:50:39][C][logger:178]: Hardware UART: UART0
[07:50:39][C][sim800l:259]: SIM800L:
[07:50:39][C][sim800l:260]: RSSI: 0 dB
[07:50:39][C][ota:029]: Over-The-Air Updates:
[07:50:39][C][ota:030]: Address: gsm_esp32.local:3232
[07:50:39][C][api:095]: API Server:
[07:50:39][C][api:096]: Address: gsm_esp32.local:6053
[07:50:39][D][sim800l:216]: Unhandled: SMS Ready - 0
[07:50:52][W][sim800l:062]: Not ack. 3 ATE0AT+CMGF=1
[07:50:52][D][sim800l:216]: Unhandled: OK - 0
[07:50:57][D][sim800l:216]: Unhandled: OK - 0
[07:51:08][W][sim800l:107]: Registration Fail
[07:51:08][W][sim800l:107]: Registration Fail
[07:51:11][W][sim800l:107]: Registration Fail

does it require “roaming”? in that case there is a patch on dev which causes it to accept roaming simcards