ESPHome RGBWW Light, brightness problem

Tags: #<Tag:0x00007f77fb792d20>

Hi everyone,

I bought a cheap WiFi Light Bulb a few days ago. It uses the “Lumary” app which I found out to be identical to Tuya or Smart Life, so I tried to flash a custom firmware using tuya-convert. And voíla, it worked right away. After finding out the correct GPIO Pins (it uses an ESP8266) using Tasmota, I flashed ESPHome with the RGBWW component (the bulb supports warm and cold white). My ESPHome config looks as follows:

  
light:
  - platform: rgbww
    name: "Schreibtischlampe"
    red: output_red
    green: output_green
    blue: output_blue
    cold_white: output_coldwhite
    warm_white: output_warmwhite
    cold_white_color_temperature: 7000 K
    warm_white_color_temperature: 2700 K
  
output:
  - platform: esp8266_pwm
    id: output_red
    pin: GPIO5
  - platform: esp8266_pwm
    id: output_green
    pin: GPIO4
  - platform: esp8266_pwm
    id: output_blue
    pin: GPIO13
  - platform: esp8266_pwm
    id: output_coldwhite
    pin: GPIO14
  - platform: esp8266_pwm
    id: output_warmwhite
    pin: GPIO12

The integration to Home Assistant works, however, and that is my problem, there seems to be a bug (or I missed some config, however the Docs don’t show many options). When setting the bulb to white, I can’t adjust the brightness. It kind of changes the color temperature, but not the brightness when adjusting the brightness slider. A similiar issue has been reported here long time ago, however no answer was provided.

Brightness changing works btw fine when setting any other color than white.

Hope somone can help, thanks in advance :slight_smile:

How exactly are you changing the brightness?

You should be able to adjust brightness and colour seperately within HA if you have a correct pin-out. You could also split into 2 light entitites (one rgb and cwww) within one device, it gives you more flexibility.

That’s exactly what I ended up doing and it works great, thanks!

1 Like

Can u get more details on this? How and why did you switch it? My light is working but I have a “W” slider that is making everything crazy. When it’s up I can’t dim the lights and it has to be all the way down to let me select a colour.

I want it to behave like my hue lights

RGBWW is not the same as hue. If you have both white channels at max brightness it will greatly dilute the RGB channels so that the colour change is barely visible.

I’m using the W only for “regular” lighting with rgb turned off and the rgb one for mood lights with W turned off (movie, music, chillout scenes etc…).
A big pro here is if you quickly need a regular bright light while you’re on a mood-light scene you can just have the W turn on without having to leave the scene on your RGB. it will just shine brighter than the RGB.

Is Hue not an RGBWW Light?

Interesting. So you define this in your yaml and two lights get exposed to HomeAssistant?

Would you mind sharing your yaml?

What I’m saying is that they work in a different manner. With ESPHome on Home Assistant, you cannot have the white LEDs on without the RGB ones as well. The solution is to use two light entities which works fine for me.
Have a look here https://quinled.info/2019/02/24/quinled-deca-esphome-sample-configuration/ towards the bootom of the page to see how Quindor does it.

My yamls are here. It’s split configs so Im gonna post the relevant ones

the device:

the light.yaml (where I split up the rgbcwww)

the output.yaml

Thank you!