EU USB sticks for the new Zigbee component

No, I don’t know anyone who has tried them

I am looking for this as well with the new support for Zigbee. Since the Z-Wave frequency in Europe is different than in the US, 868 instead of 908 in the US. The only supported stick would be useless for the Z-Wave part.

So how can we know if a stick is likely to work? Is it based on a chipset, API or a type of radio? Do you have some pointers we can look for or ask the vendor when we search for a compatible zigbee stick?

edit: Based on the info on github think it is the EZSP protocol it needs to support, right?

Been looking around a bit for other sticks based on the silabs radio and these are the ones I found until now in addition to those linked earlier by russel:

1 Like

I’m looking at similar.

I just found the other topic. :slight_smile:

@wmn79 - based on chipset. Anything with the EM3xx chips should work (specifically, the firmware should support EZSP version 4), and you need a serial device exposed.

1 Like

I can confirm that the ETRX357USB-LRS+8M can be flashed with an appropriate EZSP firmware without the use of any programming hardware.

So, without any guarantees (you might -but probably won’t- brick your device), here’s how:

  1. Download the firmware. I used some random blob someone put on github that at least seemed to have the right name. What could possibly go wrong, right? :smile:

  2. (Install USB-to-serial drivers for the device. Linux will load the driver automatically when you plug in; not sure about other OSes.)

  3. Install a serial port communication app that supports X-MODEM. (debian/ubuntu: sudo apt-get install minicom) Run it and configure it (sudo minicom -s) to use the fake serial port (/dev/ttyUSB0) at 19200 baud 8N1. Disable both hardware (RTS/CTS) and software (XON/XOFF) flow control.

  4. Type ‘AT’ , you should get OK in response. Now type ‘AT+BLOAD’ . The device will reboot into the bootloader.

  5. Change the baud rate in the serial port communication app setting to 115200 baud. (exit minicom using CTRL-A Q, run ‘sudo minicom -s’ again)

  6. Pressing enter in the terminal should now show you a three-option boot loader menu. Choose option 1.

  7. ‘C’ characters will start showing. Don’t wait for this to finish, but start an X-MODEM upload of the firmware you downloaded earlier (use CTRL-A S in minicom). You have 60 seconds to start the upload.

  8. After the upload finished, you should return to the menu. Now select option 2, to reboot into the new firmware. You’re done.



Does this mean that the ETRX357 zigbee stick then works properly with the HASS? Or is this just that you can update the firmware with out the programmer?


I am using the ETRX357USB-LRS with HA and am able to control a hue bulb. I can not get HA to work with ligtify bulbs or the hue dimmer, however not sure if this is because of HA/Bellows or the ETRX357USB-LRS.


Any updates on ETRX357USB-LRS or other Zigbee USB-adapters sold in the EU in combination with HASS?

Do I dare to purchase this one yet as a non-developer and (normally) what I would call a non-Linux user? I’m technical but on a day-today basis I’ used to only work on Windows and with different black-box systems (computer-appliances).

Personally I would prefer to find a plug-and-play Zigbee USB-dongle that ‘just works’ out-of-the-box with HASS.

The ETRX357USB-LRS works fine for me after flashing the alternative firmware as described above. But I would not suggest doing this if you feel unfamiliar with a Linux terminal.
A colleague tried the Bitronvideo Zigbee stick originally designed for the Qivicon base. It worked out of the box and is on sale for 25-30 € in Germany. Maybe take a look at that one?


I got the Bitronvideo stick. Can confirm ZHA and bellows can somewhat communicate with the stick but I’m not able to control my tradfri bulbs.

@h3ndrik - please can I ask what you are running your Bitronvideo stick on, and how you installed it?

I have not had much luck getting it to work with a Pi

I just bought the bitronvideo AV2010/10 stick (i suppose there is only one(?)) a few hours before i wrote, so i’m not an expert. I’m running the stick on a regular linux-computer. Haven’t tried to change the stock firmware. But if the serial communication with the usb stick works it should be the same on a Pi.

What I did:
Had a look at dmesg to verify there is a /dev/ttyUSB0 and added this to my configuration.yaml:

  default: debug
  usb_path: /dev/ttyUSB0
  database_path: /home/homeassistant/.homeassistant/zigbee.db

(database_path has to be absolute)

Flicked the switch of the tradfri bulb six times, observed a short flash, put it close to the usb stick,
went to services in the home-assistant UI and did a zha permit

I can see all kinds of debug messages where zha obviosly talks to the stick. Mixed with final error messages. And I can see some rows in the zigbee.db table for a tradfri bulb.

After that – nothing shows up in HA. Trying to pair the remote (press connect 4 times in 5 seconds) gives similar results.

That’s my current status. My hypothesis is: The usb stick could be okay and the supplied firmware talks ezsp but there are tradfri related (or general) problems in the underlying library(?)

I’m currently fiddling with bellows. But I can’t tell if the light bulb sucessfully joined (despite the error messages) or not. Can’t read or write attributes. But at least I can sniff the communication with the ikea gateway with the ‘dump’ command.
Maybe there, someone with more knowledge about zigbee can tell us what the problem is.

Thanks. On my Pi I don’t even see anything appear in /dev when I plug it in :frowning:

I have a z-wave stick, which I have identified as /dev/ttyACM0, and I wonder whether I inadvertently changed something critical when I was trying to install that …

To summarise:

  • I can see the stick in dmesg when I insert it

    [ 81.097057] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
    [ 81.244773] usb 1-1.3: New USB device found, idVendor=10c4, idProduct=89fb
    [ 81.244787] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 81.244795] usb 1-1.3: Product: Qivicon ZigBee Device
    [ 81.244803] usb 1-1.3: Manufacturer: Silicon Labs
    [ 81.244811] usb 1-1.3: SerialNumber: 000001B9

  • lsusb shows it exists as device 6

    Bus 001 Device 005: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
    Bus 001 Device 006: ID 10c4:89fb Cygnal Integrated Products, Inc.
    Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc.
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  • I have a z-wave stick at /dev/ttyACM0 and a usb/serial port I use for lighting at /dev/ttyUSB0 but can’t find any dev port for the zigbee stick. (There are no other ttyACM* or ttyUSB* entries)

Any thoughts gratefully received! Then maybe I can try and catch you up

Having read a bit more (eg here), my suspicion is that I will need to change the firmware on the stick to make it usable.


Yeah, that seems to be a different usb stick. My USB Stick has has “bitronvideo” on the front and “AV2010/10 // ZigBee USB Radio Stick” written on the back. But I’d not recommend buying this one until it’s confirmed working…
If you have a different one, different instructions apply. Maybe you have to flash a different firmware. Maybe it’s unsupported.


[37551.725035] usb 1-4: new full-speed USB device number 13 using xhci_hcd
[37551.874753] usb 1-4: New USB device found, idVendor=10c4, idProduct=8b34
[37551.874760] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[37551.874768] usb 1-4: Product: BV 2010/10
[37551.874773] usb 1-4: Manufacturer: Silicon Labs
[37551.874777] usb 1-4: SerialNumber: 013752B3
[37551.877255] cp210x 1-4:1.0: cp210x converter detected
[37551.878741] usb 1-4: cp210x converter now attached to ttyUSB0

Hmm - I seem to have bought an older version. The one I ordered sounds like yours (here), but the one that was delivered is plain white on one side and has a serial no, “QIVICAN ZigBee Stick” and a UK address on the other.

Put this one down to experience, I think.

The QIVICON stick in the amazon link is the wrong one. The Qivicon-ones dont work. See:


Mine (bought in a telekom store across the street as part of the set “Magenta Smarthome FUNKSTICK ZigBee & USB-HUB” for 29,99€):

Oh bugger.


I just backed:

I hope this will do all my zigbee, zwave, … needs for