Eufy Camera Integration

Interesting,
I tried your suggestion and conventional template sensor but the syntax I used doesn’t seem to resolve, when I tested it in template editor it resolved to an url but the sensor just gets the value Unknown.

Any tricks/suggestion which formatting to use? It looks like this now:
{{ states.camera.front_door.attributes.data.pictureUrl }}

Edit: Also tried {{ states(‘camera.front_door.attributes.data.pictureUrl’) }}

enjoy

{{ state_attr("camera.garage_camera", "data")["pictureUrl"] }}

states will return the state of entity, not attributes. to access attributes, you need state_attr

btw, I have noticed that template sensor is a bit slow to give you away this information.
in next release, I will publish couple of sensors, is_streaming, streaming_source_type, streaming_source_address and I can definitely add pictureUrl into that list.

2 Likes

that would be awesome!

thanks for the syntax, it still resolves to unkown unfortunately, yes I substituted garage_camera to my own entity.

PM me your entity state dump from Developer Tools

Hi @fuatakgun
I have a T8410 (Indoor Cam 2k Pan & Tilt) which natively supports RSTP.

Having HASSOS, which option do you recommend to install to have most of the sensors present in my cam?

Option1 (Install ioBroker and use Rest API / MQTT to control) or option 2 (Install HA-MQTT Bridge) from the first post?

Thanks in advance.

hey, I have not tested iobroker myself so I will not be able to comment on it.
have you tried the one I am working on? I know it does not support PTZ functions now.

I am actively working on it.

Hi, thanks for the quick reply.
I bought the cam today and was looking at some solution to integrate it into Home Assistant.
I try your integration. Thanks

Just be aware that integration is still having baby steps, far from final

1 Like

Very good,
if I can help you with some tests, I’m available :slight_smile:

@fuatakgun
Is it possible to have the door sensor paused like you can in the app via HA

i did not understand the question, what does pausing mean here in this context?

Edit: i don’t have a door sensor

Of course, just play around the integration and open issues in GitHub if you find some

Sorry
The door sensor has motion sensor detection, it’s handy to snooze motion when needed.
Working in the front garden or when speaking to people at the door.

Could you write a local script to disable it for a given time and enable later on?

The official app sends notifications when it detects a person within a set area. You can go into the app and snooze it for a given time frame.

If it was possible to do this via HA I could have it snooze if the door has been open for x amount of time.

1 Like

As i said, you can write a snooze script, so ti disable sensor for a given time and enable it later on

1 Like

Due to the release of the new version of ibroker 5.1.0, the MQTT broker has stopped working and the

/set

command does not work. I have solved this problem and am sharing my experience. Perhaps some of you may encounter this and this instruction may be useful to you.

You need to use the docker banner/broker image:5.2.0-beta 4-amd64 or docker burnett/neobroker:5.2.0-beta 4, depending on what your processor bit rate is. You can use burnett/neobroker:5.2.0-beta 4.

After installing iobroker, install all 3 packages

We put the WEB, without this package, the integration of Ugan will not work

We install MQTT server\client

We are adding a repository for downloading and installing the ugan-security integration. We do it in turn: turn on the advanced mode, select github and insert the link
Insert this link into the line URL: https://github.com/bropat/ioBroker.eufy-security

After the integration is downloaded, you need to install it

Settings in MQTT serve\client

In the hijacking-security integration, specify the login and password from your hijacking account

After that, launch MQTT Explorer and connect to the MQTT broker Home Assistant, where the topic should appear iobroker/eufy-security/0

Текст на русском (Text in Russian)

В связи с выходом новой версии iobroker 5.1.0 перестал работать MQTT брокер и не работает команда

/set

Данную проблему я решил и делюсь своим опытом. Возможно кто-то из вас может с этим столкнуться и данная инструкция вам может быть полезна.

Использовать нужно образ docker buanet/iobroker:v5.2.0-beta4-amd64 или docker buanet/iobroker:v5.2.0-beta4, смотря какая у вас разрядность процессора. Можете использовать buanet/iobroker:v5.2.0-beta4.

После того, как установите iobroker, ставите все 3 пакета

Ставим WEB, без этого пакета не будет работать интеграция Eufy

Ставим MQTT serve\client

Добавляем репозиторий для скачивания и установки интеграции eufy-security. Делаем в порядке очереди: включаем расширенный режим, выбираем github и вставляем ссылку
Эту ссылку вставить в строку URL: https://github.com/bropat/ioBroker.eufy-security

После того, как интеграция скачается, ее нужно установить

Настройки в MQTT serve\client

В интеграции eufy-security указываете логин и пароль от вашей учетной записи eufy

После этого запускаете MQTT Explorer и подключаетесь к MQTT брокера Home Assistant, где должен появиться топик iobroker/eufy-security/0

Thanks for sharing detailed instructions, what are missing points for you to not to migrate eufy_security integration?

I have a T8410 camera. In the integration, I use PTZ control, turning the LED on and off, tracking a person (the camera turns), rebooting the camera, changing the recording quality, turning the stream on and off. Simply put, I would like to have all the camera control functions available.

You can send commands using integration, there is a service called eufy_security.send_message. you can send any type of command to eufy security ws docker instance