Eufy smart lock support

First I really appreciate the amazing work you and others have done on this integration. Thank you so much!

1)Can you please create/point me to some documentation on how the push notification should be setup and work?

From my phone’s Eufy Security app I have turn on notifications for the lock when logged in as the account I created specifically for home assistant. This setting appears to be specific to the phone. Once I login with my main account I get notifications only to the phone. And the “locked” status does not update as I would expect in home assistant. Not even when I lock/unlock from home assistant. Note: I’m not using your other add-ons meant for video streaming because I only have the lock. Let me know if one of those other add-on is what actually handles the push notifications.

2)Can you update your troubleshooting notes to better spell out where you want the logging to be enabled.

I added it in the “Eufy Security Add-on” because there is the only place I am aware of editing the configuration in Yaml. Putting the yaml there showed WARNINGS in the Supervisor log saying there was no ‘logger’ option.

    custom_components.eufy_security: debug

Lock Model T8520. (Lock with built in wifi)

At time of writting:
Supervisor 2022.07.0
Operating System 8.4
Frontend 20220802.0 - latest

Disregard #1. This appears to be an order of operations thing.
A)You have to have the add-on running with account setup for home assistant.
B)From your phone app using the main account turn on notifications.
C)The add-on started showing in near real-time (same as app) when door was locked/unlocked.

just be sure that you are not using the same account in mobile and add-on.
feel free to raise a PR to improve the documentation.

PR submitted, but I’ll still need you to fill in some of the missing bit.

I have the Eufy Smart Lock D20 (T8501) with built in Wifi. I have set it up in Home Assistant (2022.9.6) with a different account as suggested. I can see the status of the lock but I am not able to unlock or lock it from Home Assistant. This model isn’t listed as being supported, but since most Eufy locks with Wifi are listed as working, I’m wondering if there’s something I can do to get the lock/unlock feature working.

Engage with eufy-security-client repository owner @bropat, when he has time, he can add support for the device after you share the device with him.

1 Like

How did you set yours up? The way your integration works sounds exactly like what I’d prefer to do. e.g see the status in Home Assistant, but not let Home Assistant or anything else unlock it.

I just used the instructions from the Github repo: GitHub - fuatakgun/eufy_security: Home Assistant integration to manage Eufy Security devices as cameras, home base stations, doorbells, motion and contact sensors.

I have 3 T8520N locks setup and they work quite great through the eufy security integration. But HA says this integration depends on the cloud. Is there anyway I would be able to have local control over the locks? Sometimes they get slightly delayed due to the cloud integration. Plus I’m trying to get everything to not be cloud dependent.

This integration is mimicking the app, so it is definitely cloud dependent. Some P2P commands might be sent to your devices directly but they are very limited compared to all functionality.

@anon63427907 I have a stupid question. I’ve just installed the lock with wifi (T8520J11). I already have your integration installed for my Eufy cameras, but I can’t figure out how to get lock to show up as a device to add. How can I trigger the integration to re-scan for devices?

Assuming that you are using a dedicated account for home assistant integration;

  • login via mobile app on that account and confirm that lock is accessible
  • restart add-on
  • reload integration
  • if reloading doesn’t fix it, try to restart home assistant

@anon63427907 Follow up stupid question. I tried uninstalling and reinstalling the integration, and when I try to reinstall, it says host/port is wrong. I’ve left port as 3000 and I’ve tried both “localhost” and my home assistant IP for the host.

When you are issuing these posts, please share logs from add-on, always

I was able to get past the original error (the add-on had turned off).

Now I get errors with the integration not being able to start listening in a timely manner.

This is the error in the add-on log.

2022-12-11 19:38:49.264  INFO  Eufy Security server listening on host, port 3000 
2022-12-11 19:38:49.620  ERROR Response data is missing 
  code: 0,
  msg: 'Succeed.',
  data: undefined
2022-12-11 19:39:05.792  ERROR Response data is missing 
  code: 0,
  msg: 'Succeed.',
  data: undefined
2022-12-11 19:39:18.386  INFO  Client disconnected with ip: port: 35102 code: 1000 reason: Normal Closure 
2022-12-11 19:39:23.634  ERROR Response data is missing 
  code: 0,
  msg: 'Succeed.',
  data: undefined

@jake_moore I am having the same issue where my integration is not able to populate my lock as a device. I am running HA os.
My log for the eufy addon looks like the image attached.

Add on is able to connect to the devices but only the alarm/chime shows up as a device in the integration. I have a separate account and I can see the devices on the eufy app for that account.
I would like to know as well how to get those devices manually populate.

I have the T8506 lock, it shows up in HA, but no lock/unlock options. Only debug sensors

Same. There is a support request on GitHub.

Hi @anon63427907, thank you for working on this! I wanted to know how can I request to get Eufy T8530 added to the list of requested integrations. Or are you already planning on working on this lock ? Thank you!

So I can safely assume there is no support for the Lock/Unlock feature for the T8506 currently?!