EWeLink Integration request

I would appreciate the integration of EWeLink wit HA.
eWeLink is a smart home control APP that can control all ITEAD home automation devices and cooperated products. It allows you to remote control and manage your favorite smart devices
See https://www.itead.cc/wiki/EWeLink_Introduction

Would be nice to link straight with ewelink to avoid having to flash.
I am using this switch “Lx-wifi-03o” https://fccid.io/2ANKOLX-WIFI-03O/User-Manual/User-manual-3554904


I second this request. The only way to use ITEAD (Sonoff) devices is to flash them with third party firmware and use MQTT. Native support would be nice.

And so do all the other people who’ve posted this request already :slight_smile:

And it will decrease the load of Sonoff Cloud storage :wink:

+1 vote…

Flashing Itead Sonoff devices via original OTA mechanism!!! WORKING!!!
After a lot of search, I could find this excellent project to change the firmware to this switch lx-wifi-03o without soldering nothing !!! I changed the firmware to 3 of my devices today and they are work ing perfect.

This is a script to update a Sonoff device from the stock firmware to Sonoff-Tasmota purely over WiFi.
I used my Windows 7 64bit and Python 3.5

Have you tried with lx-wifi-03o 1Gang touch switch yet?

I’ve tried to flash lx-wifi-03o 1Gang via OTA several times but no success.

** This application should be kept running and will wait until connected to the WiFi…
…Current IPs: [‘’]
~~ Starting web server (HTTP port: 8080, HTTPS port 443)
Using selector: KqueueSelector
Traceback (most recent call last):
File “./sonota.py”, line 734, in
File “./sonota.py”, line 730, in main
File “./sonota.py”, line 660, in stage2
File “/Users/chinh/Library/Python/3.6/lib/python/site-packages/tornado/tcpserver.py”, line 144, in listen
sockets = bind_sockets(port, address=address)
File “/Users/chinh/Library/Python/3.6/lib/python/site-packages/tornado/netutil.py”, line 163, in bind_sockets
PermissionError: [Errno 13] Permission denied


Hello @chinhhut, I updated these two models of boards:
Lx-wifi-03o (US/3ch) = 3Gang
Lx-wifi-03o (US/4ch) = 4Gang
I a few weeks, I will test the models of 1Gang and 2Gang

Check this out:

ewelink now supports LAN getting this integrated into Home Assistant would be great since the newer firmware does not seem to allow flashing of firmware thanks

did u find anyway to add ewelink devices to hassio?

not Ewelink directly but did figure out how to control the device locally on Home assistant was a bit involved but working great I wrote a how to on this Setting up EweLink controlled device ST-DC1 with OEM Firmware to work on local network