External access with MyFRITZ service?


Is it possible to have access to my home assistant via the FritzBox service MyFritz?Instead of ie. DuckDns?
It is a DynDns service from AVM (the FritzBox manufacturer) which is already integrated in the FritzBox.

Has anybody a working solution?

Thank you

Duckdns and myfritz serve the same purpose: name resolution for dynamic ip-addresses, so yes, this should work.
You would still have to configure everything else like you would with duckdns, like port forwarding and what not.

I’m using nabu casa so I cannot provide a “working solution”

Haven’t tried it, but in general it should work. At least for IPv4. If you also have IPv6, your MyFRitz-Domain will point to your FritzBox. To get to your Home Assistant with IPv6 you need something like homeassistant.yourfritzdomain.myfritz.net. Not sure how to do that. But I guess it’s good to know that this is a problem that has to be addressed if applicable.

myfritz DNS name always points to your FritzBox, regardless of IPv4 or IPv6. You Need to use an additional port forward at your box to route incoming traffic to your (internal) HA instance

I don’t know if AVM made some changes, but the last time I have attempted to do this, adding an IPv6-Freigabe did not result in port forwarding, but instead just punched a hole into the IPv6 firewall to allow external access to the global IPv6 address of the related host. Which makes sense. With IPv6 NAT isn’t really a thing after all. And because of that, accessing the MyFritz domain via IPv6 resulted in connection timeouts since the FritzBox, correctly, isn’t listening on the port that has been opened. Connecting to the global IPv6 address of the host worked. But that’s not where the MyFritz-domain points to, as it already points to the FritzBox itself. Hence the requirement for the hostname in addition to the domain.

If AVM has implemented some sort of fake NAT to make things behave like if it was IPv4, then that’s nice to know. But exactly because of this limitation (at the time I have tried it) I just bought a domain + wildcard-certificate get both IPv4+6.

Anything new about this topic?? :slight_smile:

Iam using my Fritz for remote control without any problems

1 Like

yeah… sorry
days after i posted my question i got it to work

much more easier as i thought in the first try!

The only thing is

  • i switched on my https access to the fritzbox
  • i configured all ports and everything in HA to access (lets encrypt e.g.)
  • i switched off my https access to the fritz because i don’t need it and i don’t want it… if i wanna use my box from outside i take vpn

after some weeks (6-8 i guess) my HA access break up because of the invalid certificate
than i have to manualy do the same steps like switching on https, restart lets encrypt e.g. e.g.

anybody some better idea to my pretty not smart conclusion?

If you are using a vpn you dont have to use a certificate

i am trying to enable access homeassistant for remote access and i have got fritz box.
i am strugling on configuring the system to work.
Can someone help me describing the steps to follow ?
I opened the port TCP 8123 on Homeassistant and fritz assigned an external IP address. Such IP address is different from the one that DuckDNS capture ( router one). I understood i should not use duckdns. how i should move forward? thanks for your help

I have to forward your 8123 port to port 80 and than you can use your my fritz adresse

so you added a port 80 in homeassistant application in the router
and did you use duckdns in homeassistant or you removed the addons?
Did you activate DynDNS in fritzbox?
thanks again

You have to set your homeassistant 8123 port to your external 80 port than you have to visit your my fritz link you can get it in your fritzbox settings

I installed fritzbox laboratory OS as it supports wireguard VPN!

Install the wireguard app on the phone, scan a QR code from the fritzbox setup, done!

optionally white list your own wifi in the WireGuard app and tell it to autoconnect to the vpn in all other cases, and then you can use the HomeAssistant app wherever you have an internet connection.

Security wise its an opensource VPN to your home, so nothing gets exposed to the internet.

Can you show me how you did this, I can’t figure it out.

Thanks for the effort

sure: check out the list of compatible devices here

then follow the install instructions.
Basically boils down to:

  1. identify device
  2. download “lab” firmware (avm term for newer firmware with new features such as wireguard that arn’t in wide release yet)
  3. go to you router web interface
  4. find the update firmware page
  5. upload the downloaded lab firmware
  6. wait for the device to restart.

then setup wireguard VPN: Head to the FRITZ!Box user interface and select “Internet > Permit Access > VPN (WireGuard)”.
See also WireGuard: VPN has never been so easy | AVM International

If you still want to use myfritz DDNS then read this