Ezviz camera discovered but unable to connect

I have installed the Ezviz integration (EZVIZ - Home Assistant) and configured it. The integration sees my camera and shows it with an configuration button.

With that button I’m able to enter an username and password. That username should me admin and the password is the security code which is found at the camera.
When saving I get an error: ‘Invalid hostname or IP-Address’.

When restarting HA I get an notification about this new discovered device and in the ‘login screen’ I can see the IP-address of the camera.
I also tried to use the use the manual setup using the ffmpeg platform:

  - platform: ffmpeg
    name: Camera 
    input: rtsp://admin:***@

but that is also not working.

How can I solve this problem? Is this happening because I use Nabu Casa?

1 Like

I have exactly the same error whereas before the integration worked perfectly.
For my part I do not use Nabu Casa

Has anybody managed to get this resolved? I just installed the integration (for the first time) and it is not working for me either. Thanks.

+1. It stopped working some days ago. I wonder if there has been a firmware update on the camera?

+1. It stopped working some days ago.

It started with one camera and now all my camera’s have the same problem.

Found this solution on GitHub that solved this for me:
“How to enable RTSP
Step 1: Ensure the camera and your phone are under the same network Step 2: Open EZVIZ app, tap the profile icon on the top left > Settings > LAN Live View > Start Scanning Step 3: Tap the camera you need to use, input the password, which usually is the 6-digit capital letters code on the white sticker of your camera Step 4: Tap the gear-like icon on the top right > Local Server Settings > enable RTSP”


Thank you.
It’s working for me

Thank You!!!

I have the same problem on one of my 2 cameras, a TY1. It was working fine but stopped a while ago but unfortunately the fix above didn’t work for me, I see the stream in the Ezviz app live view but HA still gives the Invalid hostname or IP-Address error when trying to configure it :frowning:

Seems like solution, working here as well. Thank you!

+1 working for me too - fantastic!

Doh! I had missed the last step! “Tap the gear-like icon on the top right > Local Server Settings > enable RTSP””
It is now working again. In the meantime my other camera stopped so they must be defaulting RTSP to off in the latest firmware updates

The solution worked, thank you. At first I couldn’t see the option, I had to update the APP

Thanks for the tip - however I just tried this on a new DB2 Pro and when logging in it says “Device does not support live view” um… running V5.3.3 build 220725. Is this still working for you?
Edit: I can also interrogate the DB2 Pro using EZVIZ Studio in advanced mode, but can’t see any RTSP toggle. Um.

1 Like

I have the exact same problem, app says “Device does not support live view” and there’s no option for rtsp in Studio.

According to this thread EZVIZ Releasing New Doorbells DB2 and DB2 Pro | IP Cam Talk DB2 does not support rtsp streaming, which is a shame. I guess there’s no way to capture the feed outside official apps?

1 Like

Thank you!

Wonderful! This solved my problem as well! :slight_smile:

Thanks! That did it for me!

Had the same problem, this solved it. Thank you!