EZVIZ Cameras RTSP Stream Not Working

Hi there,

I’ve recently started to setup our Home Network with Home Assistant. We currently have 7 outdoor cameras that are all from Ezviz (specific model being the C3TN), but each time I try and open the video stream from the “Media” section on the default panel it seems to not load at all.

A screenshot to depict what I see:

  • When I click on one of them the stream window glitches and moves around, obviously not as it should

I did try and do some self-debug with possibly using the WebToRTC plugin and some other suggestions I found off of the forums, but I’m just a bit lost. If there is anything that anyone could think of that I missed?

After last firmware update to 230113 rtsp no more work

I noticed my two CTQ3W cameras’ RTSP stream has stopped working recently. All my other non-EZVIZ cameras’ RTSP streams are working fine, so I know the issue is an EZVIZ issue.
The firmware on the two EZVIZ cameras is 20230302.

1 Like

Any luck with RTSP on these cameras? I opened a ticket with EZVIZ, waiting for a response.

1 Like

Just as I posted… I found the solution! so in my case here is is a Howto re-enable RTSP after firmware upgrade:
My apologies for using a idiots guide in the step by step (I am one). They really make it hard to get what you need. Anyway:

SHORT VERSION
EZVIZ IOS app–>Profile–>Settings–>Lan Live View–>(Start scanning)–>Select Camera–>Login–>Settings–>Local Service Settings–>Enable RTSP

Idiots Guide (with Pictures)

  1. Using the EZVIZ mobile app (in my case the IOS app
  2. Open the app to where you see all your cameras
  3. Go to Profile (on IOS its an icon) top left. on iPhone app its an icon
  4. Go to Settings
  5. Go to LAN Live View and start scan. Your cameras will show… eventually in you are on the same LAN. I kept dragging the screen down to refresh. (don’t use the Search button… IOS bring up number keypad and there is no way to type the IP address)
  6. Select a camera. sometimes it will open the camera… sometimes it will ask for a password. In my case I have four camera 1 open the other 3 i had to figure out the passwords. the Default password is the code on the actual camera sticker. (you can also view it from the normal about camera page in the app)
  7. The app now shows the current feed. Top right is an Icon for Settings. Click that.
  8. Click on Local Service Setting and enable RTSP and Save.

Finally:: I recommend disabling auto firmware update… “if it ain’t broke… Don’t fix it”!






20 Likes

@antoweb @dwightus
See my response… hope it helps. I tried a lot of solutions including the Windows Studio one in the end the solution was simple.

For the SEO, this solved my problem, thanks!

This is the way! Thank you!

Thank you for this clear solution! Been having the issue for a while now, so happy that it’s solved :smiley:

Funny enough the “Local Service Settings” options is no where to be found on my device. Only the AP option is available…

1 Like

I think its the app on your device, is it Android ?

Hello all, my first message.
I just joined to say biggest THANK YOU to @Ndini_Wenyu !!!

I have 2 Ezviz cameras linked to my Synology NAS that suddenly stopped working, and have been looking for information trying to understand.
Thanks to this clear thread, they are both working again!

You made my day! Well, I won’t never know how one of the fishes on my pond got killed out of the pond (the reason why I went to check recordings and realised cameras were not working), but at least they work again for the next one :slight_smile:

Regards

Was in contact with EZVIZ support and they gave me the following instruction:

  1. Download and install EZVIZ PC Studio (available for Windows PC only), here is the website link: Download Center - EZVIZ Support ;

  2. Make sure your camera and PC are under the same LAN;

  3. Configure the advanced settings as follows:

    3.1 Go to the root directory of Ezviz Studio in your PC and find the folder named “config”
    3.2 Copy the file named “AppConfig.ini” in the folder of “config” to desktop. Open “AppConfig.ini” in desktop
    3.3 Add the following command which highlighted in yellow in “AppConfig.ini” and save before exiting:

    [LocalOperation]
    Show=1

    3.4 Copy the “AppConfig.ini” file in desktop to folder of “config” and overlay the old one. Refresh the device page in Ezviz Studio or reopen the Studio, then you will see the “Advanced”.

Advanced setting should be visible now next to your device, under “All devices”

  1. Then click Advanced—Network—NAT and confirm UPnP is enabled, then Apply.

Worked :wink:

1 Like

You saved me, many thanks.
I was going crazy looking at settings in HA, my network, etc…

Anyone else having the issue that the rtsp option turns off after a week or so only on my C3X but its also the only one that i needed to turn on rtsp in the local lan view settings my other 4 ezviz cameras never had these issues but also didn’t need to enable rtsp on them. I really dont get this feature :man_facepalming:

Yes I’m finding rtsp turns off again after anything from 1 day to a week. It’s incredibly frustrating, if I can’t fix it soon then it’s coming down

My c3x is the only ezviz having this issue when the camera reboots the option rtsp turns off I didn’t find a fix for it. The strange thing is i have 3 other ezviz models same look cheaper c3n and husky or something like that they dont have this issue didn’t even need to turn the option on

Mine is also the c3x :frowning: if I find a solution I’ll be sure to post it. I might explore downgrading the firmware

1 Like

My EzViz just stopped working on HA, so uninstalled, reinstalled and setup as per instructions above. No errors.

However, I am not getting any video feed? No errors at all either, just a blank box.

Any ideas?

Stupid question - do you need the EzViz cloud subscription for this to work as my freebie time has run out.

Quick update on my ezviz issue with rtsp self deactivating. My logic was one of two scenarios:

  1. It’s self deactivating (since it’s somewhat random this feels odd, if it was local it would probably be firmware scheduled or after reboot)

  2. It’s phoning home and being deactivated remotely.

I figured 2 was more likely since, ya know, corporations, so since I’m using frigate and everything is local I’ve restricted the device from accessing outside the local network and the problem has resolved. Aaaand that’s ezviz ruled out for the next purchase.

1 Like