EZVIZ Cameras RTSP Stream Not Working

Thanks for the heads up. Just turned off auto update as I heard new versions are causing issues. All my exterior cams are ezviz and depend on them

Thank you! Fixed my issue.

You’re a genius

Hello, anyone know what to do if my Ezviz CP4 door camera android app don’t discover any cam in LAN Live view? When I put manual IP, port, admin and key (password) I get error 330007.
Regards.

4 Likes

I’m having exactly the same problem with my C3N camera - wrong username/password or 330007 error when trying LAN live view.

You need to type “admin” as username and verification code (6 digit code written on sticker on camera) as password.

I’m a bit of a rooky trying to get my 3 Ezviz camera’s feeds in HA. I’ve followed the steps posted by @abelone91 here and I think they should all be locally accessible. However, no image appears in the Ezviz integration on my dashboard. Should I manually configure anything in the Ezviz integration, like input the rtsp links somewhere?

Hey! Same problem here, I have tried all I know, even modified the streaming type from H.265 to H.264 in EZVIZ studio, but it still doesn’t work.

I don’t know what more I can do.

I have 3 C3N EZVIZ cameras, and no one’s working. I continue thinking it’s an EZVIZ cloud problem but I have contacted with them, and they said all was working fine.

Hope someone sheds some light.

Unfortunately that don’t work. I contact support and They also don’t help me. My device don’t show also it’s wifi subnetwork EZVIZ…

It seems that Lan Live View does not work for all cameras. This is the case for me:
Cam EZVIZ C3X V5.2.5 built 231016 and LC3 V5.3.4 built 230629
EZVIZ PC STUDIO 2.2.1
Ezviz Iphone App 6.1.0
1/ In the iPhone app, / Configuration/ Lan Live View, on the same WiFi network, does not work. No cameras found.
2/ With EVZIZ PC STUDIO, the modification in appconfig.ini ([LocalOperation]/Show=1) does not work: the extensions do not appear).
3/ In Line Live View, if you click on the magnifying glass, you can enter the IP of the camera, the port (8000) the account identifier (admin) and the password (Verification code on the label of the camera).
The only problem as far as I’m concerned, in the French version at least, is that the numbers in the IP address can only be separated by a comma whereas a period is required! New despair…
4/ The solution consists of a) Create an address in the iPhone address book including the IP number (with dots) as the address entry and b) by pressing the area, copy and paste with this address.

And there, my little gases, the system very quickly recognizes the camera and by clicking on it you have a menu to activate RTPS. To safeguard. Miracle, HA now recognizes the camera.
Finally:
1/ Nothing to do with Ezviz PC studio
2/ Manually enter the camera data into Line Live View, overcoming the comma bug by copying and pasting.
3/ Activate RPTS
Thank you EZVIZ

1 Like

Hi JCP,

I don’t get your part 4. Creating an address is the address book? Can you be more specific?
I tried adding the camera manually, but it still says ‘connection failed’.
Can you help me out? I have the BC1C.
Thanks!

Thank you !

I spent hours looking for that setting a few nights ago. Your instructions ( I especially love the SHORT VERSION) took me straight to it.

Model C6CN

Ciao , per caso è riuscito a risolvere il problema 330007 ? Grazie

Could someone share the path settings ?

image

Could you share the RTSP path you are using in Synology Survailance? For the love of god - I can not make it work (after enabling RTSP as shown above)

rtsp://admin:[email protected]:554/H.264

Here is my VLC log output

qt debug: IM: Setting an input

main debug: connection succeeded (socket = 41)

main debug: net: opening 0.0.0.0 datagram port 9478

main debug: net: opening 0.0.0.0 datagram port 9479

satip error: Failed to setup RTSP session

satip error: Failed to teardown RTSP session

main debug: net: connecting to 192.168.178.72 port 554

main debug: connection succeeded (socket = 41)

access_realrtsp warning: Cseq mismatch, got 1, assumed 0

access_realrtsp debug: rtsp connected

access_realrtsp warning: only real/helix rtsp servers supported for now

main debug: no access modules matched

main debug: dead input

qt debug: IM: Deleting the input

main debug: changing item without a request (current 7/8)

main debug: nothing to play

I have the same problem, when I scan, cant find my camera and when use the magnifying also cant find and gives me the 30007 error

Hello, thank you for sharing your solution, I have a problem regarding scanning LAN devices, since when it asks me for username and password, when entering them, they tell me that the credentials are not valid, which is strange, because I am 100% sure that they are fine

I have the same model, and i cant fix it,i have a problem with te user and password when im scanning the camera

same problem it asks me for username and password. if I enter the same password used to activate RTSP it always gives me an error
Error