Failed add tuya integration

Home Assistant 2021.6.2

When tried to add tuya integration, it shows popup:
Aborted
Failed to connect

Is this integration currently not working? Any workaround?

Thanks.

1 Like

I also experience problems with an existing tuya integration: since this evening it’s not responding anymore.
Devices can still be controlled with the android tuya app though…

Same with mine tuya integration seems to be borked but app is still usable also looked on there Facebook page people reporting tuya is down pretty much globally but no response as of yet from the company

Same here. Awoke, today, to find that I can only control my Tuya devices directly through the Tuya app. Home Assistant is still showing the Tuya entities and allows me to change their settings but the settings are not going through to Tuya.

link?

(app works of course, because it goes direct… sigh)

WARNING (SyncWorker_15) [tuyaha.tuyaapi] control device error, error code is DependentServiceUnavailable

(incase someone is searching the forum…)

This is from Tuya’s support chat-bot:

Dear user,
From 22:24 on June 10, 2021, UTC, your device, App, or third-party voice control may be unavailable due to the failure of the AWS data center network and services. We have worked with AWS to handle this issue and it has been resumed.
If you are facing this situation, it is suggested that you can try again later. You can raise a ticket by tap “Me - FAQ & Feedback - Feedback / Suggestions” in the APP.
We are very sorry for the inconvenience caused, and thank you for your support!

1 Like

Indeed, working again over here!

Thanks @mark_wiese for this information. :+1:

1 Like

agreed - integration seems to be working now

Yep, back online, here, too.

Imagine that you have critical devices with tuya…
I had only 1 light that I needed and it’s even more clear why I don’t want at least possible in the cloud!

1 Like

Yep, cloud dependency hell.

anyone tried tuyalocal, I checked the github it seems to complicated to setup, there are many manual configuration?