Failed to deliver message: <EmberStatus.DELIVERY_FAILED: 102>

Aaaand I forgot the question I wanted to ask all of you LOL!

Some of you mentioned about changing the channel on your ZHA coordinator. I saw this option under network to change the Channel directly. Can I do it here? I did a bit of googling on how to change the Zigbee channel, and none of them mentioned about doing it here. It’s always some long convoluted steps that always end with “this will break your network and you have to reset EVERYTHING!” lol

I changed my channel on the screen you indicated. You might first want to “Download diagnostics” from your main Zigbee device (click three dots to the right and download diagnostics there). Look at the file to see what channel has the least utilization. I’m currently on channel 16 and while I still get the occasional DELIVERY FAILED: 102 error, it’s not too often that it’s a problem. Good luck.

1 Like

Hi @ecchodun, thanks for your reply. I downloaded the diagnostic from my SkyConnect (Zigbee Coordinator under Device), and looking through the content, I can’t seem to find anything that refers to different channel utilization. I most likely don’t know what to look for exactly; still new to this whole thing :smiley:

Mind pointing out where in the text file I should be looking at?

It will look like this -

“energy_scan”:
“11”: 28.30261646762903,
“12”: 25.74050169409602,
“13”: 43.057636198227904,
“14”: 46.26944564832987,
“15”: 59.15797905332195,
“16”: 46.26944564832987,
“17”: 68.14622793558128,
“18”: 98.43344238842926,
“19”: 99.363464769115,
“20”: 99.06269548719737,
“21”: 98.93395819824867,
“22”: 75.96022321405563,
“23”: 65.26028270288712,
“24”: 9.713248103580147,
“25”: 17.086630587133605,
“26”: 59.15797905332195

Those are channels and the second number is utilization. Lesser is better.

1 Like

Oh I downloaded the wrong diagnostics LOL! I was staring at the diagnostics of the coordinator itself, but instead, I was supposed to download the diagnostic for the whole Zigbee network under Integration Entries. Now I see it.

Mine looks like this -

“energy_scan”: {
“11”: 91.05606689948522,
“12”: 97.7033852118351,
“13”: 97.39286236923465,
“14”: 89.93931580241996,
“15”: 97.97769123383605,
“16”: 97.39286236923465,
“17”: 98.62178092672917,
“18”: 97.97769123383605,
“19”: 97.39286236923465,
“20”: 52.75969252664325,
“21”: 52.75969252664325,
“22”: 78.25348754651363,
“23”: 82.35373987514762,
“24”: 73.50699819621309,
“25”: 92.95959997754716,
“26”: 98.21983128611214

So if lesser is better, then should I go with channel 20 or 21? I’m currently on Channel 11.

That is correct. It may take a bit for things to switch over completely (about an hour). Many of those numbers do look high so you could have some wifi interference. You might need to switch your wifi router channel as well.

1 Like

Awesome! Thank you so much for your help. Crossing my fingers in hopes that the new channel will help fix some of the issues I’m having. Will update here on how things goes.

Hi @ecchodun, unfortunately, and surprisingly, changing the channel to 20 seems to end up being worse for me. Not sure if this is related or not, but now all of my signal strength between devices seems to have dropped lower. Their LQI readings are quite lower than before. Looking at my network visualization, previously I had a couple of green lines and mostly yellow with a couple of reds. Now it’s all reds with two yellows.

I am somewhat convinced that the root of my problem might be the signal strength that the SkyConnect provides and the reliance on the end devices having to connect to the routers while the routers themselves don’t have a good connection to the SkyConnect to begin with. I need to re-verify this, but I believe with the Sonoff Dongle, the overall interconnectivity of the devices is much better, thus resulting of course in a more stable and reliable environment.

Is there a way to “hack” and maybe add some kind of antenna to the SkyConnect to improve its signal range? If not, then I might need to move back to the Sonoff Dongle.

All I know is one of these recent updates broke something.

My network is solid as a rock and I’ve had zero issues for many many months. I invested considerable time tuning my network so it always works, don’t touch it, and that is no easy task. Took me a long time to finally learn that constant fiddling with the setup, even when it works well, is unnecessary. So, it was near perfectly reliable and operational, but reflecting back, one of my failures is installing every single update. Unless something is broken or I need a new feature, I’ll update twice a year or so.

Starting a month (weeks?) ago the same error appeared as the rest of you are finding. I have not started debugging as I assumed one of the devs borked and update and it would be fixed soon, but here we are almost a month later and my network is still half functional.

Pfffft. Kinda irritated over this.

2 Likes

Usage on all your channels seems very high (the second number is a percentage). Here’s mine. ZHA is on channel 20, Z2M on 15:

"energy_scan": {
      "11": 80.38447947821754,
      "12": 84.164247274957,
      "13": 88.70042934643088,
      "14": 65.26028270288712,
      "15": 31.01324838787301,
      "16": 4.15070068297423,
      "17": 12.244260188723507,
      "18": 12.244260188723507,
      "19": 70.89933442360993,
      "20": 59.15797905332195,
      "21": 6.011489450827149,
      "22": 6.011489450827149,
      "23": 8.631361812931262,
      "24": 6.011489450827149,
      "25": 1.1664179210724432,
      "26": 62.257682586134884

This may indicate interference. I see you are using a USB extension cable - is it the one that came with SkyConnect? I replaced that with a 2m one. What wi-fi channels are your neighbours using? If they have their router on auto it may change from time to time.

I’ve noticed no difference after recent updates.

Edit: And I know this is a bit of a cracked record, but three routers is not going to get you very far. Zigbee doesn’t depend on signal strength (always weak); it needs many, many connections so that messages can take alternate routes. Here’s my map:

Another edit: I expect you’ve looked at all the guides:

Hi @Stiltjack, thank you again for your reply. I am using the USB extension cable that comes with SkyConnect, but I also used a separate USB extension cable that I have to move it further away from my server. I don’t, however, want to move it too far away from my server because I don’t want it to be placed somewhere that is visible to others. I still personally think that while the SkyConnect might be a better Zigbee coordinator, the lack of interference shield like what the Sonoff Dongle-E has makes it vulnerable to interference, especially in very congested area like where I live.

My neighbors’ wi-fi channels are all over the place, and there are probably hundreds of them around me, mostly extremely weak but just enough to be picked up by my unifi router. I live in a duplex style housing complex, and each unit has 3 floors, so everyone most likely has a router + 2 or 3 access points to cover the whole house, and they’re all probably blasting at full strength.

After my last reply to your message, I’ve decided to purchase 4 more routers (third reality smart plugs) and placed them various areas around the house, and honestly those routers, along with the Sonoff Dongle-E, have made the connectivity with all the other end devices significantly better, so I definitely agree with you that more routers and repeaters are required.

I still do think that these Sonoff or Ouvopo motion sensor end devices (both are eWelink MS01) are finicky and very prone to doing their own thing. I need to find much more reliable end devices or switch to BLE motion sensors.

Update on this problem–

Turns out that updating the firmware on the Inovelli Blue 2-1 Switch firmware from version 2.0 to 2.15 fixed this issue. (Still using Channel 25) Needed to use ZHA Toolkit to accomplish this, but otherwise we’re back in business and working well!

I just got few new plugs and installed an IKEA Trådfri Motion Sensor to control the lights in my garage. The sensor works fine, but the plug gives this same error message. I changed the plug, but it didn’t help.

What I find strange is that HA receives the power consumption data from the plug, but gives an error message when I try to switch the power off.

Now all my ZigBee devices have become Unavailable. Restarted HA, powered Off/On the HA Green box, but no change.

Is this a common problem?
Any solutions available?

image

@aquariuz23 i picked up some third reality motion sensors with AAA batteries. They play very well with my skyconnect in ZHA.
Most of My Aqara sensors lose connection frequently.

There is normally two-way communication: plug sends (it reports) its power usage data to the dongle (that route works in your case) and the dongle sends commands to the plug to switch on/off (which apparently doesn’t work). Might be a case of router mesh shortage.

I have the same problem of random failure to fully execute an automation. For example, an automation that opens 6 blinds using Aqara roller blind operators will execute and occasionally one blind (not always the same one) will fail to respond. Further commands to that blind then continue to produce the Ember Delivery Failed 102 result while other devices continue to work. A nuisance but at least I’ve found a way to avoid doing an HA re-start! The 3 dots menu beside ‘Configure’ on the Zigbee integration page has a ‘Reload’ option which is quick and restores everything to working order. Doesn’t appear to be a zigbee network problem. More like something in either the coordinator software or the ZHA integration. Looking forward to the professionals finding the glitch :thinking:.

I just started using home assistant recently, so I’m very new to everything, but I just started getting this error message today when I tried to execute a script. The script will not run now, and I don’t know how to do debugging and coding, so I guess my home assistant is broken.

I reloaded the zigbee integration, but that didn’t do the trick, so I then restarted home assistant, but it’s still giving me the same error. Ugh.

Update: it’s been about 10 minutes since I reloaded the sigbee integration and then restarted home assistant, and now the script is working fine again.

For all here, sory i did not write sooner. But it hase been few months that i changed my zigbee channel, repair all battery devices, and everything is working like it should.

I’m also concerned about this issue.
Running :

  • Core 2024.4.3
  • Supervisor 2024.04.0
  • Operating System 12.2
    No 2.4GHz overloading. Channel seems to be rather free of other interferences.

Everything was working fine one week ago.
What I did :
Added an Ikea Styrbar and an Ikea Tradfri white bulb.
I succeeded to pair with these two devices.
Shortly after : no actions could be done on them. And the error message “Failed to deliver message: <EmberStatus.DELIVERY_FAILED: 102>” is shown on HA.
After that : lost one of my Zigbee connected plug.

Is there something I can test to help debug that issue ?