Failed to start addon - Mosquitto broker

Unfortunately that is the case.
Apparently there is no solution yet.

Same issue here since today. My whole system at home is based on home assistant… I can’t leave it like this

I was downgrading to 2021.01.7,and I have a snapshot at this version.
So when I rollback to 2021.01.7 and restore addons from snapshot,everything works fine.
Don`t forget disable supervisor autoupgrade.otherwise problem will be back.

Is there an easy way to do this on a Synology docker installation ?

How do you do that ?

Ok from this post, I did the following

  1. ssh into my synology
  2. sudo docker exec -it hassio_supervisor bash
  3. vi /usr/src/supervisor/supervisor/misc/tasks.py
  4. search for RUN_UPDATE_SUPERVISOR
  5. delete that line
  6. save and quit
  7. restart supervisor from within hass gui

If there’s an easier way please post ! Fingers crossed this works…

Edit:
After making this change, I had to disable the ‘auto-update’ option in each add-on before they would load properly

I’ve removed two lines and it seems to work:

Currently I’m not updating anything until my RAM extension is delivered. This I need to run the HA VM directly on a Synology and hopefully then this mess will stop.

Thanks Bluejay, that did the trick for me. Also I have removed the “jobs.json” file that I had created into hass.io folder in order to enable updates.

The jobs.json file was just one line:

{“ignore_conditions”: [“healthy”]}

Now, my server won’t update anymore, I’m stucked and happy with my actual old version until docker is updated on my syno !

@anschein I’m in the same state - did you ever get node red to come back? I’ve gotten just about everything else back up but node-red is kind of essential.

Funny thing… i have HA installed on my Synology and i had to restarted my Syno because i’ve had unusual constant big CPU load (appr.50%, unknown reason, not connected with HA at all…), after restart all worked fine in HA, except SQLite add-on couldn’t be started with pretty much same error.

An error ends with

exec: “/dev/init”: stat /dev/init: no such file or directory": unknown

After some tinkering all works fine again, i have no clue why… :face_with_monocle:

Now, things i did:

  • joined beta channel and updated to latest beta supervisor, restarted supervisor - no luck…
  • i tried @BlueJay’s suggestion to disable supervisor update (dont’ ask me why…). Restarted supervisor, all ok.
  • i uninstaleld SQLite add-on
  • i enabled supervisor auto-update again, but now i couldn’t restart supervisor anymore, it said error:

WARNING (MainThread) [supervisor.jobs] ‘Supervisor.restart’ blocked from execution, system is not running - CoreState.STARTUP

  • i leaved beta channel and went back to xx.7 version of supervisor manually in docker’s terminal. Supervisor now restarted ok.
  • installe SQLite add-on again. It started and it works again!
  • updated to latest xxx.9 supervisor, still works.

Now go figure what was wrong… :open_mouth:

I have nodered in my snapshot,So only restore the nodered works for me.

Yes I did that from this post.

You could also just add a # in front on the updater line. Makes it a little bit easier to re-enable.
I’m wondering when we’ll see a real solution though. Do we really need to wait for Synology to update the docker package?

I believe so ?

Or else as @fridolin suggested, run hass in a VM.

Docker is so lightweight though - that’s why I’m persisting with it…

Is the issue a Dockers version issue? Or is it a “bug” in the supervisor?
Can’t the developers here @ HA do something about this issue?

Btw I can recommend everyone to request the updating of Docker through this form:
https://www.synology.com/form/inquiry/feature
(Mailing to [email protected] directly might also work.)

Syno runs an older version of Docker, which I believe is not supported by HA

And supervisor/HA does have a habit of breaking things with each update - but it’s free software so that’s fair enough :slight_smile:

worked for me as well… thanks for much for sharing the workaround.!!!

Has anyone braved the current Supervisor release (2021.03.4) ?

I’ve marooned myself on 2021.01.7 and all is working, so I’m loathe to change !

Same problem, solved with the same workaround. If I update the superivor all work for few day but after taht MQTT goes down. There is any solution?

thanks,works for me .

2021.03.4,docker run as -v /share -v /data -v /dev -v /ssl and Entrypoint /init

2021.01.7,docker run as -v /share -v /data -v /ssl and Entrypoint /init