Failed Update of HAOS from 12.2 to 12.3?

Hi there!

Got an update prompt from HAOS 12.2 to 12.3. Hit update and I think it failed, giving me what it appeared to be a fault in a sequence of error messages (yes, I didn’t save it, just issued an acpibutton shutdown :frowning: ) (running in VirtualBox).

Started the VM again and this is what I saw:

It rapidly loaded Slot B and the console said Home Assistant 12.3.

I did a shutdown and loaded slot A just to see what it was and… it loaded 12.2.

I don’t know that to do… Should I use the 12.3 version? Is it reliable? How do I purge slot A?

I just recovered a VM clone I did just before upgrading.


That is the way HA OS installs updates, alternate in slot A and B. Something must have gone wrong during the update.

Oh! :frowning:
Tried again… captured the screen:

What to do?

I had an issue upgrading as well. Launched the upgrade from 12.2 to 12.3 in the UI. I have an Odroid N2+ 4GB. It didn’t come up, so broke out the HDMI & USB to check out the CLI. Got to a HAOS prompt in the CLI and there were a slew of repeated errors after each command: “error serverip not set”. The last command executed was “tftpget”.

I’m now doing a clean install and restoring from my last update (fortunately I downloaded the last backup before the upgrade). Not happy this blew up. The clean install with 12.3 and restoring the backup worked.

Thank you for the feedback. Will try clean.

Tbh I am very happy with my decision to run HA in a VM. Just got an old notebook with a SSD, Mint and VirtualBox and I run some infrastructure software out of it. Easy to backup / clone and it comes with an UPS :smiley:

After a couple reboots, got the “error serverip not set” error again. Trying a fresh install with HAOS 12.2

Don’t know if it would help, but I have a peculiar setup to be able to monitor 2 /24 networks (1 BgE and the other wifi, all bridged into the HA VM).

Story here:

The HA VM only got stable after I defined a default gateway for the second "virtual’ nic. Of course, I configured an IP outside the same network so it is unreachable.

If I left the second nic without a default gateway, it would reset to automatic, although I had chosen for it to be manual.

In fact, will try to upgrade again but removing the second nic first.

My poor Pi3B refuses to enable wlan since the update today.

Have been down a rabbithole with a lan cable… no joy so far

Had the same problem this morning. Happened upon a thread that suggested to type BANNER at the CLI prompt. It worked. No, I can’t explain it, but it fixed my system. IDK.

1 Like

Hi all

I’m on a minipc with Proxmox 8 and HA OS at 12.2 actually.

Do you suggest to do the upgrade?

I tried already yesterday, but after more than 10 minutes waiting, I just restarted HA and it was ok, but with 12.2

I have done a container snapshot anyway from Proxmox

Is there a “safe” way to do the upgrade or do you suggest to wait for next one?


Could you all please report these issues here:

The OS devs rarely monitor the forums for issues. So this is how you get the problem noticed.

Search through the existing issues (open and closed issues) first and make sure your platform (pi, x86 etc…) has not already been reported. If it has just thumbs up the first post. Do not post “me too”. It makes it difficult to follow actual logs and information related to the issue. Which you should definitely post if you have them. The more information you can provide the quicker this will be fixed.

1 Like