FATAL: The configured certfile is not found

Hi all,

I am trying to start up motionEye, I have managed to install it just fine, but when I start the addon, in the log file it returns me the below error:

FATAL: The configured certfile is not found

The full log file is:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-banner.sh: executing... 

-----------------------------------------------------------
 Hass.io Add-on: motionEye v0.1.1

 Simple, elegant and feature-rich CCTV/NVR for your cameras

 From: Community Hass.io Add-ons
 By: Franck Nijhof <[email protected]>
-----------------------------------------------------------
 armhf / Raspbian GNU/Linux 9 (stretch) / HA 0.79.3 / SU 138 / stable
-----------------------------------------------------------
[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing... 
Log level is set to INFO
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 02-updates.sh: executing... 

INFO: You are running the latest version of this add-on
[cont-init.d] 02-updates.sh: exited 0.
[cont-init.d] 10-requirement.sh: executing... 
FATAL: The configured certfile is not found
[cont-init.d] 10-requirement.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] 99-message.sh: executing... 
-----------------------------------------------------------
                Oops! Something went wrong.
 
 We are so sorry, but something went terribly wrong when
 starting or running this add-on.
 
 Be sure to check the log above, line by line, for hints.
-----------------------------------------------------------
[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] syncing disks.
[s6-finish] sending all processes the TERM signal.

I did some Googling which led me to the following guide:

I have added the two PEM files in my configuration.yaml and it therefore reads:

http:
ssl_certificate: /usr/share/hassio/homeassistant/certificate.pem
ssl_key: /usr/share/hassio/homeassistant/privkey.pem

Unfortunately this returns me the error:

Invalid config for [http]: not a file for dictionary value @ data[‘http’][‘ssl_certificate’]. Got ‘/usr/share/hassio/homeassistant/certificate.pem’
not a file for dictionary value @ data[‘http’][‘ssl_key’]. Got ‘/usr/share/hassio/homeassistant/privkey.pem’. (See /config/configuration.yaml, line 29). Please check the docs at https://home-assistant.io/components/http/

I’m not sure if I am on the right lines of troubleshooting the original error for installing motionEye or not. If I am on the right lines, can someone explain the above error for me?

Any tips or pointers please?

EDIT;

Below is the motionEye config, I have tried pointing it to the two PEM files I created, but this has not worked either. Same error.

{
  "log_level": "info",
  "port": 8765,
  "ssl": true,
  "certfile": "/usr/share/hassio/homeassistant/certificate.pem",
  "keyfile": "/usr/share/hassio/homeassistant/privkey.pem",
  "ipv6": false
}

EDIT:

For anyone else who comes across this error, I would suggest using DuckDNS to assign your SSL certificates. This is what worked for me.