Feature request: block supervisor auto-updates

  1. Does blocking version.home-assistant.io prevent that supervisor is updated too?
  2. Is there a way to install a Hassos image with its original version of the supervisor?


  1. Yes. Essentially blocking this URL prevents HA from checking and downloading new versions therefore it is not able to update supervisor. This also stops all add ons from downloading their updates which is not really useful as add ons can be prevented from auto update.
  2. I’m not sure I understand your question.

This also stops all add ons from downloading their updates

This is not correct. The addon versions are queried from Github.

I can confirm that this blocks add ons updates on my system as well as supervisor and core. It may not block downloading the add on updates, they all come from github… but it certainly stops add ons, supervisor and core from checking for updates and showing that an update is available hence at least core and supervisor won’t do an auto update.

Finally, they added a toggle for supervisor auto-updates :slight_smile:


Nice! When to be expected to arrive in a productive release?

It’s been in stable for 3 weeks.

Which component and version? HA Core? Frontend, supervisor, …?

Couldn’t find it in any docs yet. Just want to know how (where) to configure it.

In certain situations like to monitor my inverter long term, I want it frozen in time where I’d use browser version with a separate browser profile run by a shortcut just to do that.

Once it is working after testing for some time I want it left alone just to do that particular task without anything that may interfere and cause me problems.

I do have a firewall which is PfSense and I already have this as a vlan interface so I can control access. My intentions were to block outgoing traffic.

It doesn’t help that on an occasion when given an opportunity, it may update behind my back without my permission when I don’t want it to and it fails and goes wring which is why I despise that.

I considering over using a virtual appliance that will frequently make backups. I am testing it at the moment and seems to work well with my Solar inverter. One thing I found that I hid was the dimming overlays, that obscures the background and hurts my eyes where it flips but I hid without a problem with Adblock but the HeaderHiderFixer extensions doesn’t seem to autohide the blue fixed header nav/toolbar (can be hidden in developer tools until page reloads) which I find bloats the page and very distracting and annoying (can’t stand it at all stuck there constantly) but fortunately for the overview panels I found with HACS “Kiosk mode” which helps.

Maybe i should start donating to project in hope of one day seeing these options.

Anyway at the same I am very grateful that I found the registers for my Foxess Inverter on an addition for this platform trying to adapt something for Solax script on NodeRed but found it was readymade, not the nicest UI with the fixed headers but it is fully functional.

Foxess told me the ethernet port is non function when it stays third party monitoring in the manual and this lied to me. I am waiting for the day that these “cloud” hosting only solutions offered by the manufacturers go to subscription only.

Thank for making something that works so well.

This entire FR is about being able to stop supervisor from auto-updating. So, supervisor? But also none of the other stuff you listed auto-updates so I’m confused by your question.

Or are you asking when it arrives in the UI? If so the answer is it doesn’t. There’s no UI toggle, its in the cli.

ha supervisor options --auto-update=false

Btw for anyone looking to do this, two important notes:

  1. If supervisor is out of date then all updates are blocked. Core, OS, addons, none of it can be updated while supervisor is out of date. You also cannot install new addons or add new addon repositories. Something to be aware of
  2. Only the latest version of supervisor is supported. Your system will be treated as unsupported for purpose of issues while supervisor is out of date.

Yes, and I was commenting about things. Sorry I shoudn’t have in this thread. Thank you very much for the command and seems to have set it.

Yes that’s what my question was aiming at. Got it. Also good to read the two (quite big/important) downsides of disabling auto-updates for the supervisor.


Trying again…

WTH can’t I take control on when to update Supervisor? - Month of “What the heck?!” - Home Assistant Community (home-assistant.io)

You can. The solution is literally 3 posts before yours.

1 Like

I’ve tried that, but it still auto_update attribute is set to true even after a restart.
Am I missing anything?


Oh. That’s just a bug. That’s metadata, it doesn’t do anything. It’s hard-coded to true from when supervisor always auto-updated:

Supervisor manages its own updates. As long as ha supervisor info says auto update is false then its not auto-updating.

Can you submit a bug to core about that to track it though?



Supervisor update entity is not reporting the right status for auto_update attribute · Issue #79555 · home-assistant/core (github.com)

1 Like

Wow! That was fast!

This issue was fixed with 2022.10.0.

1 Like

Short: Has anything changed regarding those facts and statements?

As I ran into a (at the end minor, but a bit time-consuming though) issue caused by the auto-update to 2024.1.1 (the delay of 24 hours did not help in my case) yesterday, I’m thinking of disabling Supervisor auto updates.

Basically I like the approach to plan ANY updates, meaning to have a bit spare time in case something breaks (and yes, that happens more often than we all like). Cause if something breaks when you’re on the go or even away for a longer time with no possibilty to remotely fix stuff… always a tough lesson. Supervisor is literally the last component in my personal HA ecosystem with auto-updates enabled.

Then just disable it. You just need to update supervisor before you can update anything else.