Fed up of unreliability - ready to move Nodered to a Pi, Zigbee to Hubitat, etc

I’m so fed up with the unreliability of my HASS Blue setup, I’m now thinking that I shouldn’t have given it so much responsibility. It has a Zigbee2MQTT network of 105 devices & Nodered for all my automation and I wonder if that is why it needs a reboot every other day.

I’ve tried disabling the Homekit addon because I thought that might be a stretch too far. How do I diagnose the Zigbee network or the device itself being down on almost a daily basis?

Is there a 5 step guide I should have searched for?

My plan is to relieve it of Nodered by putting that on a dedicated Pi, I’ve ordered a C8 Hubitat device to handle the Zigbee network and I’ll probably do a dedicated device for Hoobs for Homekit. Then, what is HA really for in my setup any more? Maybe I’ll do a dashboard and use it for some of the non-Zigbee integrations.

My concern with moving to 4 devices is the management of all 4, but perhaps at least I’ll have more luck with diagnosis and if my problem with HASS is because I’m overloading it, then maybe I’ll find that this is my ideal setup.

Any thoughts?

This may or may not be of help but changing the wifi channel on the ap nearest to my zigbee dongle ended all my zigbee issues.

it was discussed here

I’ve got a Unifi system that should automatically change it’s channels (daily) to avoid any nearby conflicts

A question. The Unify system only change wifi channels to avoid interference from other wifi sources or. Can hardly also help with zigbee channels that is really not the same

Good point, i’ll try changing the channel manually just in case it only sees wifi channels rather than overall interference

I have been using unifi for over 4 years now and I cant recommend it enough. but DO NOT USE the nightly scan function. It just doenst work well and the wifi devices eventually just disconnect.

My suggestion is that yo do a manual scan, find the lowest noise channel in your area and manually set it to that. You will not have any more problems.

Also as @Yuran pointed out, make sure there’s no conflic with the zigbee channel. See this reference

1 Like

I have also found the UNifi nightly scan thing to not work. Just set it manually.

1 Like

Just buy an Intel NUC/mini PC, install HAOS and never have issues again.

Hi, so you reboot the device daily yourself?
As you might already know: a zigbee network can be unstable for many reasons and if it would be conflict with WiFi, it might be a better option to change the zigbee channel instead of WiFi.

You don’t mention what the real problem is for rebooting the system.
If it’s because of zigbee issues, have you seen/read this: Guide for Zigbee interference avoidance and network range/coverage optimization

I can imagine it’s a PITA when you have built a system with so many devices & automations and when it’s not working (well), you might be tempted to go for a drastic approach - as you seem to have planned.
I would advice you to try to find the cause of your issues instead of just buying new.

EDIT: I just learned that the blue only has USB3 ports. Did you plug your zigbee coordinator in 1 of these ports?

do i set each WAP to the same channel? I’ve got about 15 of them

yes, ti’s plugged into one of the USB ports on the Blue

Is it on an extension lead? This is a known problem with dongles plugged in directly to .sub ports.

Well, there you have already 1 probable reason for issues.
I really advice you to read the topic that I linked to in my previous post.

1 Like

Thanks, when I put it on an extension it was worse so I moved it back. I will put it on an extension and will play with my wifi channels.

Any tips on an extension cable, I just ordered the cheapest before and wonder if that didn’t help?

I’ve now put all my WAPs on channel 11 or 6, trying to make sure none that overlap are on the same channel. I’ve put the USB stick on the original extension cable with Zigbee channel 11 and I’ll see how we go.

BTW, the Unifi WAP is directly above the HA Blue device.

Did you read the topic I linked to?

yep, sure did.

If the Unifi AP and the HA box are that close, changing channels will have no effect. You need to get at least a couple of meters between them.
That could also explain why the USB extension made it worse, it was just acting as an antenna for the AP signal.

1 Like

If you read the info behind the link, you would know what the effect of the extension cable could/would have been and that the problem is not the extension cable itself - which made my eyebrows frown when you posted that.

There still are unanswered questions which may be important to help you but maybe buying a NUC/mini PC, preferable with at least a i5 can solve your problem. :thinking:

Abandon nodered. It is an extremely bloated thing to add to home assistant and I don’t really understand why it’s become so trusted.

Disclaimer: I hate nodered.