FEIT Electric BPA800/RGBW/AG/2 Smart WiFi Bulb (Tuya)


I just picked up 10 of these things on sale at Costco (2 for $20). I had done some quick searching and had saw that they were on the tuya platform and pulled the trigger thinking that they would be compatible with HA.

I’ve now discovered and seen in some previous dead posts that they don’t seem to work fully. The color temp slider does not function and does not seem to be properly controlled by Circadian Lighting either (when it attempts to dim the bulb, it shuts it off, temps don’t change correctly). When setting color and brightness with the UI on the bulb, it will sometimes “crash” by turning off and back on and resetting to a neutral temp and brightness.

So, that leads me to the point, how do I fix this? lol. I see a couple posts with people talking about flashing different firmware but they kind of fall off the face of the earth. Does anyone have these things up and running right? Any help would be appreciated!

1 Like

Me too…

I’ve attempted to flash the 3rd party firmware (Tasmota) but it doesn’t seem to be working currently. My guess is that these bulbs have a version of their firmware that blocks the method used to flash Tasmota. I think that leaves me with the option to wait it out or give up for now (which are really the same option, one just admits defeat right now).

The upside is these bulbs seem to be gaining popularity, so the likelihood someone finds another exploit is pretty high and soon. There might also be a way to “un-update” the bulbs to an older firmware, but I have yet to find the magic posted anywhere obvious online if that’s the case.

Good luck!

I have seen various reports of people having success and failure with the bulbs from Costco. It might just be the pack you pick up whether or not you get a bulb that can be flashed currently.

If you do manage to flash tasmota on the bulb, there is a template that is known to work. Take a look at


Make sure you enter setoption37 54 in the tasmota console as these bulbs are BGR color order.

I have a few Feit bulbs that seem to be working fine for me. I did purchase them from a different vendor however. They were labeled Feit on the package. But if you take a look at the following fccid link


Feit appears to be selling the same bulb just under different packaging.

@digiblur did a live stream that covered Feit bulbs in part:

Hope this helps.

This looks awesome. I will give this a try for sure.

Any recent and documented success? I just got some at Costco and would love to flash these OTA (or return back). The question remains: Is there a working way to flash Sonoff-Tasmota? (Just don’t torture me referring to a video where someone reads stuff off the screen for almost two hours) :wink:
If I was after one or two bulbs I could open and flash through serial port (I hope) but I would like to get more bulbs than practical. Thanks a bunch!

1 Like

Can answer myself: Tried OTA flashing. The bulb (in pairing mode) got connected to the network (so I know that the Tuya-Convert script accessed the bulb. However, the bulbs from Costco (September 2019) already have patched FW so this process did BRICK the bulb.
The bulb doesn’t fight back when you try opening it. Desoldered the ESP8266 module connected to serial. Cchecked the output ans yes - the boot loader got programmed and keeps cycling:
[notice]mqtt_client.c:576 gw wifi stat is:5
no vtrust-flash found, reconnect after 1s

Reflashed through a serial cable and voila - now I have Tasmota FW there. Now what remains is establishing the correct template to make it a RGBW bulb again :wink:

How did you connect to the module? I see the gnd and 3.3 connections but where is the rx & tx?

I have a couple that I also bricked with the tuya convert that I need to change over an I purchase 4 more but would much rather run tasmota on them.

Pics or pin out if possible…

Thanks in advance

There is a great description on github.
I started first pulling the bulb apart, desoldering and taking pictures along the path. When I started tracing the GPIO pins to the ICT pads on the little module I got lazy and started googling. And sure enough:

My understanding is: When the module is removed it is probably the easiest to power it from the 3.3V test (ICT) pad. But I suspect that within the bulb the power comes to the “VIN”, there is a step-down regulator on the module and the 3.3V pin is actually output for the logic board.
The pictures in the above write-up show the boards further spaced than on my bulbs. Soldering w/o separating the boards may be harder but should be possible.
We are all investing more time into each bulb than what was the initial cost ;-(
Good luck - Martin!
managed to solder the wires on the assembled PCBA sandwich. Not much space but doable.

Oh and the
profile did seem to do the trick.

1 Like

I picked up Feit Electric Color Changing WiFi bulbs in 2 packs at Costco as well and was able to get them to work with HASS. Reset the bulbs and set them up in the Tuya app rather than the Feit Electric app. When you set them up, you will get a warning that the bulbs don’t work and that you have to update the app, but ignore that warning. Now set the Tuya module up in Hass and they should all work. They worked for me, however the color temperature slider was glitchy. I was still able to change the temperature with the Call Service function though.

All the best,
Jack D Knight from Loopdy Loop

1 Like

I grabbed 4 2-packs from Costco all the same day. 2 of the eight required the BPA800 template. the other 6 required the OM60 template. The 2 BPA800 came in different packs! The OM60s will need me to reverse the colors as folks have noted. The BPA800 templated ones the colors are correct. All are running Tasmota 7.2.0.

If one template doesnt work, try the other and you should be good. Now to get them in to HA!


How can I tell which template I need? I applied the OM60 and the bulbs seem to mostly work in HA except for cold/warm white temp slider. Should I try the other template, or is there a more concrete/scientific way to determine the correct template?


anyone has ota tuya convert to flash tasmota guide? the above youtube is two hours long :frowning:

Wow, 2 hours is nuts. I don’t remember exactly what I did, but I definitely didn’t watch a 2 hour video. I maybe skipped around through it.

But the instructions are here:

yeah, actually following it and use template from database.

fyi, Costco has it on sale, $15 for 2 bulbs. I am getting 4 of them for my porch and garage.

Good point: The “official” profile is now in the database:

{“NAME”:" BPA800/RGBW/AG/2",“GPIO”:[0,0,0,0,140,37,0,0,38,142,141,0,0],“FLAG”:0,“BASE”:18}
NOTE: There are two variants of this bulb, BPA800/RGBW/AG/2§ and BPA800/RGBW/AG/2 (this template). The additional key info from the same source:
Need to run setoption37 54 in the console to correct the RED and BLUE mismatch
This bulb seems to have hardware Gamma correction, so you need to make sure you disable Software Gamma Correction: LedTable 0
Don’t forget to set the SetOption19 1 to enable Home Assistant automatic discovery and you should be ready to go.
I also just did series of the OTA upgrades from Tasmota 6.6.0:
Upgraded to 7.2.0; Upgraded to 8.1.0; Next upgrade failed (assuming binary size issue).
So upgraded to 8.3.0 Minimal. That BEGS for upgrade! Upgraded to 8.3.0.
Now up-to-date and the WEB UI is great - much improved color control. Though once under HASS we may never need it again :wink:

I’ve got the plain unmodified version of these bulbs. When I open it in the Tuya Smart Life app, I’m able to control on/off, brightness, and color temperature. The RGB doesn’t show up at all. I’ve got the HASS integration and it’s the same story there. Is this normal?.. is there any way to get the RGB control up?

1 Like

This worked for me, well warm cold still wrong way around

{"NAME":"Feit Bulb","GPIO":[255,255,255,255,141,140,255,255,38,142,37,255,255],"FLAG":0,"BASE":18}

This worked for me, well warm cold still wrong way around

{"NAME":"Feit Bulb","GPIO":[255,255,255,255,141,140,255,255,38,142,37,255,255],"FLAG":0,"BASE":18}

Go to console and SetOption37 to 1

This works with your template on the bulbs I just got from Lowes that have the 2019 copyright on the bottom of the box.


Have you had any luck getting this answered?