Fibaro Door Sensor V2

Tags: #<Tag:0x00007f77faa34ca0>

I just got a new Fibaro Door Sensor V2 (FGDW-002), and added the sensor to my zwave config.

I do see the sensor in the devices, but it looks like it doesnt have a correct profile.

I only get a binary sensor, but it stays off for the whole time, it does not register any change in the sensor.
Also i am missing a temp sensor, which it should have.

The info also mention unknown product name:
is_info_received: false
manufacturer_name: FIBARO System
sentCnt: 1
averageResponseRTT: 0
node_id: 10
sentTS: 2017-06-12 21:02:21:825
is_failed: false
receivedTS: 2017-06-12 21:01:48:014
battery_level: 100
query_stage: Probe
averageRequestRTT: 0
receivedUnsolicited: 0
product_name: Unknown: type=0702, id=1000
capabilities: beaming,routing
receivedCnt: 0
max_baud_rate: 40000
is_zwave_plus: true
node_name: Fibaro Deursensor Voordeur
wake_up_interval: 0
lastRequestRTT: 0
friendly_name: Fibaro Deursensor Voordeur
lastResponseRTT: 0
sentFailed: 1
receivedDups: 0
is_ready: false
is_awake: false
retries: 0

Any idea to get this sensor working?

Good evening,

The product id and type seems to be correct:

Could you tell us what is your z-wave controller ?

And give a copy of the node information in the xml file in the home assistant folder.

Best

My zwave controller is a Rpi with latest version of HA (46.0.1), and an Aeotec Zwave stick 5.

This is the node part in my xml file:

<Node id="10" name="Fibaro Deursensor Voordeur" location="" basic="4" generic="7" specific="1" roletype="6" devicetype="3078" nodetype="0" type="Notification Sensor" listening="false" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Probe">
		<Manufacturer id="10f" name="FIBARO System">
			<Product type="702" id="1000" name="Unknown: type=0702, id=1000" />
		</Manufacturer>
		<CommandClasses>
			<CommandClass id="32" name="COMMAND_CLASS_BASIC" version="1" request_flags="4">
				<Instance index="1" />
				<Value type="byte" genre="basic" instance="1" index="0" label="Basic" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
			</CommandClass>
			<CommandClass id="34" name="COMMAND_CLASS_APPLICATION_STATUS" version="1" request_flags="4" innif="true">
				<Instance index="1" />
			</CommandClass>
			<CommandClass id="48" name="COMMAND_CLASS_SENSOR_BINARY" version="1">
				<Instance index="1" />
				<Value type="bool" genre="user" instance="1" index="0" label="Sensor" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="False" />
			</CommandClass>
			<CommandClass id="49" name="COMMAND_CLASS_SENSOR_MULTILEVEL" version="5" innif="true">
				<Instance index="1" />
				<Value type="decimal" genre="user" instance="1" index="1" label="Temperature" units="C" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="22.9" />
			</CommandClass>
			<CommandClass id="86" name="COMMAND_CLASS_CRC_16_ENCAP" version="1" request_flags="4" innif="true">
				<Instance index="1" />
			</CommandClass>
			<CommandClass id="90" name="COMMAND_CLASS_DEVICE_RESET_LOCALLY" version="1" request_flags="4" innif="true">
				<Instance index="1" />
			</CommandClass>
			<CommandClass id="94" name="COMMAND_CLASS_ZWAVE_PLUS_INFO" version="1" request_flags="4" innif="true">
				<Instance index="1" />
				<Value type="byte" genre="system" instance="1" index="0" label="ZWave+ Version" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="1" />
				<Value type="short" genre="system" instance="1" index="1" label="InstallerIcon" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-32768" max="32767" value="3078" />
				<Value type="short" genre="system" instance="1" index="2" label="UserIcon" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-32768" max="32767" value="3078" />
			</CommandClass>
			<CommandClass id="112" name="COMMAND_CLASS_CONFIGURATION" version="1" request_flags="4" innif="true">
				<Instance index="1" />
			</CommandClass>
			<CommandClass id="113" name="COMMAND_CLASS_ALARM" version="5" request_flags="2" innif="true">
				<Instance index="1" />
				<Value type="byte" genre="user" instance="1" index="0" label="Alarm Type" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
				<Value type="byte" genre="user" instance="1" index="1" label="Alarm Level" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
				<Value type="byte" genre="user" instance="1" index="2" label="SourceNodeId" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
				<Value type="byte" genre="user" instance="1" index="7" label="Heat" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="254" />
				<Value type="byte" genre="user" instance="1" index="9" label="Access Control" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="23" />
				<Value type="byte" genre="user" instance="1" index="10" label="Burglar" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="254" />
				<Value type="byte" genre="user" instance="1" index="11" label="Power Management" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="254" />
			</CommandClass>
			<CommandClass id="114" name="COMMAND_CLASS_MANUFACTURER_SPECIFIC" version="1" request_flags="4" innif="true">
				<Instance index="1" />
			</CommandClass>
			<CommandClass id="115" name="COMMAND_CLASS_POWERLEVEL" version="1" request_flags="4" innif="true">
				<Instance index="1" />
				<Value type="list" genre="system" instance="1" index="0" label="Powerlevel" units="dB" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" vindex="0" size="1">
					<Item label="Normal" value="0" />
					<Item label="-1dB" value="1" />
					<Item label="-2dB" value="2" />
					<Item label="-3dB" value="3" />
					<Item label="-4dB" value="4" />
					<Item label="-5dB" value="5" />
					<Item label="-6dB" value="6" />
					<Item label="-7dB" value="7" />
					<Item label="-8dB" value="8" />
					<Item label="-9dB" value="9" />
				</Value>
				<Value type="byte" genre="system" instance="1" index="1" label="Timeout" units="seconds" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
				<Value type="button" genre="system" instance="1" index="2" label="Set Powerlevel" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
				<Value type="byte" genre="system" instance="1" index="3" label="Test Node" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="0" />
				<Value type="list" genre="system" instance="1" index="4" label="Test Powerlevel" units="dB" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" vindex="0" size="1">
					<Item label="Normal" value="0" />
					<Item label="-1dB" value="1" />
					<Item label="-2dB" value="2" />
					<Item label="-3dB" value="3" />
					<Item label="-4dB" value="4" />
					<Item label="-5dB" value="5" />
					<Item label="-6dB" value="6" />
					<Item label="-7dB" value="7" />
					<Item label="-8dB" value="8" />
					<Item label="-9dB" value="9" />
				</Value>
				<Value type="short" genre="system" instance="1" index="5" label="Frame Count" units="" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-32768" max="32767" value="0" />
				<Value type="button" genre="system" instance="1" index="6" label="Test" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
				<Value type="button" genre="system" instance="1" index="7" label="Report" units="" read_only="false" write_only="true" verify_changes="false" poll_intensity="0" min="0" max="0" />
				<Value type="list" genre="system" instance="1" index="8" label="Test Status" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" vindex="0" size="1">
					<Item label="Failed" value="0" />
					<Item label="Success" value="1" />
					<Item label="In Progress" value="2" />
				</Value>
				<Value type="short" genre="system" instance="1" index="9" label="Acked Frames" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-32768" max="32767" value="0" />
			</CommandClass>
			<CommandClass id="128" name="COMMAND_CLASS_BATTERY" version="1" request_flags="4" innif="true">
				<Instance index="1" />
				<Value type="byte" genre="user" instance="1" index="0" label="Battery Level" units="%" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="255" value="100" />
			</CommandClass>
			<CommandClass id="132" name="COMMAND_CLASS_WAKE_UP" version="2" request_flags="2" innif="true">
				<Instance index="1" />
				<Value type="int" genre="system" instance="1" index="0" label="Wake-up Interval" units="Seconds" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="21600" />
				<Value type="int" genre="system" instance="1" index="1" label="Minimum Wake-up Interval" units="Seconds" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="0" />
				<Value type="int" genre="system" instance="1" index="2" label="Maximum Wake-up Interval" units="Seconds" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="64800" />
				<Value type="int" genre="system" instance="1" index="3" label="Default Wake-up Interval" units="Seconds" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="21600" />
				<Value type="int" genre="system" instance="1" index="4" label="Wake-up Interval Step" units="Seconds" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="-2147483648" max="2147483647" value="3600" />
			</CommandClass>
			<CommandClass id="133" name="COMMAND_CLASS_ASSOCIATION" version="1" request_flags="4" innif="true">
				<Instance index="1" />
				<Associations num_groups="3">
					<Group index="1" max_associations="1" label="Group 1" auto="true" multiInstance="true">
						<Node id="1" />
					</Group>
					<Group index="2" max_associations="5" label="Group 2" auto="false" multiInstance="true" />
					<Group index="3" max_associations="5" label="Group 3" auto="false" multiInstance="true" />
				</Associations>
			</CommandClass>
			<CommandClass id="134" name="COMMAND_CLASS_VERSION" version="1" request_flags="4" innif="true">
				<Instance index="1" />
				<Value type="string" genre="system" instance="1" index="0" label="Library Version" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="3" />
				<Value type="string" genre="system" instance="1" index="1" label="Protocol Version" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="4.38" />
				<Value type="string" genre="system" instance="1" index="2" label="Application Version" units="" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="3.02" />
			</CommandClass>
			<CommandClass id="142" name="COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION" version="1" request_flags="4" innif="true">
				<Instance index="1" />
				<Associations num_groups="3">
					<Group index="1" max_associations="1" label="Group 1" auto="true" multiInstance="true">
						<Node id="1" />
					</Group>
					<Group index="2" max_associations="5" label="Group 2" auto="false" multiInstance="true" />
					<Group index="3" max_associations="5" label="Group 3" auto="false" multiInstance="true" />
				</Associations>
			</CommandClass>
		</CommandClasses>
	</Node>

Hallo AutoRon,

Both product type and id are good.

However, could you try to change the Manufacturer id="10f" to "010f" - this might be the culprit.

<Manufacturer id="010f" name="FIBARO System">
<Product type="0702" id="1000" name="FGDW002 Door Opening Sensor 2" config="fibaro/fgdw2.xml" />

Groeten :slight_smile:

1 Like

You are awesome!

I have added the 0 in front of the manufacturer id, and now i receive all sensors.
Cannot test if the binary sensors works, but will find out later.

Thanks for your fast response!

You are welcome

I have the same problem! Sensor v1 working fine, but new door sensor V2 is always on same state. I have change 10f to 010f without any success. Do I have to restart my all raspberry after editing the config or HA is enough?

   <Node id="4" name="Cuisine" location="" basic="4" generic="7" specific="1" roletype="6" devicetype="3078" nodetype="0" type="Notification Sensor" listening="false" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="CacheLoad">
            <Manufacturer id="10f" name="FIBARO System">
                    <Product type="702" id="1000" name="Unknown: type=0702, id=1000" />
            </Manufacturer>

Thanks.

Guillaume

Today i was able to test the sensor.

I do recieve information from the sensor (like temperature etc), but it will not trigger any change when the door is opened or closed.

Also it seems like a reboot will reset the node id in the xml file.

I updated to 0.47 to check if the error was still there, but unfortunatly, i still have the same issue like ghayoz.

The parameters that should be changable through the zwave (wake up time etc) are not visible either, so i still think the device is not recognized correctly.

I have been digging around…

It looks like the HA doesn’t have the last openzwave information.

When i check https://github.com/OpenZWave/open-zwave/tree/master/config/fibaro, there is a xml file for fgdw2.xml.

when i check my pi at: /home/homeassistant/.homeassistant/deps/python_openzwave/ozw_config/fibaro/

fgbs001.xml fggc001.xml fgmszw5.xml fgs211.xml fgs223.xml
fgd211.xml fgk001.xml fgpb101.xml fgs212.xml fgsd002.xml
fgd212.xml fgk10x.xml fgr221.xml fgs213.xml fgss101.xml
fgfs101.xml fgkf601.xml fgrgbwm441.xml fgs221.xml fgwpe.xml
fgfs101zw5.xml fgms.xml fgrm222.xml fgs222.xml fgwpfzw5.xml

is do not have that xml file.

Am i looking in the right spot, and if yes, how do i update the open-zwave?

Has anyone contacted Fibaro directly?

Yes I just have contact them. And answer is simple…


Hello,
Please contact in this case with manufacturer of controller.
All Our modules meets all requirements required by z-wave alliance.
Please confirm with manufacturer that they have proper template of parameter for this new device.

Door Windows Sensor should be compatible.


I guess the current openzwave installation in hassbian is not the latest version, thats why we have these issues…

Is there a way to upgrade openzwave?

I think you can just grab the latest XML files from the github repo for those devices, and drop them in?

Hey guys,

I’ve got the same problem. Copied the XML file in to the directory, but still no luck. Any other ideas? Or who can I ask to include the XML-file in the new release? Or do I just report an issue?

Thanks

Hi, I Also have issues with this sensor.
Running HA 0.50.2 (Hassbian on Pi3) and Open-Zwave 1.4 with Z-stick gen5

I have the xml for this sensor (fgdw2.xml). But the second line in the xml says it is for fgk101, so not sure if that is a typo, or if it is the wrong file.

Also my manufacturer_specific.xml does not reference to fgdw2.xml anywhere, so doesn’t seem like it is fully implemented yet.

Sorry if none of this make sense :slight_smile: I’m new to all this, and just trying to learn a little

I have it working now.

Did a pip install python_openzwave --upgrade inside the virtualenv of homeassistant

On Hassbian this is pretty much the procedure i did:

$ sudo systemctl stop [email protected] 
$ sudo su -s /bin/bash homeassistant
$ source /srv/homeassistant/bin/activate
$ pip install --upgrade python_openzwave
$ exit
$ sudo systemctl start [email protected]

I am no expert, so don’t come crying if it break anything :slight_smile:

I hav try to use the solution of @nepa but I still have the same problem.
Sensor is named : FIBARO System Unknown: type=0702, id=1000 Sensor

Any solution please?

Anyone find a solution for this?

Same issue here. Turns up as “Unknown”, I’m running Hassio.

Same here, did an pip install --upgrade python_openzwave but that didn´t help :frowning: