Fibaro FGS-223 double relay - second channel doesn't update HMI

I have a FGS-223 double relay. When I toggle the physical light switch connected to channel 2, the Hassio front end (MHI) toggle switch doesn’t change state. Channel 1 works perfectly. Any ideas what is wrong?

I can control the light ok from the front end HMI, although when I switch on, the front end toggles back to off, ie the switch state is obviously not being reported back to the zwave controller. When I toggle the front end a second time, then the toggle sticks. Very odd.

Sorry, I found the solution by further searching the forums, the device needs to be added in secure mode, now it works as expected. See solution here Fibaro double switch (fgs-223) current state not correct

Noting that I did it all through the HASS.io “Configuration / Z-Wave network management” card rather than the OZWCP method described in the link above.

Had the same problem but found a different solution that works for me. I found the info here: https://github.com/OpenZWave/open-zwave/issues/1003

The FGS 223 (and also 213) needs to be associated with the multi channel association.
First remove the previous association in Group 1 with service: zwave.change_association and JSON:

{"association": "remove", "node_id": NN, "group": 1, "target_node_id":1}

(replace NN with your Node_id)

then call zwave.change_association again with:

{"association": "add", "node_id": NN, "group": 1, "target_node_id":1, "instance":1}

(replace NN with your Node_id)

Dear HA_jr,

Can you explain to me step by step how i can solve this problem. Oftrn when i switch on or off the fibaro switch, hassio doesn’t see it on or off.

Best regards,

Nino

Dear Nino, is your problem related to second channel specifically? /JR

Hi, yes it is the second channel ( i allways thought the left switch is the 1e but it is not )

thanks for helping

OK, so what you need to do is to:

  1. On the FGS-2x3, remove the association to your controller (typically node 1)
  2. Then add your controller back again but this time as instance 1. This adds it with a multi-channel association.

In my Home Assistant (web page GUI) there is an option called Services. First click on this, then select Service zwave.change_association. Use the two JSONs from my comment above.

1234567890

Thanks it works now. I had a small problem with the quotes so replaced ” with "
Now it works fine, magic haha

Hello…Sounds like the hc truly experiences difficulty associating with the modules. Possibly they’re excessively far away or the hc believes they’re excessively far away, something that you fixed through work config. Take a stab at drawing the hc nearer for the leftover modules.

pcb quote