Home Assistant Community

Fibaro Roller Shutter 3 (FGR-223) - cannot get it to work properly

#1

I recently purchased a few Fibaro Roller Shutter 3 (FGR-223). Although HASSIO recognizes it, I cannot get it to work properly.

For starters, besides the shutter level control entity, it is exposing the switch entity. By taking a closer look at the core.entity_registry file, I noticed that the older FGRM-222 (Fibaro Roller Shutter 2) also had a cover.xxxx_switch entity, but its config_entry_id and device_id were set to null. The FGR-223 does have config_entry_id and device_id set with long hexadecimal ids.

But the worst part is that I just cannot get the shutter buttons to act as they should. I have a double momentary switch connected to each of my new FGR-223 and even though I have parameter 20 (Switch Type) set to Momentary switches, I have to keep each button pushed to maintain its operation, whereas with the FGRM-222 all I have to do is to push and release one button to make it work and press it again to stop its function.

Anyone using these new FGR-223? Any suggestions to fix this?

1 Like
#2

Same here. Without the “cover…_level” there is no way to control the shutter through HA.
The previous version had “sensor…_switch” - but it was not needed (redundancy to ‘level’ all the way). This version does not.
Besides, I have the same issue with the shutter buttons but it is a Fibaro issue, not HA…
A workaround might be using a scene control with HA… not great but should work till a solution will be supplied by Fibaro. Will try that later today (hopefully).

This version also has a new sensor - sensor.fibaro_system_fgr223_roller_shutter_controller_3_system - don’t know what it means.

#3

I have exactly the same problem. Calibration works fine, but afterwards I can only fully open or close the blinds. Setting it to a specific position does not work.

#4

I have a problem with the tilt function, but the UP/DOWN function works fine. I can use it with Home Assistant and manually with switches and get always the position feedback.

Fibaro Roller Shutter 3 (FGR-223) Lamellas Position “Venetian Blind Tilt Position” is not working

#5

I am able to set the shutter to an intermediate position by using the progress bar that is displayed when one accesses the _level entity on the GUI (I have a cover.*_level entity). I did not try to set the position with a service yet, but I guess that if it works on the GUI, it will work with the service.

Nonetheless, the fact that buttons do not function as they are supposed to (“press & forget”) is what troubles me the most, because they are not useful this way.

#6

Yes, the cover.*_level appeared eventually on my HA as well (also the sensor.**_switch).

But I couldn’t make the scenes work:

  1. Fibaro changed the scenes IDs.
  2. their documentation is not clear - seems all S1 clicks give the same ID…
  3. I’ve been able to see in the log only once that HA identifies a sene ID. On all other trials it just shows data I cannot understand
  4. HA interface for zwave parameter configuration does not allow setting the scene value for S2 (parameter 41)

here are some related images:

HA zwave config UI:


Scene documentation of Shutter-Roller-2 -

Scene documentation of Shutter-Roller-2 -

#7

Well, all of the sudden my FGR-223 started to work as expected (press & forget). Don’t ask me what I did, because I do not know :slight_smile: (other than opening the circuit breaker and closing it again).

As for the cover…switch entity, I got rid of it by ignoring it on the zwave component.

#8

Fixed itself?
I did the update to 0.87.1 and it still does not work correctly

#9

Same here. On the Fibaro forum it has been stated that Fibaro is aware that positioning does not work correctly and they are working on a fix.

#10

I did not upgrade my HASSIO (I’m still on 0.86.4), so that is not what did the trick.
I can also confirm that I am able to set my shutters to a specific percentage using HASSIO (it is also working with Google Home by using the google assistant component).

Regarding the issue that Fibaro is aware of, I’m not sure how we will manage to update our FGR-223 firmware, as Fibaro requires users to have their Home Center to apply firmware updates on their zwave devices.

#11

tiny progress:

#12

Apparently Fibaro changed the way they work with scenes. HA needs to implement the new way. Here is a link to a post with more details:

#13

This is my solution to the problem of the position of the covers:

First under Configuration -> Z-Wave -> Nodes -> select your fibaro roller shutter then “Entities for this node” -> “your node” with “level” in the name -> set “Polling Intensity” to 1 then save. Do the same for each fibaro cover.

Now add (write your names of covers) lines in the configuration.yaml file:

# Fix to covers position 
  polling_interval: 2000
  device_config:
    cover.fibaro_system_fgr223_roller_shutter_controller_3_level:
      refresh_value: true
    cover.fibaro_system_fgr223_roller_shutter_controller_3_level_2:
      refresh_value: true
    cover.fibaro_system_fgr223_roller_shutter_controller_3_level_3:
      refresh_value: true
    cover.aeotec_zw141_nano_shutter_level:
      refresh_value: true

Restart hass and try.
After the system has stabilized, it should indicate the position of the covers in “real time”.

#14

A polling of 2000 means that your system will be polling the state of your devices every 2 seconds. In a relatively large network this could generate some severe bottlenecks and render the whole system useless.

Is your installation working OK after applying these changes? How many zwave devices do you have?

#15

I was afraid about it…

Yes, by reducing the value I checked the stability

Only 12 (few with battery) but the target will be max. 20 z-wave.
In addition, more than 30 other non z-wave devices.
This is a temporary solution. I don’t know how it affects devices with a battery (no changes visible after 24 hours).
Without tests there is no answer. :slight_smile:

edit:
There are few queries to other devices in the OZW_Log.txt. There are many to those with Polling Intensity setting = 1

Files home-assistant_v2.db and OZW_Log.txt still growing. :joy:

#16

This thread on the OpenZWave community forum provides some hints about this issue.
According to “Fishwaldo” on one of the last replies, there is something that needs to be done on HA side in order to make the FGR-223 report the shutter position correctly:

#17

Some solutions here and on Github suggest to poll the device to get an update on its position. But this is not working on my end. Polling only helps to update the position when the blinds are either fully closed or fully open. When I move the blinds to halfway closed (either by using the cover.set_cover_position service or manually by usind the physical switches) it never updates to position 50. It always stays at 100. Any help how I can get this fixed using polling would be highly appreciated.

#18

So no news for this problem? Is this Fibaro problem or HA?
I need to buy some roller shutters, but do not want to buy an old version…

#19

Hi all,
i’m a noob in home assistant and even more a noob in zwave.

I bougth myself a gen 5 usb stick on amazon and this fibaro roller.
I modified my electricity installation to include the node and adapted the configuration of HA to include zwave

I know that I need to pair both devices ^^
and I somehow manage to do that at least once, and then i could put up the roller but then the device is displaied as dead :confused:

So i tried to remove it from it association (either in HA, either with a very long press on the stick and the 3 fast click on the B button of the fibaro)

I added a secure key in the option.xml file
and tried again to add my fibaro

when i add the device the log dispaly following information
https://pastebin.com/1gHwDxXg

as you can see I have some bullshit like
ERROR: Dropping command because node is presumed dead

I also copied/paste the the config settings bobsilesia gave but no more luck :confused:

Any idea ?

ps : I also tried a factory reset, the manual says long press on B until it change color to white, green, violet, yellow then release and click fast it should start blinking red after a time to tell it was reseted…

but mine goes white, green, violet, green and nothing happens …

The same manual said the calibration is done when release and fast click on white, … didn’t saw any calibration :confused:

#20

just for info I bought a qubino model and manadged to make it work like expected. So it is this FGR 223 that is buggy, therefore I send it back to amazon…