Fibaro Smoke Detectors (FGSD002) How to trigger alarm / how to group them?

So I have 11 of these (Fibaro Smoke Alarm, FGSD002). I did a test with “smoke in a can” test spray, and it successfully triggers the alarm after a few seconds (3-8 seconds I think).

However, it did not broadcast the alarms to the other sensors that I had put in the same group. I have only used these sensors in HA, and set the
Parameter 13, Alarm broadcast
1 – SMOKE ALARM command broadcast (2-nd & 4-th Association Group) active; casing opening notification broadcast (3-rd & 5-th Association Group) inactive (unfortunately not possible to see all the text in the configuration in HA, as it is truncated, but it is the second option in the dropdown list.)

None of the other sensors with this same option enabled was triggered. Am I missing some extra option that needs to be set (manual)? The sensors also seems to get this option reset to 0 - broadcast disabled, perhaps because I try to activate this option for more than 5 devices. Is activating this option also adding the device to the group?

The manual states that maximum 5 units can be controlled by the FGSD002, I guess effectively limiting to the same number in each “association group” (?).

I’m not even sure how I define which group each device is in, and it might seem that some parameters are not visible in the HA configuration for the device. It is noted that the params are as given by the Z-Wave JS integration database Z-Wave JS database for FGSD002

Anyone knows how I can do one of:

  1. Associate all 11 smoke detectors for direct fire alarm broadcasting
  2. Let HA send the trigger signal to the FGSD002? (So that I can make an automation that sends this signal to all detectors if any of them are triggered).

Are you using Z-Wave JS UI? You can’t create group associations using HA.

I’m using the Z-Wave JS integration in HA, not Z-Wave JS UI. I didn’t know this limitation. However, I’m not sure how I switch between them. I run HA core on a raspberry pi, and have installed Z-Wave JS via node (npm) on npm i @zwave-js/server.

I fail to add Z-Wave JS UI via the link at as it is only meant for HASSIO I think?

What are my options now - I cannot run HASSIO, since I use an xComfort integration, which isn’t supported by HASSIO.

Realistically you’ll want to install Z-Wave JS UI if you want to use associations. HA doesn’t support it via any UI, and the raw service calls to do it are complicated. There are multiple ways of installing ZUI: Docker is the easiest but there are binary downloads too.

Regardless, running zwave-js/server manually is not advised nor supported by HA, so it’s recommended to use Z-Wave JS UI for a non HAOS install. To switch you would just need to copy over the driver cache files (*.jsonl files) and re-configure the same security keys.

You don’t need HAOS to use Z-Wave JS UI, but why does using that integration prevent you from using HAOS? HACS works on any install type, and that integration ( ?) can be installed with HACS according to its docs.

You can try Broadcast. It doesn’t require groups, it is literally a broadcast message to the entire network. However, broadcast messages only work for devices within direct RF range, they are not relayed.

Thanks @freshcoast, I’ll try to install zwave-js-ui now.
I cannot use HAOS, since I don’t use the xComfort-integration you mention as I don’t have the SHC, but the CKOZ-00/13 USB stick and therefore use GitHub - karloygard/xcomfortd-go: Eaton xComfort CKOZ-00/14 and CCIA-0x/01 to MQTT gateway and I failed to compile that on HAOS (don’t remember exactly why now).
I hope I manage to switch over to Z-Wave JS UI, though!

Well, I did manage to switch from Z-Wave JS/server to Z-Wave JS UI on my raspberry pi (ended up by compiling from git source, ok).

But it seems that the Fibaro FGSD002 cannot work in series, since they do not listen to messages in the group, as they are battery operated (only wakes up every 6 hours or so, or when smoke is detected, or temperature changes).

I would need a siren device and add that to the same group as a smoke detector, and then have the siren to start whenever any of the smoke detectors are triggered.
This also means that there is no way for HA to send a siren signal to the FGSD002 smoke detector.
Please correct me if I am wrong.

Yes, you can send notification reports to the smoke detector. You would need to figure out which notification it is.

Here’s an example service call to send a report message to a node.

I also saw someone in Discord using alarm level 255 for some Fibaro devices.

service: zwave_js.invoke_cc_api
  command_class: "113"
  method_name: sendReport
    - alarmType: 0
      alarmLevel: 255

If you associate the controller with the notification group, you can see what is actually being sent by the device.

The messages will be queued in the driver until the device wakes up, so you’re still stuck with the hours long delay.


Thanks, this is interesting, but:

so you’re still stuck with the hours long delay.

:joy: yep, so it will be pretty useless in a fire situation.

I think I just have to admit that I was wrong in my assumption that I could use the Fibaro FGSD002 as interconnected smoke detectors.

But I will save the links you gave for later to with an actual siren I think.

Just for let you know that this command works fine with the Fibaro dimmer 2 light controlling module. The light then starts to blink accordingly to its configuration. Moreover, it is way better than building an automation to blink the light (since the usage of the zwave netwwork is way less intensive).

Changing the parameter alarmLevel: 255 to alarmLevel: 0 in the API call is then cancelling the alarm modus.

1 Like