Finally a beautiful dark theme for Node-RED

I just released the first version of my dark theme for Node-RED. It’s based on the midnight theme for Home Assistant. Hope you like it!

10 Likes

WOW! A lot has happened since I posted this.

The Midnight theme for Node-RED has a new home now.

And it’s also available as an NPM package.

Most recent screenshot.

I also published two more themes.

Solarized Light

Solarized Dark

I hope you like it.

1 Like

I know this is old, but how do I install these?? I see that it mentions npm, but I don’t know where I run this…

Thanks

How did you install Node-RED?

From the Supervisor Add-On Store.

Then just set dark_mode to true in the add-on configuration.

1 Like

Son of a. How did I miss that, me and my eyes thank you.

1 Like

I know this is old so I hope when dark_mode is deprecated they have options for this.

With HassIO HassOS or whatever the heck it is called where you install with Supervisor how would you go about installing a theme? I got on SSH port 22222 on the host and docker exec -it XXX /bin/bash to get in the container and it doesn’t contain a lot of the requirements to do the npm install.

I didn’t try much further than that before leaving this comment because I tend to break things a lot :slight_smile:

Have you tried the theme option?

1 Like

Thank you for this amazing theme. I have it installed for a couple of years now.

For some reason, it had automatically reverted to the default theme which I believe is after a recent update to Home Assistant. Setting the theme option to midnight-red and restarting the NodeRED add-on did the trick! Cheers! :+1:

For those of you who are wondering how to do this:

  1. Go to Supervisor
  2. In the list of installed Add-ons, select NodeRED
  3. Go to the Configuration tab
  4. Change the value of the theme to midnight-red
  5. Click SAVE (it will prompt you to restart the add-on)
  6. Confirm to restart the NodeRED add-on
  7. Enjoy the theme :slight_smile:

Hope this helps.

5 Likes

Thanks for the message.

The release notes of the latest version of the add-on mention that. :wink:

The dark_mode option was removed and replaced with the theme option.

For some reason my entire theme uses dark except the actual grid >.< Any ideas?

Can you post a screenshot?

Sure thing! Here you go

That’s weird. Have you tried to clean up the browser’s cache?

Sadly yes. Tried the F12 → Hard Reload and Empty and a CTRL-F5, still stays the same

EDIT : Resolved ! → Dark Reader addon in the browser was changing contrasts. Disabled it for the HA URL and it works now. Thanks!

1 Like

So I understand this is an old thread but somehow I’ve got my Node Red into the light theme again (didn’t change it on purpose). It’s set to dark in the add-on configuration. I’ve also tried to set it from the node red dashboard with no luck. Can’t stand the light, but not sure what I’m missing to get it back to dark. Clearing cache doesn’t help, happening on all browsers I’ve tried from.

What version of the add-on are you on? Did you change anything in settings.js?

10.0.1 and no I haven’t made any changes to settings.js. I’m stumped