Finally upgraded home assistant. now everything is broken

I was following this link when setting up the yaml

however they say I could set it up in the configuration-> general but under general there is no https setup possibilities.
as shown below:

Clear your cache and refresh your page, then it should appear.

still, none of that is your actual problem, the TUYA is giving the issues

My live configuration would beg to disagree, as would the official docs :wink:


Eh, it’s not like I don’t say that’s not possible only for somebody to point out that is has been for X releases :rofl: I’m pretty sure you’ve done that at least once :smiley:

Yea yea, I was looking in the HTTP section, didn’t think to check the basic config…

I’m running the site without a cache now and it still doesn’t appear.
I’ve disabled tuya just to be sure that it won’t interfere but I still have an issue appdaemon not working. but thanks for your help so far it seems that I might need to completely remove the configuration and start over.

Are you still configuring via yaml for the homeassistant section? If so, follow @Tinkerer’s correct documentation link and place internal_url and external_url in that section.

As for appdaemon, did you update that as well? Did you move from appdaemon 3 to appdaemon 4?

when I follow @Tinkerer’s example I get this result.

2020-11-10 19:49:11 ERROR (MainThread) [homeassistant.components.hassio] Component error: external_url - Integration ‘external_url’ not found. Component error: internal_url - Integration ‘internal_url’ not found.

as for appdaemon I’m not sure atm I do believe I was at 4 and just had a smaller version update of that one.
I’m thinking that it’s my https configuration that is somehow problematic atm as I think that is the one preventing my Appdaemon and causeing my headages with the error’s in the log.

somehow it feels like something might had gone wrong in my upgrade.

That’s an error telling you that external_url is not an integration. It goes inside the homesistant integration.


external_url: ....


  external_url: ....

This is most likely due to your internal_url or external_url not being set correctly.

Every single attempt at putting the external_url: in to it even the way you just told me fails. and I can only start it up when I go back to the old base_url that I keep getting told not to use.

Last time I updated was last Christmas so I’m thinking wasn’t there something about something changing with the docker image ? could it be that I’ve corrupted my docker image by upgrading because I was on a too old version ?

Are you sure you’re not running into other new issues? last Christmas was version 103. There have been at least 10 major breaking changes between then and now. I think you’ll have to post each error that you run into if you can’t figure them out yourself.

As for appdeamon, that was definitely 3 at the time because 4 was released in January 2020. And that update had a completely rewritten configuration model.

EDIT: Edited the appdaemon version numbers…

only issues I’m running in to is my configuration.
and I’m pretty sure the last update I did was just after app daemon was upgraded to 4 because that was quite an ordeal to handle. maybe I’m remembering wrong about Christmas.

I’ve just enabled info in the log and the only warning I get is that one deprecated base_url
however I’ve disabled most of my original configuration to focus on only the https part. so that might explain why I’m only having that one issue ?

I’ve just backed up all my configurations I’m really thinking hard about just removing docker, and all images of home assistant as well as all addons.
and then start over completely getting https to work as the first thing and then slowly adding each part of my original setup.

It’s not a bad idea. I did that when upgrading from 0.32 to ~0.74ish.

Oh my seems that running docker the way I used to is no longer supported. Sure I can get core up and running but my supervised is gone. I guess I have to start playing with some sort of full fledged

It seems like every time I was upgrading, there were breaking changes that I had to work on, sometimes for days. I finally made the decision to stick with 112.4 since the added benefits weren’t worth the hassle of the upgrade. I have 2 other friends in the same boat. I’ll be left in the past with my classic build unless there is some security issue.

Docker is still supported, it’s now called Home Assistant Container. See HERE for an excellent post describing the current installation methods.

If you want the Supervisor, you have a few options. I can’t see what sort of machine you are using, perhaps I’ve missed it, so 2 options posted;

If you have a Raspberry Pi, you can use the official docs HERE and install Home Assistant OS, or you can run Home Assistant Supervised by following this guide.

If you are using a PC, Laptop, NUC, one option is to run Home Assistant OS as a virtual machine using Proxmox , or run Home Assistant Supervised using Debian 10.

1 Like

well I’m using a Ubuntu 20.04 lts

server that I have running anyway. I used to run a docker container with Home assistant on it but that broke so now I tried to reinstall rather than spend time on fixing the upgraded mess.

problem is that would give me a Home assistant core only no supervisor.
so now I’m on with your other suggestion to install an actual virtual machine on it… liked the low footprint of docker but I guess this is what I got.

yea I’m beginning to feel the same way. :frowning: but was already stuck on a very old version when I decided to upgrade as I was thinking it would be a good idea to fix my other issues. Guess what I just got tripled up on issues.