Finding offline key using August integration for use with the Yale Access Bluetooth integration?


I have the August integration installed in my Home Assistant to control two Yale Doorman automatic door locks. It works great but since a recent update HASS also finds the locks using the Yale Access Bluetooth integration.

When configuring the automatic discovered devices using the Yale Access Bluetooth integration you need to input the locks 32-byte hex string. In the documentation it states that this can be found in the iOS or Android Yale or August Access app. However, this requires root access on Android which I do not have on my Pixel 4a. The other alternative is using the August integration because it

will automatically provision the offline key if the configured account has the key loaded. You may need to create or use a non-primary existing account with owner-level access to the lock, as not all accounts will have the key loaded.

I do not understand where the 32-byte hex string is found in the August integration? I have used the option to downloaded diagnostics but in the config_entry-august-XXX.json.txt file downloaded it states OfflineKeys": "**REDACTED**".

Where can I find the 32-byte hex string in the August integration?


You can only view it with a rooted android. If you have the august integration and have enabled auto-unlock the key will be found automatically overtime. My 2nd lock on the back door took about 2-3 days of having the auto-unlock turned on and work before the Yale Bluetooth integration found the key.

And with automatically you mean it won’t ask for the key when adding the discovered device? Maybe I’ll just let it sit a couple of days then…

Yeah exactly. After I setup my backdoor to auto-unlock. The documentation states it only gets generated when the auto-unlock has been enabled and has been activated. I would just check it once a day and then all of a sudden it found my key and connected the lock.

I just upgraded to the latest version of HA and it was captured immediately.

Hmm I wonder if HA needs to be rebooted after the key has been generated by the auto-unlock…
@n0ir if you check again and it still doesn’t see the key maybe try rebooting HA

I’m still a little fuzzy on the work flow now. It seems after adding the key, everything works the same in all of my automations and I didn’t need to make any changes. The lock just uses bluetooth now instead of the cloud when communicating with HA correct?

My bridge is still necessary for things like auto-unlock and using the app itself when I’m not home correct? just wanted to confirm

I have installed August integration and then the Yale acces Bluetooth. This one found the key automatically because i have auto-unlock in use.

I would like to know where in home assistant files is stored the key, because now I have the two integrations installed and I would like left only the Yale one, and to accomplish that I need the key and the slot.

Some body know where is it stored?
Thanxs in advance.

Turn on debug logging for ‘yalexs’. The key isn’t redacted in the log

1 Like

Can I just confirm - should the key appear within the diagnosis of the integration? I’ve followed the HA guide which is to log the August Integration in as a non-primary Owner but still getting the same as @n0ir. Next Step is to backup the iphone iMazing and check the preferences library

The key is not shown in diagnostics, its redacted there.

It is only in the raw logs for the library.

1 Like

I can’t seem to get the Yale Bluetooth integration to recognize my key.

I located the offline key in my Home Assistant logs after enabling debug logging for the August integration.


When I enter my offline key and slot number into the Yale Access Bluetooth integration config, I get an “Unexpected Error” message in the UI and the error below populates in the HomeAssistant logs

2022-10-07 15:55:02.958 ERROR (MainThread) [homeassistant.components.yalexs_ble.config_flow] Unexpected error
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/yalexs_ble/", line 189, in async_step_user
    await validate_lock(local_name, discovery_info.device, key, slot)
  File "/usr/src/homeassistant/homeassistant/components/yalexs_ble/", line 47, in validate_lock
    await PushLock(local_name, device.address, device, key, slot).validate()
  File "/usr/local/lib/python3.10/site-packages/yalexs_ble/", line 360, in validate
    await self._update()
  File "/usr/local/lib/python3.10/site-packages/yalexs_ble/", line 86, in _async_wrap_operation_lock
    return await func(self, *args, **kwargs)
  File "/usr/local/lib/python3.10/site-packages/yalexs_ble/", line 107, in _async_wrap_retry_bluetooth_connection_error
    return await func(self, *args, **kwargs)
  File "/usr/local/lib/python3.10/site-packages/yalexs_ble/", line 370, in _update
    async with lock:
  File "/usr/local/lib/python3.10/site-packages/yalexs_ble/", line 61, in __aenter__
    await self.connect()
  File "/usr/local/lib/python3.10/site-packages/yalexs_ble/", line 80, in connect
    self.client = await establish_connection(
  File "/usr/local/lib/python3.10/site-packages/bleak_retry_connector/", line 450, in establish_connection
    client = client_class(
  File "/usr/local/lib/python3.10/site-packages/bleak/", line 315, in __init__
    self._backend = PlatformBleakClient(
  File "/usr/local/lib/python3.10/site-packages/bleak/backends/bluezdbus/", line 57, in __init__
    self._device_path = address_or_ble_device.details["path"]
KeyError: 'path'

I got the same error as @dberg2
OfflineKeys and slotnumber from home-assistant.log doesn’t work.


Did anybody find a solution?
I’ve iOs and I tried to download the backup plist files but I can’t locate this key … Any idea?

1 Like

Hi there,

I switched Logger to debug but not seeing anything.
Could you describe how you switched the debug logging on please?



  default: info
    yalexs: debug
1 Like

Same error here as well. Anybody found any solution to this?

Create a second owner account, give it access to the lock, activate auto unlock at least once, and then setup the account in HASS

Is it only for me the integration have gone bonkers after the recent update? I now receive a never ending flood of devices (71 and counting!) from the Yale Access Bluetooth integration. :frowning: