Finding offline key using August integration for use with the Yale Access Bluetooth integration?

I’ve got two HA boxes both running the August integration Box 1 - Primary Owner. Box 2 Secondard Owner. I’ve turned on logging on the Box which has the non-primary owner, copied the key and slot - can’t get it to work.

Interestingly when the yale BT integration autodiscovers Box -1 no key or slot required. But the integration never initialises. If I delete the uninitialised integration, it then asks for the key and slot which I got from Box 2 - no dice again

I also read that some users were having issues getting this to work off a ESP home BT proxy (which I am running on one of my systems), but have tried BT from Box (pi4) direct to the yale - again no good


Guys, I have a big doubt… I was convinced that I could use HA’s bluetooth integration to avoid buying the gateway, however at this point I have a doubt that it is still necessary. Can anyone give me this info? Do you all use gatweay as well?

Never mind, I just updated HA operating system and it took the integration automatically without any key…I just don’t understand.
In any case I confirm that it works without Gateway!

1 Like

I have now followed this exactly but still not working.

I think my problem is that I did a test run with my lock not installed on the door and a esp proxy node when the function came out in the last release over a month ago. I then actually got the key synced and the lock managed to be added into HA. Ofc the problem was the esp proxy node wasn’t working with the lock fully so I deleted that, removed the esp proxy node and factory reset the lock. I then ordered a proper usb bluetooth adapter that was supported, installed the lock on the door and tried to integrate it again but that was when the problems started.

Could It be that my old key is messing something up? Is it stored in .storage somewhere?
I have deleted the .yale.conf file in the config folder but that doesn’t seem to help.

That looks like you have the key, you can verify by looking in .storage/core.config_entries but the ESP proxy is having trouble

Watch Disconnect ble device if connect attempt fails to recover slot by bdraco · Pull Request #293 · esphome/aioesphomeapi · GitHub and reflash your esphome device with the dev version once it merges and it should be a bit better

Please forgive my complete ignorance but I have Wireless-Tag WT32-ETH01 which I flashed directly off.
ESPHome Bluetooth Proxy - will this dev version work with this board? Would I then need to complie it into a BIN and flash using ESPFlasher or the like? Or would this dev version become a prod version of the site I mentioned above?

You need the latest dev version

git clone
cd esphome
pip3 install --upgrade .
esphome compile your_yaml_file.yaml
esphome upload your_yaml_file.yaml

Although for that board you’ll have to adapter that to work with How I installed ESPHome on the wt32-eth01

Sorry guys, I am still confused on how to obtain the key. Do I just need to turn on Auto-Unlock in my August app and then wait a little bit? Then when I try to configure the lock in HA it won’t ask me for the key anymore? Or do I still need to find the key manually somehow after turning on Auto-Unlock?

What is the easiest way to get these working?


Cannot get the integration to work…


I guess I’m just as confused as you are. I have the backup from my iPhone and I have no idea how to find the data. I’m browsing the, looking in the plist -files with no luck so far


Also dealing with that issue here.

You may try here :


But it seems you need to root your phone first. I tried the all day yesterday with no success.

Infos here :

So I let if fall and tried to get that damned offline key with the August integration (creating a new August Account with the Android App, on another phone (not mandatory I guess), then inviting “me” with the first phone (to get all the infos on the second phone), went to August parameters set yes to auto-unlock, went 200m away from my house, get back, saw the notifications about “auto unlock” (but it didn’t physically work…), and then only, adding August integration to HA.

Now it found the key automatically (just added the integration) and let appear my lock, and I could find the key in the log (put the general log to “debug” in the YAML), and make a search on “yale”.

Anyway, now I got another error about Bluetooth.

Edit : now everything is fine (or so : huge latency of 7 to 10 seconds when asking lock/unlock).

I’m on a miniPC with VMware. I’ll open another thread that could help people being stuck passingthrough USB-Bluetooth.

I’m in the same boat - got a Yale Unity Lock with Connect Bridge. Yale Bluetooth access integration discovered it but I cannot get the key - I don’t have rooted Android and my wife’s iPhone does not have any Preferences.plist file or Library folder. I looked in all the plist files having done a backup with iMazing but no slot or key associated with Yale. Yes, auto-unlock has triggered for both.

Now I restarted HA and all of a sudden the unconfigured integration has disappeared and if I try to add it, it says no unconfigured devices found. :confused:

Any reason you can’t setup the August integration and let it populate from the cloud service?

Mmm, well thanks @bdraco - the relationship between Yale and August was not clear to me, so I was battling with the Yale approach, as in Australia there is only Yale I believe.

So, I installed the August Home integration and now I can see 4 entities - thanks so much, now I can play to see what’s possible

So to understand the differences, I believe the August app is using cloud control to manage the lock, whereas the Yale Bluetooth access app is local bluetooth control?

Is that right?

The august cloud integration is cloud based and the bluetooth integration is local

So today the Yale Access Bluetooth app has again discovered the lock. I can’t get the keys from Android or iOS, so should the fact that now I have the August app mean that the offline keys will auto populate to the bluetooth integration at some point?

Setup the august integration while the lock is in range. If the lock isn’t in range while it’s setup, reload the integration afterwards.

The stated range on these locks is 20ft but may be worse if you have interference of any kind. If you can’t get your Bluetooth adapter close enough you might consider an esphome Bluetooth proxy.

I’ve read over getting the Offline Key here. It is a little clunky though, especially if you have more than one August Lock. The August app only allows Auto Unlock to be active on one lock at a time, which requires faffing about to enable it on the one lock, wait for the key to be picked up, enabling it another lock, etc etc.
Rooting an Android phone to find it from the phone is not really a solution either. It’s not a solution for most mainstream users, and there are a lot of them that use Home Assistant now.
I am guessing it is a limitation with August, but it just seems like a lot to go through just to get a lock to work via Bluetooth.
I wish there was a better way…

Regarding range and BT proxies with the August locks, which really is an entirely different topic, but don’t expect the August lock to be reliable further than about 10 feet, even with no obstacles in the way. The locks work very well with BT Proxy or with a CSR Bluetooth 4.0 Dongle (haven’t tested with any BT 5.x ones) , but needs to be pretty close. Over that 10feet mark I found some major delays and unreliability.

Where exactly in the app do I look for it ?

1 Like