Fireangel fire/CO/heat alarm network bridge integration

Have recently moved from my Raspi4 setup to a dell SFF PC and now all the serial port problems have gone away. Smoke Alarms are all connected and responding well. :slightly_smiling_face:

I’ve finally had some time to get this giving messages into HA properly. I notice that the majority of messages show up fine but some show up like this with random characters missing:

image

Is this a problem or … ?

So I was doing some digging online as I can’t they keep their API so hidden.

And I stumbled upon this…

Either someone has been doing some very advanced work on this, or it was a dev who was lazy

But this appears to be the connection to the fireangel API

If you look at the guys other projects he is setting up web sockets to read sensors from the api

Hi @chopwood,

I’m facing similar problems with not getting the INIT OK message - SPI buffer was completely empty and the Nano is constantly rebooting.

My latest iteration to fix this includes your jumper wire fix over the level converters, but I’m still not receiving any message back from the radio.

I’ve connected the Nano up to a USB 2.0 port, gone through 5 different level converters using 2 different vendors, bridged the battery connection on the radio, used an official Nano and Nano Every, swapped the init command in code to the second version and back again a number of times and nothing seems to work.

The radio is powering on - I do get a solid flash from the onboard red LED when the Nano starts up and then periodic flashes of the LED every 3-4 seconds. I’ve plugged the radio back in to the FireAngel strobe I got from eBay, unpaired, repaired with my network and validated it responds with a test from the fire alarms so I don’t think anything is wrong there.

I did manage to get it once to respond with an INIT OK and a couple of heartbeats, but the next reboot of the Nano and I was back to square one. This makes me think that the ‘signal’ from the radio is not being ‘seen’ by the Nano as you described, in the 99% of cases.

Any ideas on what I could try next?

And the back of the board (forum doesn’t allow me to upload multiple photos in one post :man_shrugging:)

Slightly embarrassed with my soldering skills, but I don’t see anything immediately wrong with it.

For some reason loading the JSON into EasyEDA or the Gerber file in the website doesn’t seem to work for me - the boards simply don’t load/appear… not obvious what I am doing dumb!

In the off-chance, does anyone have any spare printed PCBs in the UK still?

I had the same problem. the level converters solved my problem. Out of frustration and because I still had a spare radio, I removed the level converter from the circuit diagram. has been working for over a year without any problems. Greetings Matze (sorry, Google translate )

Sorry, I was asking if anyone happens to have any spare physical PCBs in the UK? I just cannot get easy-eda app (json file) or website (gerber file) to load and print for me for some reason and given the min order is 5, figure someone may have a spare!

My PCB’s arrived today (central Scotland) I have 3 spare PCB’s, if you want one send me your details!

Thanks very much - have sent a message!

Still have 2 PCB’s left for anyone that wants one! Also happy to 3D print an enclosure to go along with it for a small charge. DM me.

All built and set-up in Home Assistant with no major issues and already more stable than the official hub ever was! I run HA on an unraid docker and the arduino passed through fine also I am pleased to say…

Thank you to the tremendous efforts on the project and @murrayscott for providing me a PCB and enclosure so quickly :slight_smile:

1 Like

One question - does the fireangel control panel require the hub to properly function? Mine seemed to still be working fine but just now got the yellow and red flashing lights which I assume is a not connected warning of sorts…

Not a massive deal if not easily addressable but still useful to have as part of the network if possible and maybe I just need to manually unpair the old hub from the network or something?

This is exactly what I have been looking for. @murrayscott Do you still have any of these boards available. Unfortunately im new to these parts and therefore cannot DM at the moment. Not sure if i can reply if you DM me though.

It’s not quite your scenario but I tried to wire my connected pro via both wisafe2 and wired at the same time for a belt and braces approach.

It continually reported AC error until I disconnected the wire . Their support desk said it’s not supported to be both wired and wireless at the same time for the same unit.

Did you have any success using the Mesh Monitor to receive and transmit data to the Wi-Safe2 devices? Do you have any details on the device? Is is FTDI serial port? I’m interested to see if could be used as an alternative to ws2mqtt.