First time instalation on Raspebbry 4 B - not working

Decided to go for HA, purchased Raspebbry 4B, 32GB SanDisk Extreme card.
Dowloade the 32bit image and flashed succesfully to SD card using balenaEtcher.
Put the card into RaPi and connected power. And…

  1. Waiting even 1 hour not able to connect to http://hassio.local:8123/
  2. My router does not see any new connection
  3. On the RaPi only yellow LED is blinking (for some time stays solid ON and sometimes is flashing) - it is LED on the right looking at the board from the USB and LAN port side.

Any ideas what I am doing wrong ?

Maybe you should scan for the IP of your RPI not all routers can handle names. so try http://192.168.x.x:8123 instead of what you are using.

Thanks for quick response.

As much as I understand networks, RPI (and any device connected to network) shoudl get IP adress from my router (DNS host). And when I login to my router and check connected devices - there is no RPI. Actually there are no new devices connected (I can see those devices which I know).
So I suspect the network adapter on RPI is not “started”.
Also the green LED on RPI is not blinking at all (it is my first RPI ever so I have no exerience) and according to documentation it shoudl blink when RPI is doing something - in my case green LED does not blink at all.
I will try to install regular RPI Lynux and see if this will work - to check if my RPI is OK.

Let me share next steps I am taking. As I suspect that RPI is not booting I did the check described here: - remove/disconnect all the devices including SD card and connect power. The green LED shoudl “blinks with a repeating pattern”. This is not the case on my RPI, which means that either bootloader EEPROM is corrupted or the RPI is broken (however red power light is on and there are some blinks on Ethernet connected cable).
I have tried to reload/recover bootloader EEPROM with no success so far.
So, at this point I will be contacting the seller to replace my RPI :frowning:

Perhaps insufficient power?

Perhaps before you try with Hassio you should try using Raspian with desktop so you can connect a tv to the hdmi port and confirm that your Rpi is working ok. You can flash the same or another SD card using etcher.

With a screen attached to the pi you can see if there are any errors on boot up.

Thank you all for ideas and support.
I was going the way as suggested by BertrumUK and trying to install Raspian - no success. Then I was debuging based on info from Raspberry official site and I got to the conculsion that my RPi is broken - at least bootloader EEPROM does not work and cannot be refreshed using Rescue procedure provided.
So I have now returned RPI do the seller (by post) and waiting for another one. Also have contacted seller to check nect unit before the shipment. RPI just connected to power (with nothing else) shoudl have red LED on (power) and green flashing regulary (indicating that EEPROM is operational and missing"start-up" file. In my case the green LED was dark except very super short blink while connecting power.
And nickrout, power shoudl be OK - 5V 2,5A with no other peripheliast connected shoudl be OK. Also RPI (based on documentation) would blink red LED in case there is not enough power - which was not my case.

Maco, you have received some good advice above and I approve the steps you have taken to verify everything is okay.
Going back to Nicks post, and yours previous to that, it should have the green blink.
We have all had duff power supplies and others we have inherited. Some even say 2.5 amp on the side. Still, they don’t wanna play
Did you buy it at the same time.?
It may be the pi, but I’ve bought approx 12, never had a duff one (I’ve made them duff, but not from new :crazy_face:)
Good luck

1 Like

Where did you get the power supply from and what brand is it?

Pi4 should have a 3A power supply.

1 Like

I have used 2,5A USB supply from Apple (provided with my iPad 2 or 3 - do not remeber). I assume the quality shoudl be OK and real 2,5A can be provided.
Especially when I connect only SD card and Ethernet cable. On offical RPI site it says: “* A good quality 2.5A power supply can be used if downstream USB peripherals consume less than 500mA in total.” (
New RPI is on the way and the previous (duff one) is on the way to seller - he will do his own chek. The new one shipped to me has been checked before shipping.
With new RPi, I will use lab power supply to make sure it is OK and also to actually see/measure how much power it cosumes with just SD card and Ethernet cable in.

Charging plug packs are not recommended.

Even USB-c packs that support with Power Delivery are not recommended

I would say get a good quality 3A power supply as the place I got mine from said the Universal Power Supply they sell is made by Made by Stontronics, rebranded as OKDO that made the older Official Raspberry Pi Power Supplies and was solid performer.

If you are curious, this power supply is made by Stontronics and rebranded as OKDO. The original Stontronics supplies for the Pi 3B+ were the official power supply and 100% top performers. No lighting bolt issues!

  • A good quality 2.5A power supply can be used if downstream USB peripherals consume less than 500mA in total.

The best I could find was a 2.4 amp charger for the 3 the 2 looks like it was 2.1 so 100% it would be the problem.

I tried a USB power meter on mine and the first cable I used was a cheaper one and it caused the lightning bolt show so I tried a better name branded cable and it was fine no lightning bolt so it is you get what you pay for.

1 Like

Mine charger is like this: and apologies, I coudl have mixed it with some of the iPhones I have (so it may be not from iPad…).
It seems there are some issues with cables (the way I understand is that “less intellignet” the cable the better:
Now I have investigated my cable and this might be a bottlenect as it says max A = 2,1A :frowning: So it seems I need to look for another one.
However, powering the bare-board (with nothing connected and no SD card) shoudl consume 0,6A - and this was what I was testing with no success. Also on RPi pages it is stated that RPi 4 can provide maximum 1,2A from its USB ports. So, with 3A power provided it can supply out 1,2A to USB - which to my simple logic menas that with no USB devices connected, power consumption of RPi shoudl not be more that 1,8A.
I know this is risky path and long term I will provide 3A (or more) from good source and via good cable. I am just trying to say that it is very unlikelky that power was the problem with my case.

Apple chargers in particular can be troublesome since they try and ‘negotiate’ what rate it outputs for charging. if the attached device does not participate in the handshake then the charger defaults to a lower current.

I’m 68% sure your problem stemmed from the power supply you are using. Home Automation is not a cheap endeavor. Dont start with your power supply.

I agree, most problems with raspberry pis in any setting are a result of the power supply. It may not be your problem. But is is likely.

1 Like

We will see when next usint will come in few days. I woudl only say that at least in my country Apple accesories are on the oposite of being cheap. :slight_smile:

Thank you for all the warnings and advices - I was not aware how important power supply is for RPi4. Will take care of it. My plan is to use my 12V batteries (which are part of UPS) as the source and then connect 5V good quality regulator - this way RPi will be powered when blackout is from my provider.

Dear All,
Today I have tested new RPi4 and at this stage it does properry indicate its status with green LED onboard. When connected to power supply bare board consumes 350mA which mans 1,75W of energy.
And it works on both lab power supply as well as on Apple 12W adapter.
Today afternoon will install and make next steps. Will also measeu the energy consuption with SD card and Ethernet cable in.

Update: succesfully installed ! :slight_smile:
Power consuption with 32GB SD card and Ethernet cable connected with no activity on web interface = 480mA which is 2,4W

Case closed. Thank you again fro all help and support provided.

Best to add this if you are going to use a power supply that is not recommended as it’s can be affected by the voltage too.

1 Like

I use that component as well. I would also strongly recommend to the OP to add an automation so you can be notified the minute there’s a change in readings.

Good luck!