Fix Home location?

Running 0.105.2 in docker.
My Home location is off and I want to fix it.
Updating the coordinates in configuration.yaml did not move it at all.
Also I added 3 zones via the GUI, but do not see them stored in the config file either.
Where are they stored?
In the GUI the Home location is not editable either.

Thus my question, how do I fix the home location?

1 Like

Zones added from the GUI do not get stored in your configuration.yaml file, they get stored inside of the .storage folder (which you normally shouldn’t poke around in).

If you are attempting to edit Home zone from the Zones editor, you cannot do that (yet), it has to be changed in Configuration > General section. There’s a little mini map there which you can drag the pin around to change home location.

Or if you have the home zone defined in configuration.yaml (which it seems you do?), it will use that instead. But we’d need to see that part of your configuration.yaml file in order to help see if you did things right (but be sure to censor out any private details like your coordinates first).

2 Likes

I had it first entered here

default_config:

  name: Home
  # latitude: x.x
  # longitude: -x.x
  elevation: 240
  unit_System: metric

I later tried to update them and then comment them out, but it looks like the .storage value is overriding the config settings.

Your instructions work, but seem convoluted.
It would be better to have the Edit pencil enabled in the Configuration Zones section of the GUI and link it to the Configuration General section…

Thanks a lot.

No problem. I agree the current way is convoluted, I already suggested a very similar idea last week on the Frontend repo (https://github.com/home-assistant/home-assistant-polymer/issues/4786). It’s going to be worked on and made easier soon.

As for your YAML config, you needed to have those items nested under homeassistant: like this:

default_config:

homeassistant:
  name: Home
  # latitude: x.x
  # longitude: -x.x
  elevation: 240
  unit_System: metric

That’s why it was not working, you were missing one line.

YAML gets priority over the UI, so if you do update your YAML to the above (with your real coordinates of course :stuck_out_tongue:), it will disable this stuff from being changed in the UI until you comment out these lines.

2 Likes

Thanks Sean,

For completeness;
unit_System parameter needs to remain under default.

default_config:
  unit_System: metric

homeassistant:
  name: Home
  latitude: 9.9
  longitude: -9.9
  elevation: 99

I would just like to be able to control the size of the radius. When I go to Zones and look at my home location, it covers the next street over.

Hopefully they will fix it so it can be edited in the Zones section.

great… then i’ll wait to change the location^^

I found this thread because I wanted to change the radius around my house.

I added the following to my configuration.yaml:

# Override home radius
zone:
  - name: Home
    latitude: !secret latitude
    longitude: !secret longitude
    radius: 150
    icon: mdi:home

…and I just ended up with a duplicated Home zone:

As above… I wish the Home zone edit function worked. Any tips on how to update this? If I wanted to change my home location, I guess I’d have to redo the onboarding procedure for starters… but for now, I just want to change the radius.

Did you read the note above from SeanM that sys the zone definition for home has to be under homeassistant:

Yes, and in fact I still have it there:

homeassistant:
  name: Home
  latitude: !secret latitude
  longitude: !secret longitude
  elevation: !secret elevation
  external_url: !secret external_url
  internal_url: !secret internal_url
  packages: !include_dir_named packages
  currency: USD
1 Like

Hey everyone. This is where it gets weird. I have the exact same error message but I don’t have my zone configured in configuration.yaml. In fact I don’t seem to have neither latitude nor longitude anywhere in *.yaml files.
How do i fix that?

Hello Brilliant idea Thank you

I live in an very old village in italy and many houses are linked together…
My usecase;
When i leave i use the home" location (that has a radius of 100 m) and all works fine. everything shuts down.

However I would like to add a larger Radius say 200 meters *calle it home 1) and have everything turn on. How do i do this (in zones i did create 2 zones but it does not seem to work.

To compound the issue (yes i do understand the trip the gps signal has to do) is that many times i amt the gate of my house and the automation still did not start. as i disimbark of the car the automation kicks in. I could probobly increase the radius

Any thoughts on how to correct this?

Thyank you in advance

wbravi,

I am newish to Home assistant, I am looking into this at this point. But I would create a Radio of 200m call it “travelingToHome”. See if that works to launch your automations. From what I have seen HomeAssistant takes a minute or two to launch Automations.

I’m doing this in customize.yaml:

# override Home zone
zone.home:
  latitude: xx.xxxxxxxxxx
  longitude: xx.xxxxxxxx
  radius: 200
  icon: mdi:home

I learned the hard way not to reference lat/long indirectly with references (to secrets.yaml, for example).

Thank you allfor your suggestions
@DeltaNu1142 does this mean i can insert 2 zones in the coinfig yaml.

Althogh i’m not very confortable in yaml I will try this

zone.home:
latitude: xx.xxxxxxxxxx
longitude: xx.xxxxxxxx
radius: 200
icon: mdi:home

zone.home1:
latitude: xx.xxxxxxxxxx
longitude: xx.xxxxxxxx
radius: 400
icon: mdi:home

On a seoerate note i just changed my phone for an s10 I have an automatio to leave and one to arrive. If i manually run the automation it works. However when i leave and go beyond 200 meters the automation is not triggered.

I have owntracks on my phone properly configured and my phone has location tracking turned on and so is mobile wifi. what am i missing

oncve again thank you all

Yes, I believe you can. Although, I manage the remaining zones (the ones that are not home) through the UI, in Settings → Areas & Zones → Zones.

thanks i’ll try

Hi Tried

when i go to check configuration i get Invalid “domain zone.home:” and the same error for zone 2

I inseter these line in the configuration.yaml is trhis correct

In my setting zone I have

Home which has an house icon
arbahome that has a pointer icon
user beyond1 - home ( i don not know where this come from)

I suggest you define your zones through the UI.

DeltaNu1142, question, we do you same define the zones through the ui? Just curios, I just created a few new zones via yaml, and its much easier - and precise. I have several zones created from the UI.