[FIXED] MiLight LimitlessLED basic light setup not working

Hi, I’m finding even basic configuration of these lights is failing for me. Am I doing something obviously wrong here? I am new to HomeAssistant.


  • Hass.io 0.52.1
  • Milight v6 controller, the one with an integrated light.
  • Kitchen:
    • 4x GU10 white/warm white, bound in Milight app v3, to the first ‘virtual remote’, all on tab/group 1 in the app. On/off works from the app, all four come on and off together.
    • 1x E27 RGBW bound in Milight app v3, to the FIRST ‘virtual remote’, on tab/group 3 in the app. On/off works from the app.
  • Study:
    • 1x E27 RGBW bound in Milight app v3, to the SECOND ‘virtual remote’, on tab/group 1 in the app. On/off works from the app, though have to change to the second virtual remote obviously to do this.

For some reason I am unable to bind the study bulb to the first ‘virtual remote’ in the app, I had to add it to a second remote… don’t know why, just wouldn’t bind to the first remote. I have found this happens for other bulbs also. Any ideas?

My configuration.yaml:

  platform: limitlessled
    - host:
	  version: 6
      - number: 1
        type: white
        name: Kitchen
      - number: 2
        type: rgbw
        name: Kitchen table
      - number: 3
        type: rgbw
        name: Study
      - number: 4
        type: bridge-led
        name: Bridge Light

I have listed in HomeAssistant on the home page:

Bridge Light
Kitchen table

‘Bridge light’ and ‘Kitchen’ on/off works, ‘Kitchen table’ and ‘Study’ do nothing. I have no idea how the bridge light and kitchen group of 4 happen to match up to the correct group of lights from from the app? is this the order or tabs across the top in the app matches 1, 2, 3, 4? I can’t see how if that’s the case, as the Bridge light has it’s own section in the app and is not included in the 4 tabs.


The following errors have been logged this session:

2017-09-03 10:48:52 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=27 from 2017-09-03 09:11:23.626842)
2017-09-03 10:49:03 WARNING (MainThread) [homeassistant.setup] Setup of sensor is taking over 10 seconds.
2017-09-03 10:49:06 WARNING (MainThread) [homeassistant.setup] Setup of switch is taking over 10 seconds.
2017-09-03 10:49:06 WARNING (MainThread) [homeassistant.setup] Setup of light is taking over 10 seconds.
2017-09-03 10:49:13 WARNING (MainThread) [homeassistant.setup] Setup of tts is taking over 10 seconds.

Hoping someone can advise… I’ve spent 4 hours or more trying to figure this out. The docs/guides on limitlessled and HASS seem very sparse.


1 Like

Are the bulbs in the kitchen and the study the same type?
I suspect they are not as the various virtual remotes are for the different types of bulbs, which explains why you needed to use the second one to connect the study bulb.
For the same reason you need to indicate that in your code in HA. Indicating rgbw, rgbww or white - see the docu for the limitedless component for more details.

Thanks DDK, you’ve helped solve part of the puzzle. I went back and checked my RGBW setting… they were RGBW and should have been RGBWW. I now have working kitchen lights in two groups, one of 4x GU10’s and one of a single RGBWW. [EDIT: this was a bit of red herring, and not how it was resolved in the end… see my latest post… I was using the wrong ‘virtual remote’ for these lights, and my lights were rgbw not rgbww so I reverted this back]

The study light is the same type as the single RGBWW in the kitchen and is bound to the second virtual remote (as it will not bind to virtual remote 1, I don’t know why), but will not work in HomeAssistant. Do I need a second set of configuration for the second virtual remote?

  platform: limitlessled
    - host:
      version: 6
      - number: 1     # This just happened to be correct first time I tried. Do these correlate to the tab positions in the milight phone app?
        type: white
        name: Kitchen
      - number: 2  # I was hoping this would be the Study light... guess not!?
        type: rgbww
        name: Study
      - number: 3    # This I renamed to Kitchen table once I found out that it turned on this light
        type: rgbww
        name: Kitchen table
      - number: 4   # This just happened to work first time. Don't know where it gets #4 from? In the phone app it has it's own page and is not on one of the 4 tab groups.
        type: bridge-led
        name: Bridge Light

Finally sorted it… for anyone setting up LimitlessLED lights on a V6 bridge, here’s my working process and config to get you running.

General Overview

  1. Install the MiLight phone app
  2. Connect the bridge to your network/phone
  3. Link bulbs to one of 4 groups on phone app
  4. Add config to HomeAssistant’s configuration.yaml file

Install MiLight app

Install from your store of choice. I used v3.7 from the Google Play store.

Connect the bridge to your phone/network

  1. connect phone to home WiFi
  2. open MiLight app
  3. click + to go to configuration
  4. smart link
  5. enter home WiFi ssid and password
  6. press reset button once on bottom briefly, the two lights will start flashing
  7. press Start Configuration button on app
  8. it should say ‘Success’
  9. lights will go solid then one will slow flashing
  10. press back on the app
  11. press ‘Searching for device’ at bottom of screen
  12. your bridge should now be visible in the list, click on it to get into the configuration

If you want to get to the webmin console for your bridge, use ‘Advanced IP Scanner’ program or similar network scanner to locate the IP address. username: admin, password: admin. It’s a good idea to go in in there and set a static IP address for your bridge.

Link/bind a bulb

Before you can use HomeAssistant to control your bulbs you have to pair them to the phone app. This sends the config to the bridge. Once linked you don’t have to use the MiLight app at all if you don’t want to.

Pair your bulbs to the relevant 4 zones (tabs) along the top. These are the four groups that map to the ‘numbers’ in the configuration.yaml. For example the first tab or zone in the App is ‘- number: 1’ in configuration.yaml.

Make sure you choose the relevant logical remote control in the app for your lights. I messed around for hours and hours trying to use the default remote that had colour and colour temp.

  1. once the bridge is connected to your phone and network
  2. open MiLight 3.7
  3. click on the MiLight device
  4. you will see the 4 zones along the top
  5. click the two arrows icon in the top right to choose the relevant remote type for your bulb
  6. back on the main page, click the chainlink icon in top right corner to get to the Link/Unlink page
  7. unlink the bulb first (if you have already used it before)
    1. turn the light you want to connect to off and back on again at the wall
    2. within 3 secs press the red Unlink button
    3. light will flash 9 times and will now be unlinked
  8. select the tab/zone along the top for the zone you want to put the bulb into
  9. turn the light you want to connect to off and back on again at the wall
  10. within 3 secs press the green Link button
  11. light will flash 4? times and will now be linked
  12. go back to the main page and you can control it.
  13. Repeat the linking process for each bulb you want connected to the same group, ie. 4x kitchen lights all connected to the same tab.

I Have:

  • 4x GU10 ww/cw bulbs for the kitchen spotlight fixture, assigned to zone 1 on the app using the 10th remote control along from the left; it’s the white only with 4 blue groups buttons at the bottom.
  • The remaining bulbs are all E27 RGBW added to the relevant zone using the 2nd remote control from the left in the MiLight app v 3.7; this is the colour-only remote with 4 yellow group buttons at the bottom.
    • Kitchen table, also added to zone 1, but from the colour only remote stated above. This appears to allow me to independently control it even though it’s on the same zone as the 4x GU10 bulbs. This is because they’re of a different ‘type’, ‘white’ vs ‘rgbw’ (see the config below). This is explained in LimitlessLED example page on the HomeAssstant webpage, though didn’t explain it very well.
    • Lounge & Hall, both are bound to zone 2
    • Study, bound to zone 3
    • Bedroom, bound to zone 4

Other Tips I found on an article on the LimitlessLED website that might be of use:

We also had some feedback/tips from users:
Tip#10. I had to use the LimitlessLED v1.7 app to connect the bridge to my LAN, then it worked, thanks.
Tip#11. I had to use the correct remote screen in the app for my particular RGBW LEDs to sync, thanks.
Tip#12. I had to clear remote code pairing using section 3.3.5 of the manual, and then the app and wifi
bridge worked. Thx
Tip#13. “I figured it out. I was using a fixture that held multiple bulbs. Apparently there is interference
when you try to pair two bulbs at the same time. A fixture with a single bulb worked.”
Tip#14. It worked after I changed my wifi router to the standard wifi secure settings WPA2/PSK AES.
Tip#15. I was able to connect the bridge to my network after I set the SSID to visible.
Tip#16. I placed the wifi bridge closer to the wifi router.
Tip#17. After trying another usb power supply to the wifi bridge it worked.
Tip#18. Might be some sneaky power leaking on to your socket with the switch even off. So remove
the bulb from the socket, turn the switch on at the wall. Plug the bulb to the socket, and within 2
seconds press the group1 on button on the remote. Dual white remote for dual white bulbs, RGBW
remote for rgbw bulbs. Now for the App, you must sync it again separately, because the wifi bridge acts
just like its own remote.

Add the config to the configuration.yaml file

Here’s my working light section:

  platform: limitlessled
    - host:
      version: 6
      port: 5987
      - number: 1
        type: white
        name: Kitchen
      - number: 1
        type: bridge-led
        name: Bridge Light
      - number: 1
        type: rgbw
        name: Kitchen table
      - number: 2
        type: rgbw
        name: Lounge & Hall
      - number: 3
        type: rgbw
        name: Study
      - number: 4
        type: rgbw
        name: Bedroom

Then reboot your Pi.
You should now see the lights on your home page in HomeAssistant.

Things to note here…

  1. not sure if the version and port are required (docs say it’s optional), but I added for completeness and to remind me if I ever upgrade or run into issues
  2. There are a total of four groups because that’s all that the v6 bridge can handle… however… on my main page of HomeAssistant I have 6 independently controllable entities, i.e. there are 6 on/off switches listed. This is because each of the 4 number/groups here can have duplicates (see I have three ‘number 1’ entities) because each of those are a different ‘type’; a ‘white’, a ‘rgbw’, and the ‘bridge-led’.
  3. the bridge-led is the light on the v6 bridge, this is a special entity and think it can be assigned to any of the 4 groups, it doesn’t really matter.
  4. Even though my rgbw lights have warm white, they’re not the rgbww type because mine are the older type I think that doesn’t have colour temperature. Thanks to my buddy @noodlemctwoodle for that one… saved me hours, and was about to throw it all in the bin!

Hope this helps someone else. I’ll see if I can update the LimitlessLED page on github. [EDIT: submitted a PR, we’ll see if they allow it in.]


That is an epic post, glad you have it sorted now :smile:

1 Like

Thanks. This helped me in sorting out my limitlessled setup.

1 Like

thanks very much for the help here, I´m trying to configure my limitsless led, here´s what I have:

3 bulbs gu10 rgb+cct
ibox2 wifi controler

first thing I did was test on one bulb, I linked worked with the app writed the config.yml and worked, after I unlink put another two bulbs linked the 3 in the same zone (zone1) but when wrote the bellow config but now it´s not working, and do not showing anything on the logs:

can anyone help me

platform: limitlessled
- host: ip from ibox
- number: 1
type: rgbw
name: Kitchen

found out that my wifi bridge was listening to the 8899 port but i´ts a v.6, and it was not working so I´ve entered in milight_ip/home.html and changed the port to 5987 works perfectly.

Can somebody help me solving the problem:

Nice post!
I think I will look into the milight as well!

@Tim10 are you satisfied with the milight - is it running stable?

@Yoinkz, yep, running fine, no probs. I just bought another E27 with warm white and cool white and added it to my existing set up. As my others are mostly RGBWW I can add this in and effectively have it as another zone. Think I have about 8 independent zones off the one hub by doing this. I had to use the guide I wrote above as I had forgotten how to pair them! I think the bulb was £7, and I happened to see that the v6 hub is now only £10! I can’t find a better value bulb and hub; let me know if you find a one better.

I haven’t done much more for automation other than set them to turn on and off via the HA gui, so can’t vouch for that, but expect automation functionality is more Home Assistant, than the bulbs. The one thing that they don’t do that would be better is report back their current state; HA doesn’t know if they’re on or off, so sometimes the app is out of sync if they’re turned off on the app, and then off and on via the wall switch… for example, if you turn one off on the app, then use the wall switch to turn it back on (switch off, switch on) the app doesn’t realise that you’ve turned the light back on… no biggie though.

I just moved to running HA on Docker on the Pi. Was much easier than expected once I found a guide on line with the right level of detail for me. That seems to work fine also.

Yes, there is :slight_smile:

Have a look at switching to an emulator using ESP8266. The cost of ESP8266 + NRF24L01 doesn’t go nearly the one of an ibox. Also, there is no soldering involved.

This would allow:

  • solve the sync issues between physical remotes and HA;
  • allow to use as many groups as you want without the need to buy any new ibox unit;
  • with multiple ESP8266 units set a mesh network to control all MiLight bulbs in a large area;
  • solve the integration issues with MiLight that occur with nearly each new HA iteration (the emulator uses MQTT and there isn’t need to make changes after HA upgrade);
  • work faster than native solution as MQTT is specially designed to be lightweight (vs. UDP used by the ibox).

Also, with the emulator you can still use the current (UDP) MiLight integration in HA. Sole thing the emulator doesn’t do (but achievable on the ibox) is the transition between different brightness levels. However, this is still doable with either: a script that would change the brightness level each 2/3/5/etc. seconds or setting the MiLight component Light in HA for the same Group ID and send transition commands to that light instead of the MQTT light.

1 Like

@petrica - wow… that looks cool. Had a brief look at the docs. I have zero electronics background or tools, though am pretty handy with DIY stuff and am ok in Linux. Is this still doable do you think?

No soldering you say! Do the two boards snap together?

Yeap, use 7 female-female DuPont connectors (https://www.aliexpress.com/item/2pcs-Dupont-Wire-10CM-Female-Female-40Pin-Dupont-Cable-10cm-Female-to-Female-100MM-Du-Pont/32830124592.html) between the ESP8266 (look for NodeMCU modules as they only require MicroUSB power adapter; there are a few alternatives, some with soldering but the ones with the pins already soldered are ready to go) and the NFR24L01 modules.

In order to increase NRF24L01 reliability, a 4.7 uf capacitor can be used between VCC and GND pins on the module (this involves soldering). Alternatively, this board can be used to host the NRF24L01 module (already has the voltage regulators) https://www.aliexpress.com/item/New-Socket-Adapter-plate-Board-for-8Pin-NRF24L01-Wireless-Transceive-module-51/1859110962.html

I only have accounting degree so what the hell is that electro… electron… wait… electronic background stuff? :slight_smile:

Just don’t mess with the 220/110 V mains or anything above 12 V (either AC or DC) and you’re good to go.

3.3/5 V still has the potential for causing damage (mostly fire hazard; just look at those Samsung or even Apple phone batteries exploding) however it is quite limited.

1 Like

Hi guys,

Have anyone experienced the connection between the HA and MiLight ibox freezes or locks up?
To me it looks like it happens when I use the slider or if I call the program night mode, which might not be available for the ibox.

Hi Guys,

Newbie here!

I’ve been trying, without success, to get HA to control my Milight Bulbs. The problem is that the bridge is seen. I can switch in HA but the communication between the bridge and the actual bulb is not working. At the same time if I use the milight app everything works fine.

HA latest version
Milight bridge not ver 6 as in the API the port number was set to 8899. changing that was not a solution.

Any help would be greatly appreciated.

PS I also have some flux lights in the network, which were visible and working before I added limitless light config to the config.yaml any Idea those are not visible anymore?

Hi @330chauf… I’m about to set this up from scratch again. Ask me again in a couple of weeks if you’re still having issues and I’ll share my config.

Hi Tim,

Thanks for your reply and offer. I have meanwhile sorted that out. I eventually unlinked all the light (4) and then reset everything. After that HA picked up the lights wo any issues. All but the state, but I think that’s just not possible with milight at least not the version I have which is 4.0

Greets 330

Ok, glad it’s working for you 330. No, the LimitlessLED/MiLights I have don’t do state unfortunately. Not yet sure how that’ll impact what I want to do with them.

For me they just need to go on and off :wink: state would be nice but what I do is switch all on and off. That way I’m 99% sure they are in a state I put them in :joy:

1 Like