Flashing QIACHIP Wifi Wireless 433Mhz RF with esp8266-s3 (Sonoff RF clone)

QIACHIP Wifi Wireless 433Mhz RF with esp8266-s3

image

Description of problem:

I’m having hard time flashing this sonoff rf clone which has a little but important (I think) difference to the ‘original’. The button on the device is connected directly to the 433 rf module to pair remotes (the sonoff rf instead connects it to the esp if I’m right to toggle the realy). Therefor I have the hope to flash this device with esphome and still being able to control it in parallel with the rf module which is integrated in the device. After flashing esphome the rf function should work as normal including pairing new remotes (with the button). The device state should always be visible in esphome even if toggled via the rf function.

Problem for now is that I’m not able flash this esp8266-s3 thing despite having even the data sheet (https://fccid.io/2AKBPESP8266-S3/User-Manual/User-Manual-3594791).

image
image
image
image

I tried with the usual combination (with my usb ttl adapter which flashed already a dozens of different esps) hooking up V, GND, RX, TX and pull GPIO 0 to ground to get in flash mode. Problem is that serial connection to the device always fails. Weird is also that I don’t get the led (I think I see one right under the metal cap but not 100% as it is so tiny) on the esp8266-s3 to light up - if one exists! It makes me wonder a little bit… usually this is always a great indicator that the board has power and from the type of blinking it’s normally even possible to see if it booted successfully in the flash mode. I’m confused and not amused. :unamused:

If any one could give some advise I would be glad

Ok, now I get a light. It was insufficient power supply because the board powers the another things like the 433mhz rf module which is finally (and for the first time) to much for my usb ttl thingy.

Still I’m not able to get into flash mode and the serial output is just garbage.

Can somebody interpret what would be necessary to flash this esp board?
It think it’s somehow encrypted in these lines:



any ideas? I’m used to just put gpio 0 to ground while booting (put power) and then release ground again from gpio 0. Here it doesn’t seem to have any impact on the boot mode? :tired_face:

Try keeping gpio0 low while you flash.

Thank’s for the tip @nickrout
I tried - but still no luck :pensive:

I have one of these. I used tuya_convert to flash OTA tasmota on it. Probably works for Esphome too.

Edit: I can’t get the switch to work with tasmota. The rf part works, but the light does not turn on using WiFi. If you get it to work with esphome, please leave feedback in this thread.

1 Like

Did you tried all possible gpio pins? Could be 0,1,2,3,4,5 or 12,13,14,15 as all these ones available on the esp8266 s3.

I will try with tuya_convert soon.

I tried all. The only thing I manage is to turn the blue led on or off

Maybe the relay is switched over a UART connection with the RF module?

Does the original Software/Firmware give some information how the relay is switched?

Which esp gpio pin is the led?

And the button on the device? I guess it’s directly linked to the rf module and not connected to the esp at all… with the relay it could be the same :roll_eyes: It get’s really useless…