FLIC 2 HASSIO ADDON. New Buttons not showing

I have installed hassio addon (https://www.home-assistant.io/integrations/flic/), followed all the steps and installed the Service as well with Configuration.yaml binary sensor.

The server is running as follows:
Available HCI devices found:
Trying hci0
hci0 is busy, shutting down and retrying…
Successfully bound HCI socket
Flic server is now up and running!
Initialization of Bluetooth controller done!
Accepted new client

But i cannot add any Flic button though am pressing the flic for 7 seconds.
tried pairing it with android app and it is working great.

So i assume its home assistant issue.

Please advise ? Anyone successfully paired Flic2 to HASSIO ?

1 Like

Not an answer to your query but an alternative - Have you tried using the usual bluetooth buttons - like the ones below? They can be connected through Keyboard Remote integration of HA and are pretty reliable also super cheap. If you search you could get 3 of these in $9. IMHO flic is just an overpriced and complicated bluetooth solution

I have already bought the buttons :neutral_face: So I would really love those to work now.

While others with Flic respond, you might want to try adding them as a Keyboard Remote. If Flic behaves like a regular bluetooth, it would work. Then you wouldn’t need the Flic server.

Best of luck

So, just to get this straight.
You have bought a flic hub? (Bluetooth to ethernet)
You have several Bluetooth buttons?
You have paired these buttons with your phone?

Should you not have paired them with your hub ?

I only have original flics, but have some suggestions

  1. make sure you have un-paired flics from any phone app - they can only have one server at a time (at least my ver 1 ones were like that) - at least have the flic app closed on your phone
  2. once the service is up and running on your hassio system, you might need to restart hass.
  3. once flic is up and hass has restarted, then you can add the buttons using the 7 second press - they should stop flashing when you do a normal press after associating, indicating they are linked with the hassio service.

YMMV - this is how it works for me.

Good luck


No Flic hub is used, I had installed the flid addon and the flic service:

Service setup

If you are using Hass.io, you can run the service locally by installing the flicd add-on from pschmitt’s repository.

The button I am trying to pair was not paired with any phone.

The service mentioned above replaces the flic hub as mentioned here:

The flic being used was not paired with any app.
have already restarted hass and pressed the button for more than 7 seconds without any luck.

I have to mention that I am using Flic version 2.
Binary sensor has been configured as well.

Any lights at all on the button when pressed? I assume you get 3 or 4 flashes when you press indicating not assigned to anything, or cant find the server it is liked to.

I find the batteries can go flat quite quickly

I also use a pi as a hub, like your usecase.

The binary sensors for flic buttons don’t actually show anything apart from whether the button is “online”

The way to trigger is listening for an event

Red Lights are showing.
Nothing is showing on the service side neither on the logs when trying to pair the button.

flicd service is stating: Accepted new client
which means HASSIO is connected to the service. but the button itself cannot connect to the service.

Hi guys

I’m experiencing the exact same issue. Not getting any entities when trying to pair Flic2 buttons.

RPI4 (or 3B+ for that matter)
Flic 2 buttons (never paired with other devices)
Flicd add-on installed

Flicd log:
Available HCI devices found:
Trying hci0
hci0 is busy, shutting down and retrying…
Successfully bound HCI socket
Flic server is now up and running!
Initialization of Bluetooth controller done!
Accepted new client

Flic team has recently released new protocol specification at https://github.com/50ButtonsEach/flic2-documentation/wiki/Flic-2-Protocol-Specification
So a standalone addon (integration) could be created that doest require a deamon.

Hi. We have released a new version of the flicd binary some time ago which adds support for Flic 2.

Where can I find it. the pschmitt’s addon is not updated, so it is probably not that.

@Emill this actually works on Linux systems with home assistant installed on. We are looking for HASSIO addon, if you can update us with an ADDON that would be great.

Are you using this addon? https://github.com/pschmitt/hassio-addons/blob/f3bf0ab61611658cd6f23aee93a18d6e8fb646ca/flicd/Dockerfile It pulls the latest flicd from our github repository.

I am also using pschmitt’s addon, and I’m also unable to pair my flics in Home Assistant (previously Hass.io). Every flic owner in the Danish Home Assistant community is having the same issue.

on Raspbian I have no problem pairing my flics.

Same here. Freshly install fliclib but only Flic Gen 1 discovered. Flic 2 didn’t show up.
Have someone been successful with Flic2? Please kindly share.

Ok I have no idea. Please make sure you actually have the latest flicd.

1 Like