Flux LED/ Ledenet v8 not working well on Hassio

Hello,

I have 4 Ledenet controllers. I ordered two of them in the beginning of 2019, and some last month.
The first two are v6 (according to the Smart Home app), and the last two are v8.
The two v6’s are working flawlessly, but the v8’s are not working well.
They cannot be turned on from the dashboard, but they sometimes turn on via automations.
The colors and brigthness that the LED strips show are wrong as well, it should be orange yet sometimes it’s only red or a tint between orange and red. The brightness in the automation is set to maximum but they only appear to light up 50% (if they turn on).
I use the same LED strip for all 4 controllers, so it’s not an issue of the colors being wrong because of different strips.
Hassio also usually reports them as being off, while they are on.

Turning off via automations does seem to always work.

Also, using the Magic Home app I can perfectly turn them on/off and set the colors.
So this seems to me something in the v8 update of the controllers broke something in Hassio.

How can this be fixed?
If there is anything I can do to help test/fix this, let me know.

I ordered all 4 from this Amazon page:

Thanks in advance!

EDIT:
This seems to have fixed it for me, although name detection doesn’t seem to properly work.

3 Likes

hello,

i got the same issue, V6 work well but with v8 i can’t turn on the ligth, turning off is ok.

i tried with le rgb parameters and protocol ledenet, no change.

the V8 work well in magic home pro

thanks in advance too.

I’ve updated to Hassio v0.101.3, still doesn’t work with V8.
I bought new V6’s and these work fine, I also got new V8’s and these have the same issue.

Hopefully the V8 issue gets resolved.

i’m having the exact same issues.
Ordered my first LED WiFi Controller and it’s a v8 version.
Can’t turn it on via hassio only via the MagicHome App.
Turning off works fine and once its on, i can toggle effects/brightness/color etc.

Does anybody know how to raise awareness for this issue?

1 Like

I’m in the same boat as well.

Don’t know if its an option for you, but I’m planning to reflash mine with Tasmota, apparently that can be done, and I never have any problems with my tasmota devices, so hopefully this will fix it.

Hi @lockey4

Tasmota is probably the way to go. Is there a way to flash Tasmota on the controller OTA, or is soldering definitely required?

Best!

I haven’t read anything about an OTA flash anywhere. I think I’ll be trying something like this:

Soldering such tiny pads never works out well for me, so I’ll try just keeping wires in contact with the pads first.

Planning on doing it on Firday, so if you want a guinea pig to try it first you’ll have to wait till then :slight_smile:

I’m such a noob when it comes to things like that, I will kindly let you go ahead hahaha

Came here with the same issue. Looks like my devices automatically updated to v8 and I’ve lost use of them. Hopefully there can be a patch or something to these.

I’m having the exact same issue. I have three v6 devices that worked flawlessly, I bought a v8 device unknowingly and behaviour is so intermittent. Glad I found this so I didn’t waste more time trying to solve it. Thanks.

1 Like

I ended up flashing Tasmota onto the LED-Controller following this tutorial (german):

Works flawlessly now :slight_smile:

1 Like

Its a huge hack, but I got the use of my LED strips back by using the following

I’m guessing it would be possible to get home assistant to call that instead of what-ever python library its currently using, but that’s a little beyond me. I installed the flux_led python by just
‘pip 3 install flux_led’ and then added the following to my configuration.yaml

shell_command:
  led_strip_1_on: flux_led 192.168.1.1 --on
  led_strip_1_off: flux_led 192.168.1.1 --off

Now I can just call ‘led_strip_1_on’ as a service in my automation and the LED strip turns on and off just like before with no issues. Someone smarter than me can probably figure out how to do this within HA and get the LED strips working without an ugly hack like this. I can’t solder to save my life so flashing the firmware isn’t an option for me.

Hi @Glenn_Ruysschaert,

I am having exactly the same issue and I was wondering how I could explain it. You did it perfectly. Thanks!

Would it be possible to downgrade the devices from V8 to V6? Or maybe the flux_led developer is working in a new version for this component? @frenck, please could you help :slight_smile:

Not quite sure why you tagged me in that message?

I have no idea what this is?

Your name is in this component: https://github.com/home-assistant/home-assistant/tree/dev/homeassistant/components/flux_led

Yeah, that is not how it works, but thank for the notification.

I updated the name of the component/integration to be actually correctly spelled, that doesn’t make me the developer :wink:

Sorry m8!

Edit:

Better place to look is the manifest.json, it has a property called: “codeowner” which gives you the maintainer of an integrations. For this integration:

https://github.com/home-assistant/home-assistant/blob/2a65da5db2392bb9e0230413f43017be3914d3a8/homeassistant/components/flux_led/manifest.json#L7

No codeowner, currently unmaintained.

Thank you @frenck, and sorry for bothering :wink:

1 Like

No problem m8! I hope you guys get it resolved. :+1:

1 Like

It looks like there is a workaround already by adding a 1 second delay: