Forgot user and password of UI

dot storage ie .storage

Thanks for supporting me. but i can’t find the path. maybe i will reinstall.
But If the next time, someone forgot username and password then they must to reinstall, right ??. I need a answer from the developing team.
P/s: i install hassos on rpi with this file : hassos_rpi3-2.11.img that i downloaded from https://www.home-assistant.io/

Wrong. You have been told how to fix it.

1 Like

:mask:
Please post the output of:

ls -l /

of your console.

.storage is in your /config directory

If you are using the ssh addon console you should see it when you use ls -a

If you are directly connected to the pi with keyboard and monitor you would use root to get to the Hassio CLI. Then use login to continue to the host. (You’ll see a # prompt)

From the host, the directory is a little different. You want to cd /mnt/data/supervisor/homeassistant
and you will find .storage in there.

3 Likes


@cogneato when i type ls , i couldn’t find .storage.

Try ls -la and you will see it.

1 Like

finally i can see.storage in /mnt/data/supervisor/homeassistant/ by ls -la
Thank you so much for supporting.

2 Likes

oops. Yes, I should have been more specific. :flushed:

Hi Guys,
Im following serevral topic of how to reset my password and/or usrename… Unfortunatley without success.
I think my problem is, that i installed HA using this guide. (manual installation on a PI)
I am not able to find any config files an also nocht some hidden .storage folder to delete.
I tried all the above ls commands as User Pi, Root and inside the venv. Can anybody please give me a hint?
As this was asked for befro I will upload an image oh my ls -l/ results.
Thanks for any help.
Jayman

If you followed those directions exactly the files are under /home/homeassistant/.homeassistant

Thanks a lot, i did find that folder now an i found the .storage folder too.
I deleted the files mentioned in an other post i dont find right now.
I restarted my Pi an everything came back up. The User Interface asks me to enter new credentials. so far so good…but a click on “benutzerkonto anlegen” (“add user”) doesnt do anything. i tested this with firefos, chrome an IE. Does anybody have an idea?
One more thing, that could be the problem: The password recover Threads all mentiones that HA should be stopped befor deleting the files. I am searchin for hors, but I have NO idea how to simply stop and restart HA. As mentioned in my first Post, I am using this instalation method.
Maybe somebody could help me out with that. It could solve the problem.

Did you follow the directions to have it autostart on bootup?

If you did, it’s pretty simple.

sudo systemctl stop [email protected]_USER

Yes i did follow theese instructions.
I got it to stop, then deleted the files, then restartet and i am sitill stuck at the “new User”-Screen.
A click on the button below doesnt do anything. I read about that in an other Lost-Password-Thread, but in his case he had three browser restarts and then it worked. I’m at restart 15 by now…
Thanks for the help so far. Maybe someone knows this last issue and give me a hint

Make sure you also clear your cache and history for your instance in your browser

Yes I did that. At least I think i did.
I tried chrome, wich wasnt even installed on my PC yet before. So its cache should have been empty.
However, I am going to try some more time this evening and let you know, if i find something.
Thanks so far

OK, I Got it. Thanks fo your help.
The solution for me was deleting the whole .storage folder. After that and a restart it worked agein.
Since it was quite a fresh install the re-integrate of my Phoscon Gateway wasnt a big deal.
Just deleting certain files as mentioned in the documentation here always brought me to the never ending new-user-screen.

Hi

I have forgotten my password and it requires the current password to change it
Which I done know.

How do I set up a new password without current password

From oliver