FreeBSD VM boot configuration help (Fix inside!)

Tags: #<Tag:0x00007fc405d6ef18>

So I’m trying to configure the HassOS boot image, written to a zvol, and I’m having trouble getting it to fully boot. I realized I had to change it to UEFI boot, and after doing that I get similar, but not quite the same, output as when booting in VirtualBox direction with the VDI I used to extract the raw image.

After looking carefully, it looks like it may be an issue with it finding/mounting the partitions in the Zvol? Is that correct based on my reading of the below output?


barebox 2020.04.0 #1 Thu Aug 6 20:37:21 UTC 2020

Board: barebox EFI payload
EFI v2.40 by BHYVE v65536
EFI Event timer too slow freq = 100 Hz
acpi2: Found XSDT (OEM: BHYVE BV) with 5 entries
efi-fs handle-00000000bf055698: mounted on /boot
efi-block-io handle-00000000bf282418: Cannot read MBR/partition table
malloc space: 0x30000000 -> 0x3fffffff (size 256 MiB)
state: New state registered 'state'
state: Using bucket [email protected]
description: EFI Hard Drive
path: pci_root(0)/Pci(0x4,0x0)/Sata(0x0,0x0,0x0)
description: EFI Network
path: pci_root(0)/Pci(0x5,0x0)/Mac(589cfc01b33f,1)
description: EFI Internal Shell
path: mem_map(11,0xbfc1c000,0xbffbbfff)/Path(132,6,0x83a5047c3e9e1c4fad65e05268d0b4d100000000ffff0800)
environment load /efivars/barebox-env-5b91f69c-8b88-4a2b-9269-5f1d802b5175: No such file or directory
Maybe you have to create the partition.
running /env/bin/init...
- Hit m for menu or wait for autoboot -
Booting entry 'bootchooser'
Booting entry 'system0'
ext4 ext40: EXT2 rev 1, inode_size 128, descriptor size 32

Loading MS-DOS executable '/mnt/system/bzImage'

if you’re referring to the FreeNAS installation, I would suggest to create a VM on a zvol dataset and boot that VM from a raw file (the latest NUC image is hassos_intel-nuc-4.12.img)
you don’t need any type of installation or disk image creation with VirtualBox
that have worked for me on the testbench without any issue

@katsaplias No, I’m referring to bare FreeBSD. As in https://www.freebsd.org/.

However, I literally just figured it out in the last few minutes. I got to thinking more about how output works, and realized I needed to create a VNC framebuffer. Apparently the way HassOS is setup/configured, it acts more like Windows, rather than *nix, in that the base console operates on a framebuffer output, rather than a regular TTY(or similar) console like normal, bare *nix operates. Even Debian. So once I added the below to the Churchers vm-bhyve configuration, it all works now!

Actually, I suspect it was working fine to begin with, I just never checked my DHCP server to see if it was handing out an IP to the “homeassistant” DHCP name. I never thought to check because there was no apparent console/TTY output after it started booting the kernel image.

xhci_mouse="yes"
graphics_listen="192.168.1.X"
graphics_port="5900"
graphics_wait="yes"
graphics_res="800x600"

EDIT: Added installation instructions