Frient energy meter total comsumption switching from kWh to MWh

I got a Frient energy meter (Develco ZHEMI101) integrated into HA through DeConz, which has been working well since Janary, logging about 7600 kWh so far. This morning, I noticed something was wrong and checked the total consumption. Seems like it has switched the kWh calculation to MWh instead:

The instant reading entity is still in Watt and I managed to create a new total consumption sensor via powercalc integration. But naturally, it starts over at 0 kWh. Thus, I’m losing the historic data when tracking this entity in the Energy tab and my grafana.

Any ideas on how to keep the historical data in a new entity? Perhaps if I could clone the old total consumption and its data and then start adding new data to that entity?


1 Like

i got the same problem , i think it broke when i updated deconz to version: 6.16.0

did you fix yours?

Nope, not yet. My idea to clone the historic data to a new entity and add data to that is probably possible with some commands in InfluxDB, but I’m not very proficient in it, yet. I’ll write again here if I’m able to figure it out!

1 Like

info, returned back to 6.15.0 and it worked again.

Yep, that puts it back to counting in kWh. However, the jump to 1/1000 of the previous consumption and back to normal again is somewhat problematic for the historic data…

Edit: Just added an issue about it for the deCONZ addon at GitHub

1 Like

Is this solved now?

yes it is solved now :slight_smile: