Frient Smoke Detector / ZHA

I am considering to buy a couple of those smoke detectors; however I am reading mixed reviews on Amazon when it comes to ZHA compatibility.

Seems like most people had to switch to zigbee2mqtt; however according to Blakadder reports it as confirmed working! The GitHub threads don’t give a definitive answer either.

So I’m wondering if anyone has those smoke detectors setup in combination with ZHA and what are your experiences?

1 Like

I have 2 of these running on ZHA, no problems to report.

1 Like

I’ve got one that is always connected, and another that keeps on dropping the connection. Now I can’t even get it reconnected.

Any tricks you used?

I’ve tried putting it right next to the ConBee Zigbee USB hub. I also cannot get is to connect to an Osram plug.

I’m using Sonoff 3 zigbee dongle on ZHA, had zero problems .


I got one of this smoke detectors too, for testing and realized that I have a really bad LQI.
I get around 135 if I place it next to the Sonoff 3 Zigbee dongle I am using, but as soon as I move to the next room, or just place it at the other site of the room (2-3 meters) it drops down to 50-40.

I also verfied my Wifi Channels, so that this there is not interference, but nothing changed. Is this normal to have such bad link quality for those smoke detectors?


I have much better performance now that I moved my ConBee II stick far from my Google WiFi puck.


Since people here have experience with these smoke detectors, can anyone confirm if you are able to activate the alarm from HA ?

use case:
One alarm goes off, and I want HA to automatically activate all other alarms.

Thanks in advance!

Yes - just tested this and the siren is switchable, the strobe isn’t though.

The temperature sensor also doesn’t seem to update for me; any other observations here?

I also bought two of these smoke detectors this week. Basically everything works with ZHA. The alarm can be switched and the temperature sensor updates.
BUT: I also have the problem that one of the sensors is constantly unavailable. The sensor in the same room as my Home Assistant server with Conbee2 works. But the sensor in the neighboring room already has no connection.

Can the smoke detector be muted from HA, for example when cooking? That happens often for us when we open the oven for example. Then it would be nice to be able to pause the alarm.

1 Like


has anyone managed to change the alarm sound and volume?

This dosn’t work for me:

device_id: b57590f5b31b04427d75146ac15ce3a8
domain: select
entity_id: select.rauch_und_alarmmelder_eg_default_siren_level
type: select_option
option: Medium level sound

or this:

device_id: b57590f5b31b04427d75146ac15ce3a8
domain: select
entity_id: select.rauch_und_alarmmelder_eg_default_siren_tone
type: select_option
option: Fire Panic

Best regards


Hi there,

it is working for me without issues, changing the sound and everything within the ZHA. What im wondering is what the switch (below “siren”) is for:

Furthermore the tempearture is not updating too (was described earlier too).


Anyone had any luck with these? I’ve bought 2 to test but the siren seems to auto turn off after a few seconds if I manually turn it on via the switch. I’m using ZHA.

Do you know if it’s possible to change the sound within an automation? I would like to use it as a burglar alarm, but with a different sound for when smoke is detected.

Same here. Maybe it’s a test functionality and not a toggle to turn the alarm as it would in case of smoke detection?

I managed to switch the siren on or off via my dashboard using an input boolean helper called input_boolean.rookalarm_schakelaar, an automation and a custom:button-card. See below for details.

The automation: when the input boolean is turned on, the siren turns on.

alias: X - Hal schakelaar rookalarm
description: ""
  - platform: state
      - input_boolean.rookalarm_schakelaar
    from: "off"
    to: "on"
condition: []
  - service: siren.turn_on
    data: {}
      entity_id: siren.0_hal_rookalarm_siren
mode: single

The (mushroom) button card:

type: custom:button-card
entity: input_boolean.rookalarm_schakelaar
name: Rookalarm hal
icon: mdi:smoke-detector-variant
state_color: true
size: 35px
show_state: true
show_name: false
  action: call-service
  service: |
      if (entity.state == 'off')
        return 'input_boolean.turn_on';
        return 'input_boolean.turn_off';
    entity_id: input_boolean.rookalarm_schakelaar

On Home Assistant 2023.8.3 using ZHA, entities are not added: The device is discovered, interviewed, but the configure step seems to never finish. The Zigbee coordinator used is ConBee II.

Exact same situation here. On Home Assistant 2023.8.3 using ZHA, entities are not added: The device is discovered, interviewed, but the configure step seems to never finish. Using Nabu_Casa_SkyConnect.

Had the same problem with it not configuring. In classic IT fashion, I exited out of the add-device dialog, restarted Home Assistant and all entities showed up correctly.

Sebinity, 1000 thanks! it really worked for me too.