Frigate Mobile App Notifications 2.0

I am having a weird issue with this blueprint. At least I think I am LOL.

I have frigate setup and I have the blueprint setup. I get the alerts just as I should. However, anytime I click on the notification or view clip, the clip starts to play and then I get unable to connect to home assistant error. If I click Wait on the error, the video continues to play for a bit and I get the error again.

I can view the frigate video feeds in the dashboard without any errors. It happens if I am on my network, off the network. I have nabu case cloud service. I cannot figure out what the heck is going on.

Any ideas or suggestions to try? I have uninstalled the app and reinstalled it. No difference. Oh, I have a Google Pixel 7 Pro.

Thanks,
Scott

Could you try replacing the critical selector in the blueprint with this and let me know.

I placed two examples but it allows custom templates for you to set your own timings.

    critical:
      name: (Optional) Critical Notification
      description: >
        Send as a critical notification to the mobile device.
        Sometimes notifications (particularly on android) are delayed, this will resolve this.
      default:
        - "false"
      selector:
        select:
          options:
            - "false"
            - "true"
            - "{{'false' if now().hour in [8,9,10,11,12,13,14,15,16,17,18] else 'true'}}"
            - "{{'false' if is_state('sun.sun', 'above_horizon') else 'true' }}"
          custom_value: true
1 Like

when you are viewing the clip it is simply a url pointing directly to your HA instance API. The blueprint gives you a valid link but doesn’t play a role in the playback. Definitely seems network/bandwidth related. Have you tried other devices? or using local urls instead of the nabu casa url on your home wifi temporarily to test.

Will this blueprint work if on Frigate release 11.1?

As far as we’ve seen the original blueprint doesn’t work on frigate 0.11 without a small fix. I’m sure hunterjm will update it eventually but for now you need to do it yourself. My fork does work as I’ve implemented the fix if that’s what you were asking.

How would I go about implementing the fix. I have ver 11 install and my notification automations from the blueprint are not working.

Awesome!! This worked perfect. Thanks again.

I what file did you do the change?
I have both frigate_notification.yaml and frigate_0.10_notification.yaml. None of the have a or statement on line 178.

I needed to edit Blueprint via file editor. Mine was actually on line 160. search for '{{ fps_value|int if is_number(fps_value) or 5 }} and change the ‘or’ to ‘else’. you restart and you should be good.

1 Like

Thank you for this!
Do anyone have it working well with ios 16.1.1?

I do get the notification, but clicking on it opens up safari which tries to load a video clip which will not play, it just shows a black video. I can open the Home Assistant app and enter Frigate from there and play the clip just fine.

Ideally clicking on the notification would open up the Home Assistant app and bring me to the event in question. Anyone know if it is possible?

I am using the 0.11.0.4 - SgtB blueprint

Thanks!!
I did try to play with base URL option but with or without has the same effect.

Can’t help with the safari vs app thing. For the record on android it also opens in the browser.

If the video isn’t playing in safari have you tried using the generated link in another browser? The links should be valid (assuming baseurl works) and therefore it might indicate an issue with the recording codec or the remote access itself.

after a lot of editing ive got this blueprint mostly working on latest HA supervised.

is anyone else having issues with the zone filter? I have a drive way zone which I want to use but when I enable the filter it just seems to block all notifications.

How did you resolve this @fspatt ?
I am stuck in the same spot - cannot get any notification to fire.

It’s been a minute, but I think I used this Blueprint and it worked. toddrob99/frigate_0.10_notification.yaml

Also, I think I did this!

im having this same problem, its really annoying. I disabled casa + cloud and just tried local wifi same problem. have to keep hitting wait… so annoying.

Im trying to directly embedd the .mp4 into a websiteCard but having trouble passing the url arguments to it.

Is HA supervised that different to hassOS. This blueprint requires one change to make it work with frigate 0.11 discussed a fair bit above.

I’m using the zone filter without issues to only get notifications of objects on my property and not in the street. Depending 9n how much you edited, maybe you introduced a bug?

I’m happy to help troubleshoot. Are you using the original blueprint at the start of this thread? As above it needs a change to work with latest frigate.

thanks - I dont think theres a difference between HAOS and supervised - I have the ELSE / OR change and it does work ok.

The issue seems to be that when I have the zone filter enabled, and have more than one zone on a camera but only want notifications from one of those 2 zones, I get notifications from both.

One other weird bug im seeing is notifications on ios but no record of automation trigger on HA. Ive searched for other notifications that may be triggering these notifications but cant see any, but that will probably down to my individual config.

thanks i’ll try that.

I still can’t seem to get this to work, even with the change from orelse.

On a fresh install of HAOS, I’ve configured and enabled MQTT and Frigate. I’ve changed the blueprint as advised above and set-up the following automation:

alias: Back Garden 2
description: ""
use_blueprint:
  path: hunterjm/frigate_0.10_notification.yaml
  input:
    camera: back_garden
    notify_device: 72acf50f78b251b4bb4b2163fddadf40

But still notifications aren’t getting sent to my phone. If I go to Frigate on the side-panel and look at events, there are events from the back_garden camera.

I’ve checked the logs for the Frigate add-on and there are no errors, and same for the MQTT add-on.

If I look at entities I see a few errors related to them being unavailable? I’m not sure if that’s just a symptom of the trigger not being set off though?

Anybody have any thoughts as to why the notifications aren’t reaching my phone?