Fritz!Box integration finds not all devices

Hi folks,

I have allready 2022.2.1 installed with no positive effect to my device_trackers

So I deleted the whole Fritz!Box integration and installed it new.

Now there are only four of about 180 devices available.
No hidden device entity.


Here is the diagnitic information of the integration:

  "home_assistant": {
    "installation_type": "Home Assistant OS",
    "version": "2022.2.1",
    "dev": false,
    "hassio": true,
    "virtualenv": false,
    "python_version": "3.9.7",
    "docker": true,
    "arch": "aarch64",
    "timezone": "Europe/Berlin",
    "os_name": "Linux",
    "os_version": "5.10.63-v8",
    "supervisor": "2022.01.1",
    "host_os": "Home Assistant OS 7.2",
    "docker_version": "20.10.9",
    "chassis": "embedded",
    "run_as_root": true
  "custom_components": {
    "hacs": {
      "version": "1.18.0",
      "requirements": [
    "iq_notify": {
      "version": "1.0.0",
      "requirements": []
    "dwd_weather": {
      "version": "1.2.16",
      "requirements": [
    "linkplay": {
      "version": "2.0.39",
      "requirements": [
  "integration_manifest": {
    "domain": "fritz",
    "name": "AVM FRITZ!Box Tools",
    "documentation": "",
    "requirements": [
    "dependencies": [
    "codeowners": [
    "config_flow": true,
    "ssdp": [
        "st": "urn:schemas-upnp-org:device:fritzbox:1"
    "iot_class": "local_polling",
    "is_built_in": true
  "data": {
    "entry": {
      "entry_id": "8168d17f0eddc8127e77662d1bac635c",
      "version": 1,
      "domain": "fritz",
      "title": "FritzBox-UG",
      "data": {
        "host": "",
        "password": "**REDACTED**",
        "port": 49000,
        "username": "**REDACTED**"
      "options": {
        "consider_home": 180.0
      "pref_disable_new_entities": false,
      "pref_disable_polling": false,
      "source": "ssdp",
      "unique_id": "123402409-bccb-40e7-8e6c-DC396F19A643",
      "disabled_by": null
    "device_info": {
      "model": "FRITZ!Box 7590 (UI)",
      "current_firmware": "154.07.29",
      "latest_firmware": "",
      "update_available": false,
      "is_router": true,
      "mesh_role": "master",
      "last_update success": true,
      "last_exception": null,
      "discovered_services": [
      "client_devices": [
          "connected_to": "FritzBox-UG",
          "connection_type": "LAN",
          "hostname": "UAPACPro-Obergeschoss",
          "is_connected": true,
          "last_activity": "2022-02-04T16:25:14.764855+00:00",
          "wan_access": true
          "connected_to": "",
          "connection_type": "",
          "hostname": "UAPACPro-Keller",
          "is_connected": true,
          "last_activity": "2022-02-04T16:25:14.823732+00:00",
          "wan_access": true
          "connected_to": "",
          "connection_type": "",
          "hostname": "PatrikPC-LAN",
          "is_connected": true,
          "last_activity": "2022-02-04T16:25:14.856465+00:00",
          "wan_access": true
      "wan_link_properties": {
        "NewWANAccessType": "DSL",
        "NewLayer1UpstreamMaxBitRate": 38517000,
        "NewLayer1DownstreamMaxBitRate": 129220000,
        "NewPhysicalLinkStatus": "Up"

Same here. Only half of the connected devices are available through the integration. Deleting and reconnecting the Integration didn’t bring them back.

have you had success in the meantime?

I have the issue since last HA update that the device_tracker of my devices wont work because there were no more devices connected. A re-installation of the fritzbox integration lead to a list of all devices. But the devices only shows the internet access parameter e.g.: “Amazon FireTV Stick Internet Access” or “Samsung Galaxy Internet Access”.

I can’t shake the feeling that the fritz integration api has changed.

Hi together,

unfortunately I have the same misbehavior. I think that only the devices that are directly connected to the “main” Fritzbox are displayed. I am not able to see the devices that are connected to the Fritzbox via the mesh repeater in Home Assistant.

So I tried to install the Fritz!Tools integration for the repeaters as well. Unfortunately I don’t see any device tracker but only buttons to reboot or similar.

Do you also use mesh repeaters in your system?

Here a related post: [solved - info] Fritzbox device tracker confusion with multiple Fritz devices in network

As I understand it, the issue has been logged as a GitHub issue and the developers are on it:

1 Like