Fronius Wattpilot

Hi All,

I am currently thinking about purchasing a Fronius Wattpilot Wallbox/e-charger.
As I am already running Fronius PV system with the official integration connected to Home Assistant,
I was wondering if there is any integration for the Wattpilot, too?
Somebody who has it running within their HA already?
I did not see any support for it within the official Fronius integration… :frowning:

3 Likes

I second that need.

Wattpilot Information is unfortunately not included in Fronius SolarAPI. You may direct this feature request directly to Fronius.

Also I’m not aware of an official API the Wattpilot provides, but then again I don’t have one my own so 🤷

Found the follow after some research today

I think I will order my wattpilot within the next few days …
Then I can start playing around (and hopefully being able to contribute to the official fornius integration :wink: )

1 Like

That would be awesome. I can help testing as well.
BR,
Peter

Okay, so I put together a very early version.

It really needs some work done but it proves that integration is possible and provides some first values (& setting options).
Please use with caution (and make a backup of your HA instance :wink: )

4 Likes

Thank you @mk-maddin your custom component works great.

@mk-maddin any suggestion how device_id could be found, which is necessary to define in service call to set next trip timing?

There are multiple options :slight_smile:

My preferred one is via a HA template from an entity_id of that device.
Example like the following:

{{ device_id('select.wattpilot_charging_mode') }}

This can be extended to find all entities for an integration and from there select the first one to find the corresponding device id:

{{  device_id(integration_entities('wattpilot') | first) }}

Alternatively you can get it from the URL within device view:

Or (probably the most obvious one) within developer tools you configure the service via GUI & then switch to YAML mode:

2 Likes

Thank you mk-maddin for the work on that custum component. Unfortunatly it doesn´t work with my wattpilot. I always get the massage “wrong password”. What password is required? I tried the local one for the hotspot and the cloud access password.

Hey,

the password to use is the same you are using during the setup process within the Wattpilot App - like here:

1 Like

Hi! Thanks for your integration. Unfortunately I am not able to install. Here is what I did:

-Downloaded the wattpilo-0.2 package
-unzipped and got into src folder. took the wattpilot folder and copied everything into my custom_components folder in HA
-restarted HA

There are no new integrations available. What am I missing?

Thanks
Danielwattpilot_custom

Hey,
Not sure which files you extracted, but the content of your custom_components/wattpilot folder should look like in the following screenshot - so you defenitely have the wrong files in there :wink:

1 Like

ok then - I´v just downloaded the wrong “wattpilot” folder! It works, great! Thanks a lot.

I have one more question: the connection to my solar inverter seems to be based on the correct ip address, however the state is surely not correct

What can I do here?

And is it possible to get the current PV-Surplus in kW oder Wh? This is nicely done in the app and I would like do display this in hass aswell.

I tryed to “Import” my Wattpilot, but i get some errors:

Logger: custom_components.wattpilot.config_flow
Source: custom_components/wattpilot/config_flow.py:112
Integration: Fronius Wattpilot (documentation)
First occurred: 20:23:05 (1 occurrences)
Last logged: 20:23:05

wattpilot - OptionsFlowHandler: async_step_config_charger failed: ‘OptionsFlowHandler’ object has no attribute ‘data’ (builtins.AttributeError)

can anyone help me?

Hi,

nice to hear you are using my integration.
Could you please provide some more details?

  • HA Version used
  • Wattpilot Integration used
  • Wattpilot firmware version used
  • How did you install the Wattpilot integration?
1 Like

Home Assistant 2022.11.2
Supervisor 2022.10.2
Operating System 9.3
Frontend 20221108.0 - latest

Wattpilot: 38.5
Did Install it With your github-instructions

I User Thiel:
GitHub - mk-maddin/wattpilot-HA: This is a custom component to allow control… 263

Have you found a solution?

Sorry had some days off.

To be truth I am not able to reproduce the issue when setting up a NEW (new in this case meaning a wattpilot device that is not currently connected to HA) wattpilot connection.
The behavior you describe happens when you click the “configure” button of an existing wattpilot instance.
2022-11-23_17-02-40

Never the less this is a known error which at the moment i unfortunately do not have time to fix.
(see: GitHub - mk-maddin/wattpilot-HA: This is a custom component to allow control of Fronius Wattpilot wallbox/electro vehicle charging devices in Homeassistant.)
So as written in the instructions on github the workaround would be: If you want to change options remove and re-add the wattpilot device.

Have found the problem… its in front of the Computer xD used the false IP

Mfg Tangir

1 Like