Front-end does not load after AiO Installation

Sorry if this is TMI, but I may be out of my league–My goal was to monitor an Aeon Z-wave energy/ammeter I put in my panel to understand what circuits I could run on my new generator. I bought a RPi and Aeon gen5 USB stick, so I would have flexibility for other home automation. In my first try I loaded HA on Raspian, but the Zwave: addition to the configuration.yaml file was not recognized. I realized it needed to go through the steps to add a zwave library. That seemed complex for my beginning level, so I thought the AiO would be better. Starting over on a new SD card I loaded the Raspberry O/S and followed the steps and video tutorial for the AiO, but the browser doesn’t load the front end with the http://192.168.1.223:8123 (my Rpi IP). Finding the config file in the virtual env, I noticed it was much shorter than the one in my first attempt and I could not save it after I editing. I get the error can’t open file to write. Below is the file:
mqtt:
broker: 127.0.0.1
port: 1883
client_id: home-assistant-1
username: pi
Password: raspberry

My questions are: 1) Does this look right?
2) how do I edit it? I need to change the password and add zwave:
3) I see a possibly related topic about loading manually, what is that command?

update: a) the items after the mqtt: were indented in the file. The actual post lost that format b) I did figure how to edit the file, but still no success to get to the front end.

Are you saying that the entire configuration.yaml is just the definition for MQTT?

Clarify what you mean by “can’t edit”. I did AiO and use samba to reach my HASS installation. IIRC, setting up samba is covered by another of @bruhautomation’s videos.

BTW - use preformatted text when posting YAML.

Also - check home-assitant.log for errors.

yes that is my entire configuration.yaml file. I did solve the edit issue by using sudo nano.

I did a quick scan of the home-assistant log and did not see anything. I will look more closely. Also fyi, i’m trying the whole thing again on a different card. thank you for the help

That config seems to be missing a lot of the base entries. But the one that’s likely the biggest issue for you right now is “frontend:”

If you don’t have frontend: in your config, there’s no web GUI.

On my retry, I have a better configuration file with the front end term, but still can not get the browser to work with the my_IP_address:8123.

I would copy the configuration.yaml, but have not figured out the preformatted icon is supposed to work.

Is there a manual way to get the web page up?

Thanks

I’m not sure what you mean by manual.

Get that config/install in order and it should work.

Preformatted text: paste it in, select it, press the preformatted text button.

Or wrap the text in yaml <-begin end->
(three ticks + yaml at beginning, three ticks at end)

Are you sure you’re not seeing any issues in home-assistant.log?

How are you currently accessing the HA install to see the config, via SSH? Samba?

You haven’t set up SSL certificates, have you?

Refused connections can be caused by a bad configuration. For testing, why don’t you try simplifying your config down to just

frontend:

And start from there.

Another thread suggests putting in a value for base_url

http:
  base_url: XXX.XXX.XXX:8123

Ok the problem resolved itself after I rebooted the RPi this morning. I’m thinking the fix was a change I made yesterday to my NetGear router under the Advanced: Port Forwarding to create a service called homeassistant that opens port 8123. I had rebooted the RPi many times yesterday to no avail. When I made the router change I did not think to recycle the router. My thought is that the router recycled overnight, installing the changes and the Rpi reboot this am got everything working. I don’t think it was anything to do with the configuration or installation, since my installation log was error free and I had not touched the configuration.yaml file from what was put there by the AiO installer. This is the first time I had created any sort of server in my network, so there were probably default settings in the router to block traffic. I still have a Zwave stick issue, but that’s a problem for another day. Thought I would put this out there in case another newbie runs into it.

Experiencing same problem.
Installation went through fine (do not see any errors in /home/pi/fabric-home-assistant/installation_report.txt) and after auto reboot frontend does not load. configuration.yaml only contains a few lines for mqtt:
All other sections are missing including homeassistant: and frontend:
This is my second install on a Pi (to replace old Pi with a Pi3). The other one is actually running on my network as well (different ip) of course.

The homeassistant log only contains one line:
17-03-15 11:56:29 WARNING (MainThread) [homeassistant.config] Incomplete core config. Auto detected latitude: xx.xxxxxx, longitude: yy.yyyyy, name: zzzzzzzr, time_zone: Europe/Amsterdam, elevation: -2

I can copy over my yaml files from my other installation, but it feels something is off with the AIO installer.

After a week more experience, I do not think my router configuration change was the solution. The reason I say this that I abandoned HA and restarted with OpenHAB (The yaml issues became too much). Open HAB uses a different port for the UI and I did not have to do anything with the router to get that to work, so I really don’t know why the HA UI started to work after not working for the prior day, so there could be something with the HA AiO. The only difference with your problem was that I recall I had a clean log file.

I have the same thing happening after a clean install today. Only the mqtt in configuration.yaml

I’m guessing this is not expected behavior

I added the following to my configuration.yml:

http:
  api_password: xxxxx
  server_port: 443
  ssl_certificate: /etc/letsencrypt/live/xx.duckdns.org/fullchain.pem
  ssl_key: /etc/letsencrypt/live/xx.duckdns.org/privkey.pem

From there I manually start HA as follows:

(homeassistant_venv) [email protected]:/etc/letsencrypt $  sudo /srv/homeassistant/homeassistant_venv/bin/python3 /srv/homeassistant/homeassistant_venv/bin/hass -c /home/homeassistant/.homeassistant

The system appears to start up but then when I point my browser at it I get:

ERROR:homeassistant.core:Error doing job: Fatal read error on SSL transport
Traceback (most recent call last):
  File "/usr/lib/python3.4/asyncio/selector_events.py", line 825, in _read_ready
    data = self._sock.recv(self.max_size)
  File "/usr/lib/python3.4/ssl.py", line 730, in recv
    return self.read(buflen)
  File "/usr/lib/python3.4/ssl.py", line 619, in read
    v = self._sslobj.read(len or 1024)
ssl.SSLError: [SSL: SSLV3_ALERT_BAD_CERTIFICATE] sslv3 alert bad certificate (_ssl.c:1769)

And the browser returns 404: Not Found

OpenZwaveControlpanel also seems to not work:

[email protected]:/srv/homeassistant/src/open-zwave-control-panel $ sudo ./ozwcp -p 8888
2017-03-24 20:09:01.754 Error, Cannot find a path to the configuration files at ./config/. Exiting...
2017-03-24 20:09:01.761 Error, Exception: Options.cpp:91 - 1 - Cannot Find Configuration Files
Error: Options.cpp:91 - Cannot Find Configuration Files

There is possibly one error in the log but it looks like the install was not interrupted:

[localhost] out: Searching for gevent-socketio>=0.3.6
[localhost] out: Reading https://pypi.python.org/simple/gevent-socketio/
[localhost] out: Downloading https://pypi.python.org/packages/57/8f/16b508f602cff2dd506636b8d415e39cacb3400d49e885f002bf6436a777/gevent-socketio-0.3.6.tar.gz#md5=33f745d74885366a07da516c000854b6
[localhost] out: Best match: gevent-socketio 0.3.6
[localhost] out: Processing gevent-socketio-0.3.6.tar.gz
[localhost] out: Writing /tmp/easy_install-mt4m1toa/gevent-socketio-0.3.6/setup.cfg
[localhost] out: Running gevent-socketio-0.3.6/setup.py -q bdist_egg --dist-dir /tmp/easy_install-mt4m1toa/gevent-socketio-0.3.6/egg-dist-tmp-tu4sqjfz
[localhost] out: /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/setuptools/dist.py:342: UserWarning: The version specified (':versiontools:versiontools') is an invalid version, this may not work as expected with newer versions of setuptools, pip, and PyPI. Please see PEP 440 for more details.
[localhost] out:   "details." % self.metadata.version
[localhost] out:
[localhost] out: Installed /tmp/easy_install-mt4m1toa/gevent-socketio-0.3.6/.eggs/versiontools-1.9.1-py3.4.egg
[localhost] out: warning: no previously-included files found matching 'socketio/.ropeproject/*'
[localhost] out: warning: no previously-included files found matching 'socketio/sample_protocol_for_doc.py'
[localhost] out:   File "build/bdist.linux-armv7l/egg/socketio/namespace.py", line 170
[localhost] out:     print "ERROR: No such callback for ackId %s" % packet['ackId']
[localhost] out:                                                ^
[localhost] out: SyntaxError: Missing parentheses in call to 'print'
[localhost] out:
[localhost] out:   File "build/bdist.linux-armv7l/egg/socketio/server.py", line 108
[localhost] out:     except error, ex:
[localhost] out:                 ^
[localhost] out: SyntaxError: invalid syntax
[localhost] out:
[localhost] out:   File "build/bdist.linux-armv7l/egg/socketio/virtsocket.py", line 365
[localhost] out:     except (ValueError, KeyError, Exception), e:
[localhost] out:                                             ^
[localhost] out: SyntaxError: invalid syntax
[localhost] out:
[localhost] out:   File "build/bdist.linux-armv7l/egg/socketio/packet.py", line 156
[localhost] out:     except ValueError, e:
[localhost] out:                      ^
[localhost] out: SyntaxError: invalid syntax
[localhost] out:
[localhost] out: zip_safe flag not set; analyzing archive contents...
[localhost] out: socketio.__pycache__.sdjango.cpython-34: module references __path__
[localhost] out: creating /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/gevent_socketio-0.3.6-py3.4.egg
[localhost] out: Extracting gevent_socketio-0.3.6-py3.4.egg to /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages
[localhost] out:   File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/gevent_socketio-0.3.6-py3.4.egg/socketio/namespace.py", line 170
[localhost] out:     print "ERROR: No such callback for ackId %s" % packet['ackId']
[localhost] out:                                                ^
[localhost] out: SyntaxError: Missing parentheses in call to 'print'
[localhost] out:
[localhost] out:   File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/gevent_socketio-0.3.6-py3.4.egg/socketio/server.py", line 108
[localhost] out:     except error, ex:
[localhost] out:                 ^
[localhost] out: SyntaxError: invalid syntax
[localhost] out:
[localhost] out:   File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/gevent_socketio-0.3.6-py3.4.egg/socketio/virtsocket.py", line 365
[localhost] out:     except (ValueError, KeyError, Exception), e:
[localhost] out:                                             ^
[localhost] out: SyntaxError: invalid syntax
[localhost] out:
[localhost] out:   File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/gevent_socketio-0.3.6-py3.4.egg/socketio/packet.py", line 156
[localhost] out:     except ValueError, e:
[localhost] out:                      ^
[localhost] out: SyntaxError: invalid syntax
[localhost] out:
[localhost] out: Adding gevent-socketio 0.3.6 to easy-install.pth file
[localhost] out:
[localhost] out: Installed /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/gevent_socketio-0.3.6-py3.4.egg

Is this expected?

Looks like the ozwcp is a known issue.

Cannot open Control Panel (ozwcp) Cannot find a path to the configuration files