Once Installer Finished, keep getting connection refused

Hey all,

after having many issues with openzwave installation on mac i decided to purchase a pi and use the all in one script, however, after the script runs and my pi reboots when i try navigate to the pi IP:8123 i get "xxx.xxx.xx.xx refused to connect (my pi ip adress), Any advice on how to fix this issue? I saw online the best way to fix it is to just do a fresh installation (of OS and the script) and i have done this 3 times now one of them being on Rasbian-Lite, and still get the same message when i try connect to the ip adress. I feel like my home assistant is not auto running on boot as my Pi CPU usage stays around 0% are there any specific commands to check if home assistant is currently running/ to run home assistant from the all in one script download? (hass --open-ui doesnt work)

Please s.o.s !

What worked for me was to add a line in configuration.yaml with the entry

base_url: my_ipaddress:8123

where my_ipaddress is the address where my raspberry can be reached
and 8123 is the default port for home assistant.

Hope this helps you


Hi! I’m new with home assistant but I think I have the same problem… But using hassbian
Burned the image to a sd, plug into rasp3, ir works!
Then used putty to change weather to weather underground, rebooted and… Nothing. Connection has been refused. Over and over. No way to access the gui. Tried adding the ip as stated above… Same happens. Looks like it only works for me the first time it runs :frowning:

I can access the raspberry through ssh, tried to validate configuration, using hass --script check_config and…
-bash: hass: command not found

I have some problem here
Any one figure out yet?

Yeah the WIKI implies that you just load the image onto an SD card. Boot up the PI and everything should get installed. Doesn’t quite seem to be the case?

UPDATE : Okay on my 3rd attempt I just let it sit there for about 30 minutes and now it seems to be up and running. Maybe the 5min wait time in the documentation needs to be extended :slight_smile:

Hi, Tommy

So, your mean is that I may need to wait about 30 minutes to connect MYPI Ip:8123 after I restart home assistant?

Just the first time it starts up after you install the SD card with the image on it.

Holy cow. How was it THAT simple!? Thanks!