Fully Kiosk Browser error: Timeout fetching <ip address> deviceInfo data

I’m running Fully Kiosk Browser on an Amazon Fire Tablet 8 HD (10th gen) with the Fully Kiosk Browser HACS integration. I just noticed this error started occurring a few days ago and it’s happening frequently as the occurrences is around ~280. The error message is:

Logger: custom_components.fullykiosk.coordinator
Source: helpers/update_coordinator.py:179
Integration: Fully Kiosk Browser ([documentation](https://github.com/cgarwood/homeassistant-fullykiosk), [issues](https://github.com/cgarwood/homeassistant-fullykiosk/issues))
First occurred: April 17, 2021, 4:21:06 PM (280 occurrences)
Last logged: 10:28:58 PM

Timeout fetching <ip address> deviceInfo data

I did swap out my wireless access points from Apple Airport Extremes to Unifi 6 Lites. I noticed on the Unifi app when viewing the Amazon tablet there is a parameter labeled “Power Save” which is enabled, but it can’t be changed. Not sure if this is some new wifi feature my Apple Airport Extremes didn’t have but I doubt it since the tablet is connected to the APs using Wifi 5 (2.4Ghz).

On the tablet itself in HA, I made sure “Automatically close connection” is disabled.

Anyone else experiencing this issue or know what might be going on?

Still experiencing this issue on both my tablets. I’ve also tried setting a static IP address on the tablet itself (I was setting a static IP address on my router before) but it made no difference. I’ve tried rebooting the tablets and HA. Any other ideas on things to try?

It sounds like there’s a network issue or the tablet’s aren’t responding. When you see these errors try accessing the web interface directly in a browser at http://:2323

So after having dealt with his issue for months now, it seems to have magically stopped. I did update my Amazon Fire tablets from to to fix another issue, but this particular “Timeout fetching…” issue was still occurring even after the update. Somewhere in there I did update my Home Assistant version as well so I’m not sure if it was maybe a combination of updating the tablets and restarting HA that maybe re-established the connection from HA to the tablets fixed it? The only other change I made was I also removed an RPi3 from my network that was solely acting as an avahi reflector, but I’m assuming that has no impact on this particular issue.

Anyways, it’s been a few days now and I have not received any of the “Timeout fetching…” errors in the HA logs and I don’t see my tablets becoming “Unavailable” in the logbook or history timelines. Previously I would see this occurring probably every 10-20 minutes for a very short period (3-5 seconds).


I am having a similar issue. This used to be a problem but then magically went away and worked perfectly. I am running a dashboard which displays a lot of info, and it seems to stop updating and showing info that is not current anymore until you try and interact with it, then it reconnects and everything updates. This is not really how I want it to work. It needs to show current into all the time.

I had problems with it earlier this year, but it has been working perfectly for a few months now until last week. Now it’s having the same issue again. Unfortunately there has been both a HA update and a Unifi Network application update and firmware update on my UDM done around the same time, so I don’t know if it’s a Unifi issue (tablet is connected to a Unifi NanoHD AP on 5Ghz) or a Home Assistant issue.