Garage Door (Secure Barrier) just shows stats on states but no actions

Hello everyone, I am running the latest version of HA (0.50.2). I added my garage door device (GoControl/Linear GD00Z-4 Z-Wave Garage Door Opener) to my Aeotec Z-stick Gen5 via the HA zwave section (even tried from Open Zwave Control Panel). However, when i load up the home assistant page I only get some stats about the device in a weird way. I cannot see any way to actually control the device. See image below.


Here is my yaml for zwave…

  usb_path: /dev/ttyACM0
  config_path: /srv/homeassistant/src/open-zwave-control-panel/config
  polling_interval: 10000
  network_key: !secret zwave_network_key

I set the network key in the config_path’s option.xml and the key matches in the secret.yaml. For the sake of debugging purposes here,. this is how it is formatted in the secrets yaml (with a new random key).

zwave_network_key: 0xF7, 0x08, 0x06, 0x63, 0x0B, 0x86, 0x53, 0xE1, 0x2B, 0xA3, 0xA5, 0xEE, 0x69, 0x04, 0x52, 0x71

What am I doing wrong? I want to be able to control my garage door.

The problem is that until recently HASS didn’t support it, and OpenZWave still doesn’t.

You can get it to work if you are prepared to do some patching, there is a thread on it here

I thought they added things to work in this version? Only that they had to use the dev branch of Openzwave.

Any updates on the Garage Door working/not working? Looking forward to this.

Please see this thread.

@firstof9, I’m reviewing that thread as well. Very long, but at the end I see still a half-way working. Is this standard now or still requiring the dev branch? Hard to tell.

Still needs the dev branch to work, but you only need a single command to install it now.

I think I’ll hold off until it’s more baked in before I migrate that off my other hub. Until then things are good.