GE/Jasco 26933 issues

Tags: #<Tag:0x00007f3270a82f88> #<Tag:0x00007f3270a82e98> #<Tag:0x00007f3270a82dd0>

I am having multiple issues with a newly installed GE 26933. I’ve hard reset the device multiple times and the problems remain the same. I have 8 other zwave devices, mostly GE switches and dimmers, that are happy.

  1. Each entity is duplicated. For example, I have 2x sensor…alarm_levels, 3x light…dimmer_levels, etc.
  2. The device isn’t sending callbacks/updates for any of the entities.

Commands to turn the lights on and off from HA work fine.

Only clues from openzwave are 10 of these messages in the logs:
Info, Node021, DisablePoll failed - value not on list

If I setup polling intervals, HA will update but of course this isn’t ideal and doesn’t fix the odd double entities issue.

The host is debian stretch with HA 0.49.1. Please let me know if you have any pointers or thoughts.

Can you post a screen shot of the devices from the <> menu on the left side of home assistant?

Attached are pictures of all of the devices. I noticed when I set Operation Mode to manual from HA that I get triplicates of the entities. I have the switch version (26931) that I may try and wire up tonight to see if it behaves the same way.

Apparently setting any configuration options adds an additional entity.but it stops at 3.

Very strange looks like a glitch in OZW Library not HA.

It this be caused be something in the device database or would it be something more core? Looking for a thread to pull so I can dig a bit deeper.

Does this duplication occur when you set the configuration via OZWCP?
If so then it’d totally be a OpenZwave issue, otherwise then it’d be a HA issue.

Yes, it looks like I have duplicates in OZWCP as well.

Very strange, looks like an OpenZwave issue then.
You could try compiling the latest dev version of python_openzwave to see if that helps.

I didn’t think OZWCP used python-openzwave. The clone of openzwave is from 7/26 but I’ll try a current and see what happens. I also posted over in the openzwave list (https://groups.google.com/forum/#!topic/openzwave/7RcXqa-Oc4I) to see if anyone has some ideas.

Thanks for your thoughts on this.

it uses the openzwave library, in OZWCP does it show version 1.4.xxxxx or 1.5.xxxx?
1.5.xxxx is the dev build.

I noted this in the dev branch:

Looks to be 1.4:

2017-07-28 09:54:49.878 Always, OpenZwave Version 1.4.2692 Starting Up

I’ll compile the dev branch to see if that changes anything.

I run the dev branch due to proper support for garage door openers. It works well.

@homeslice Also this: https://groups.google.com/forum/#!topic/openzwave/_NY_IfQWrSc

Same issue with 1.5.2817

I believe I have sold the issue of additional instances popping up by adding the following to 26933-motion-dimmer.xml:

    <CommandClass id="38" mapping="endpoints" />
    <CommandClass id="94" mapping="endpoints" />
    <CommandClass id="113" mapping="endpoints" />

I’ve then hid the the second instances using hidden: true under customize. I am still having issues with the switch reporting status and have tried everything including switching the breaker. Looks like others are having similar issues and is mostly likely either a firmware bug or an issue with openzwave.


http://forum.micasaverde.com/index.php?topic=48090.0

If the issue persists on other platforms, I’d have to say it’s a firmware bug.

Was a solution ever found? I’m having the same issue on 0.52.1

Same issue, GE 26933

The duplication appears to be due to the switch because multiple controllers (hubs) report more than one entity. I have a Winkhub and it will find two lights and an alarm entity. With openzwave, it also reports tons of entities including two lights, alarms, and burglar entities.

However, I did figure out how to enable the motion sensors for HA. This was mainly after a couple hours of research including this helpful homeseer topic mentioned above. I ended up getting an Aeon Z-Stick connected to my RPi3 as I wanted the fuller command set that Winkhub doesn’t have.

  1. Set the Jasco switch to manual mode. I did it using the buttons but supposedly you can do it using the zwave command setting parameter 3 to value 1.

  2. Isolate the burglar sensor that has changing values. I did this by staying in the dev-states section of HA and watching which Burglar sensor would change state as I moved in front of the switch. One would switch from 0 to 8 (this could be related to motion sensitivity but I didn’t play enough to find out. The other would lock at 254. In my case sensor.great_room_switch_burglar (Note: I had renamed my node but I think the default is “sensor.ge_26933_smart_motion_dimmer_burglar”.

  3. Create a template binary_sensor to convert the number value to a on and off value.

     greatroomswitch_motion:
     friendly_name: Great Room Switch Motion
     device_class: motion
     entity_id:
       - sensor.great_room_switch_burglar
     value_template: >-
       {{states("sensor.great_room_switch_burglar") |float > 0 }}
2 Likes

Did you do any other tricks to get this working? I have set the switch to manual mode, and I have two instances of the “burglar” sensor, but they both stay locked at 254 all the time, regardless of if there’s motion or not. Has anyone else solved this problem?

1 Like