Generic x86-64 Installation on Fujitsu Esprimo Q920

Hello,
I’m trying to install HA OS on mini-PC Fujitsu, following the instructions provided by the official guides but, I suppose, I’m failing some steps since isn’t working.
In bios I enabled UEFI and Network Stack, disabling also Secure Boot then, after formatting the SSD, I flashed the OS into it but when boot it nothing happens and it turns off after a few minutes.
I connected the mini-PC to a screen to see what happens and it doesn’t go further the black screen you see in the image.
Please let me know where I got wrong, thanks.

According to the first picture (IMG_20211014_155722) under “Boot Option Priorities” you have set:

  • "Boot Option #1" to "Ethernet IP4"
  • "Boot Option #2" to "Ethernet IP6"
  • "Boot Option #3" to "Diagnostic Program"

Set “Boot Option #1 - “Ethernet IP4” to “YOUR-SSD-DRIVE” (the actual name/drive should be selectable through the BIOS-settings; make sure the drive is properly connected to the Q920) unless you have a ethernet connected SSD-Drive (which you obviously don’t have).

Hi @Tamsy, thanks for the reply. In order to get the SSD boot option I changed some parameter in bios, putting “UEFI and Legacy” in “Launch CSM” (see pictures).
However, problem still remains, mini-PC doesn’t even appear in my local network when ethernet cable is plugged in.


Just to get it right: Your mini-PC still doesn’t boot? Or it does boot but is not reachable through the LAN?

If the device is still not booting from the SSD:

How did you flashed the OS to the SSD, what software did you use for the procedure and which OS-image did you exactly try to flash?

It boots but it is unreachable via LAN.

I used Balena Etcher getting the OS from link reported in the official page: https://github.com/home-assistant/operating-system/releases/download/6.5/haos_generic-x86-64-6.5.img.xz
My best guess is that I’m not correctly configuring my bios but I don’t really know what else I should do.

Connect a monitor and keyboard to your Q920 and do the initial onboarding through direct connection. You should be able to configure LAN settings directly through the HA web interface.

If I connect it with a monitor I only get a black screen, same as if I connect a monitor to my Raspberry.

Small update.
It seems like if I set the bios in UEFI mode I have only IP4 and IP6 as boot options, however, the device it shows on my local network.
If I set the bios in UEFI and Legacy mode, putting the SSD as boot point, I get only a constant black screen and the device doesn’t appear anymore on my local network.
I really don’t know about how to get out to this impasse…

Unfortunately I have never worked with a Fujitsu Esprimo Q920-PC thus I don’t know about the available BIOS parameters.

As the next step to narrow down on why the Q920 is unavailable on your LAN I would set

  • "Boot Option #2" to "DISABLED"
  • "Boot Option #3" to "DISABLED"

Since you don’t plan to boot the Q920 over Ethernet it should be safe to disable all settings referring to LAN-booting from the BIOS-settings.

Let me know how it goes.

Would this mini PC be able to install windows or linux at all?

If yes. I would do that, and then use the windows/linux as the host OS of an VM setup, and then run HAOS as an VM.

I mean, you absolutely could, but you don’t have to dedicate the entire box for HAOS.
The Fujitsu box is (way) overspec’d just for HAOS.
Well unless you have other considerations.

So, after some dig I discovered that other users had my same trouble with the same device, therefore the only solution I see is to utilize a VM.
I installed Proxmox and, consequently HAOS. Now I’ve a question, If I restore a backup from my instance installed and running on my raspberry, this will create some conflicts if I run them simultaneously (Raspberry and Fujitsu)?

Did you install HA via Proxmox successfully? I cannot even do that, I get PCIe errors and cannot boot UEFI disk with HA even when it’s a Proxmox VM…

Make sure virtualization support is turned on in the BIOS of the server.
Disable Secure Boot in UEFI Bios. Usually under Device Manager.

For some reason, I needed to disable secure boot in the Proxmox BIOS when launching HA install. When on Proxmox7, I also got errors with ‘waiting until kernel time synchronized’ and ‘wait until come online’. These were likely caused by Proxmox 7 using Crono instead of timesync-d of Proxmox 6, so I needed to install 6.4 instead of 7.1, This did the job and now HA is running smoothly.