Getting a warning about mqtt config after adding the mosquitto in hass.io

Hi All

I’ve added the mosquitto mqtt from hass.io as I understood from the docs that would be a better solution than the built-in.
I now see this warning in the logfile:

Data in your config entry is going to override your configuration.yaml: {'broker': 'core-mosquitto', 'discovery': True, 'password': 'XXXXXXXXXXXXXXXXXXXXXXX', 'port': 1883, 'protocol': '3.1.1', 'username': 'homeassistant'

In my configuration I have this:

mqtt:
  broker: LAN-IP-ADDRESS
  discovery_prefix: homeassistant

I know it’s only a warning, but I really don’t understand it, I had a ‘discovery: true’ in the config file, and removing that didn’t change anything, so what is it complaining about? The IP address is my IP address for the Raspberry Pi with Hass.io, not an internal container IP (which I wouldn’t know anyhow).

I also see a warning about the life360 component not being tested yet, that I can understand, so I can just ignore that and hope it gets tested and / or integrated.

1 Like

Hi, did you ever get anywhere with this error? I have a similar problem having just created my first Home Assistant server with Mosquitto add-on.

Thanks

hi

same for me, nobody knows how to fix it?

thanks

Hi Olivier,

Yes I figured it out in the end but this was the solution for my set-up and not sure if its the universal answer… give it a try and see how it goes…
First off I added the Google Backup Add-on to my set up - Nice YouTube video here if you need help doing that. https://www.youtube.com/watch?v=WcErD5PvIYw&list=PLFLOgOwVGodVlT9CIv4qUocBtVVsA-M7o&index=7&t=3s
I did this because I needed to edit the core.config_entries and I wanted a good reliable method of backing up my HA files.
Then I removed the following section from /config/.storage/core.config_entries

    {
                "connection_class": "local_push",
                "data": {
                    "broker": "core-mosquitto.local.hass.io",
                    "discovery": true,
                    "password": "eeR1engo8Quaht0ohngoomohng0oot8iajubeesu2phohj5kieh6xe6iecicoofu",
                    "port": 1883,
                    "protocol": "3.1.1",
                    "username": "homeassistant"
                },
                "domain": "mqtt",
                "entry_id": "9d5bb51f5b4c496da1d575c9d6967b23",
                "options": {},
                "source": "hassio",
                "system_options": {
                    "disable_new_entities": false
                },
                "title": "Mosquitto broker",
                "version": 1
            }

I think this was the HA’s auto-discovered / created MQTT broker that was overriding the settings in my configuration.yaml. After a restart everything worked fine and I didn’t get the error anymore, hope this helps.

1 Like

hello @neilc and thanks for your reply,

yes i already do that before and i think it works for me too!

Just dont forget to remove the “,” at the last “}” above because this part is my last entry of the “core.config_entries” :wink:

thanks!

Holy moly thank you. Ive been banging my head against the table for a week trying to figure out why eveyrhing but hass could connect to the broker.

Hi.
I had the same warning, so I tried the same solution.
I removed that section and restarded HA.
Mosquitto starts and in its log I can see that clients are connecting to it.
Anyway on frontend I see all my MQTT entities unavailable.
In HA log I read: “ERROR (Thread-6) [homeassistant.components.mqtt] Unable to connect to the MQTT broker: Connection Refused: not authorised.”

If I restore the old /config/.storage/core.config_entries files, everything gets back as before.

I tried this because I’m having some “mqtt socket error on client xxx disconnecting” in Mosquitto log.

What am I missing?!?

Ok, maybe I fixed it… it looks like that this was the solution in my case: MQTT Addon: "Data in your config entry is going to override your configuration"

You’ve configured MQTT through both the UI (Configuration -> Integrations) and YAML. You need to delete the UI integration and configure it all through YAML (or delete the YAML and configure it all through the UI).