Getting going after a brownout

Can someone help please? I’ve had HA ruuning nicely in VM VirtualBox on a windows pc for ages but the mains power just went low voltage for a couple of hours. The HA server still seemed to be running but inaccessible. When power was restored HA did not restart. Looking at VM it said “waiting for cli”. I typed F2 & logged in with “root”. I get “welcome to home assistant OS” but am stuck again.
I read somewhere to type “docker pull hassio-cli” abd i get “no such container”.
What can i do now?

ha supervisor repair

Thanks but I get the same response “no such container: hassio_cli”

I don’t know if this helps, but I got this on-screen when I tried restarting again this morning;

If I install HA from scratch, is there any way of fetting my old confirguration back?

In Virtualbox, create a Debian VM. Then attach your HA OS VDI to the Debian VM, mount hassos-data and try to copy your config (including hidden files and directories), or backup if there are.
These can then be restored to a new HA OS VM.

1 Like

Thanks Francis. I’ve pulled debian but am stuck on how to do the rest. Can you suggest where I can find the commands needed?

Choose your HA OS vdi

Check Hard Drive

Check if the hard drive is detected by running the following command:

sudo fdisk -lCopyText Copied

Step 1: Get Device Name

Look for the hard drive in the list of devices. It will be listed as something like /dev/sdb or /dev/sdc. Make a note of the device name.

Step 2: Create Directory

Create a directory where you want to mount the hard drive by running the following command:

sudo mkdir /mnt/harddrive

Step 3: Mount Hard Drive

Mount the hard drive to the directory you just created by running the following command:

sudo mount /dev/sdb /mnt/harddrive

Replace /dev/sdb with the device name you noted in step 1. You should now be able to access the contents of the hard drive by navigating to the /mnt/harddrive directory.


Im sorry to be so useless, but your first command gave errors but fdisk -l gave me the attached image so i think the data i want is in /dev/sda8. As you can see, mkdir told me the file system is read-only, so im stuck again.
I am right in having executed “docker pull debian” from the # prompt after signing in as “root”?

Did you install a full Debian VM ? the Debian VM should use sda1, and the attached HA OS vdi sdb.
Anyway, your configuration is in /dev/sda8

No idea what that does, is there a full debian in a docker image ?

1 Like

I did but it resulted in a non-responsive black box in virtualbox.
How can i get at the configuration in /dev/sda8? Can i restore from it in a new installation?

if Debian does not work, you can use any other Linux distribution

1 Like

Having another try setting up debian. A slow process!

You can download a pre-made image


Hello again. My 2nd attempt to set up debian failed as did downloading a pre-made image. However I have got ubuntu running.
I seem to have gone wrong again though - see screenshot

I also tried adding a path to the haos vdi file which gave the same result. Any ideas?

What does this return ?

1 Like

I can’t get copy & paste to work, but here’s a screenshot of the last section. No mention of /dev/sda8

And you did already attach the .VDI to your ubuntu ?

1 Like

I missed that step! I must be going about this wrong. This is what I just tried:
From Oracle VirtualBox manager with just the ubunto machine running I click select the HA directory & click HA virtualbox. I then get the messsage Failed to open virtual machine located in D:/HA/HA.vbox.

Trying to open a VM config ‘D:/HA/HA.vbox’ which has the same UUID as an existing virtual machine.

Result Code: E_FAIL (0X80004005)
Component: MachineWrap
Interface: IMachine {300763af-5d6b-46e6-aa96-273eac15538a}
Callee: IVirtualBox {7682d5eb-f00e-44f1-8ca2-99d08b1cd607}

My knowledge of Virtualbox stops there. Never knew it could create disks with the same UUID.

1 Like

Well im very grateful to you for yrying to help!
As fdisk -l lists /dev/sda8 from within the HA VM, isnt there any way i can save its contents from there?