Gigaset Elements - Discontinues its services as of 29 March 2024

Gigaset Smart Home/Care discontinues its services as of 29 March 2024

Custom component providing Gigaset Smart Home integration. More information can be found on below github page:

1 Like

Hi dynasticorpheus, I have installed the Gigaset component via HACS but not sure how to configure it, can you help?

I have been able to make it work.
Great job! I have been looking to integrate Gigaset Elements for a long time.
Now I want to find a way to switch on some lights in case of an alarm.

Just reporting a possible bug: arming works for each mode (away, night) but disarming doesn’t work properly. If you disarm the system by disabling the night or away switch, it changes to “custom”, if you switch to “home” (disarm) it is ignored and the system remains armed.

Hi @tizgal

Alarm mode (names) are standardized in HASS hence I used below mapping, this ensures future development from either sides won’t break things:

So turning the gigaset_elements_home_mode switch on currently means selecting custom mode. Confusing I admit so I will rename switch.gigaset_elements_home_mode into switch.gigaset_elements_custom_mode to make this a bit more clear.

edit: version 0.2.2 with renamed switch now released

Yes, renaming Home to Custom is the solution.
I have tested with HomeKit as well and works just fine. I was losing home to interface Gigaset Elements to any other smart home system, thanks again for your work!

Quick question, I can’t find a way to detect an alarm, I would like to use it as a trigger to switch on some lights.

Hi @tizgal Did you already set up the Alarm Panel card using entity alarm_control_panel.gigaset_elements ? It will go to state triggered in case the alarm goes off hence your automation should monitor for this state in case you want to turn on the lights.

Hope this helps!

ps: You will also notice the Alarm Panel card uses standardized names for the alarm states which links back to the required mapping as mentioned before. e.g disarmed = home & armed_home = custom

Yes, the alarm trigger works just fine, I have been finally able to switch on the lights in case of alarm!

I did some more tests with the mode selector.
The single switches gigaset_elements_away_mode, gigaset_elements_night_mode, gigaset_elements_custom_mode, gigaset_elements_panic_mode work fine, but the alarm panel doesn’t.

this is the panel in normal condition (home):

the buttons “Arm Away” works fine, the button “Arm Home” sets instead the custom mode.
The button “Arm Home” should be “Arm Custom”, the buttons “Panic” and “Arm Night” are missing.

Also, when armed it is impossible to disarm, no matter if you push the “Disarm” button, with code or not, nothing happens and you must disarm using a switch or the Elements app.

Last question, what is the PIN for? It is not used in the Elements app, and it is not clear how to use it.

@tizgal As I tried to explain before (and failed :slight_smile: ) the alarm mode names (states) in hass are standardized / unchangeable and since “home” and “custom” do not exist these are mapped against disarmed and arm_home. Although I named the switches similar to the modes used in the gigaset app, underneath it still uses the arm_home, arm_night and arm_away naming. (the alarm panel will show you this)

I think the only thing you really need to remember is custom = armed_home and vice versa when controlling things from home assistant end.

arm_night is missing from the alarm panel because you did not add this mode while setting up the card. Panic mode is not an alarm mode hence hence only exists as switch.

Last two options in the configuration.yaml control the pin in the alarm panel. code obviously being the pin to be used when disarming the alarm. If code_arm is set to true you also need to enter the pin when turning the alarm on.

You can also disable the switches when setting option switches to false. If one would really prevent the alarm being disarmed without code this is needed as the switches do not require any code. Moreover the pin is a home assistant only feature and indeed does not exist in the gigaset elements app.

  name: "gigaset_elements"
  username: !secret gse_username
  password: !secret gse_password
  switches: True
  code: 1234
  code_arm_required: false

@dynasticorpheus you are right, my bad, I didn’t understand your previous post :slight_smile:
Everything’s working as expected, I have been looking for this integration for a long time.
It works very well and should be offered officially.
Thanks again for your work!

@dynasticorpheus Your Gigaset Elements implementation works great. I am now having fun implementing some automation.

I have a question about the pending time, I have noticed 20 seconds delay before arming or disarming.
Is there a way to disable this time?

@tizgal In reality the (dis)arming happens immediately however “pending” is shown until the next refresh interval happens (10 +/- secs) and the requested mode is provided as new status. Not super happy with this behavior so need to look into that if I can optimize this. Same more of less happens when using the switches which move back to original position until next refresh. WIP!

1 Like

What makes me mad about Gigaset elements is that everything goes through the cloud, so any operation is delayed, and sometimes the cloud is offline so I can’t arm/disarm the system. I have solved the problem using a button that arms and disarms.

Would be really nice to have access to the local control unit to speed up the control.

Hi @dynasticorpheus, recently, the component doesn’t expose the triggered status. I have updated the components and running the latest version of the Gigaset Elements app.
Arming/Disarming works just fine; only the triggered status is not detected anymore.

Hi, is there anyway to set a long delay before the system arms? I use it on a tablet in the kitchen but we can take 5 or 10 mins to finally leave the house by which time we trigger the alarm.

Currently you can only configure this in the official gigaset elements app. I will put this on the list of future enhancements.

You are correct let me check and fix this

Should be fixed in version 0.3.0, please test.

Updated just now to 0.3.0 but still no luck.
I there any specific test I can do to help you debug?

It’s working for me after doing some tests once more. Did you restart home assistant? Also the front-end needs some time to update so be patient.

Hi dynasticorpheus

The Gigaset implementation works like a charm! Thanks, great work.
Maybe you can help me to improve my installation:
I use water sensors, as well as a universal sensor on one door. I can see that the Water sensor shows humidity as well as temperature, but only in the tab of the binary sensor. I did not find an entity with those additional values.
Can you provide me with a hint how I can make homeassistant to show those additional values as entities?

Thank you!