Google Assistant addon 1.1 stop working

who has problems after updating it with the addon google assistant? after the last 2 updates it has all worked out.
[Info] Install / Update service client_secrets file
Traceback (most recent call last):
File “/”, line 30, in
with Assistant (credentials) as assistant:
TypeError: __init __ () missing 1 required positional argument: ‘device_model_id’

Same issue here

Same here. v1.0 didn’t work either. Had to roll back to 0.0.3p-5

Yup. Downloaded new credentials.json, but the problem persists.

Would you have some steps to roll back a plugin handy?

use a snapshot. I always make a new one before any updating. good practice

Snapshot backup didn’t help - i think this is due to the update to the Google SDK. Weird that a ned credentials.json doesn’t work.

make sure you uninstall 1.1 first, then restore 0.0.3p5 that worked here.

looks like model-id should be fixed in 1.2

added project_id and model_id
still something wrong with version 1.3 getting this error now

File “/”, line 59
for event in assistant.start():
SyntaxError: invalid syntax

back to 0.0.3p5 again

Same here!
I downgraded to version 0.0.3-p5 but still getting the same error?
Any hint?

I had Google Assistant add-on fully implemented and working well. But now I am on HA 0.68.1 and Google Assistant addon 1.3 and assistant is totally broken. In fact I don’t even get the errors you highlighted.

We need to know if future updates will put things back the way they were or whether we need to re-implement the add-on, which isn’t a nice thought.

the same problem, the only one is to go back to the working version, even if I’m hoping for this because maybe make it useful to the Italian language.

[Info] Install/Update service client_secrets file
[Info] Start WebUI for handling oauth2
[10/May/2018:08:13:12] ENGINE Listening for SIGUSR1.
[10/May/2018:08:13:12] ENGINE Listening for SIGHUP.
[10/May/2018:08:13:12] ENGINE Listening for SIGTERM.
[10/May/2018:08:13:12] ENGINE Bus STARTING
CherryPy Checker:
The Application mounted at ‘’ has an empty config.
[10/May/2018:08:13:12] ENGINE Started monitor thread ‘Autoreloader’.
[10/May/2018:08:13:12] ENGINE Serving on
[10/May/2018:08:13:12] ENGINE Bus STARTED
[10/May/2018:08:13:32] ENGINE SystemExit raised: shutting down HTTP server
[10/May/2018:08:13:32] ENGINE Bus STOPPING
[10/May/2018:08:13:32] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer((‘’, 9324)) shut down
[10/May/2018:08:13:32] ENGINE Stopped thread ‘Autoreloader’.
[10/May/2018:08:13:32] ENGINE Bus STOPPED
[10/May/2018:08:13:32] ENGINE Bus EXITING
[10/May/2018:08:13:32] ENGINE Bus EXITED
[10/May/2018:08:13:32] ENGINE Waiting for child threads to terminate…
File “/”, line 59
for event in assistant.start():
SyntaxError: invalid syntax

does anyone know how I can get back to the working version?

What would change for Italian?

I have no idea, I could not set the Italian language, I thought that with this update something changed.
why did you manage to use it in Italian?

I have a multi language family, so a particular case.

I set 3 GH speakers to English except phone (I need Google Maps in italian for inputting with voice the streets) and one speaker for Grandma in Italian.

Overall a bit of a mess…

My Hass integration is with previous system and it works but I just use English

ah ok, but have you ever tried a setting in other languages? I was interested in using the raspberry as google home but in Italian :slight_smile:

google home mini is so inexpensive I recommend use it instead of a PI

I have 1 google home mini, and it’s great if used properly, but since I have the chance to have on the raspberry, I wanted to try, because otherwise I’ll take another one later to put the other side of the house.

Just to chime in I’m having an issue as well with the google assistant addon.
I’ve registered my device and added the new model ID as well as the project ID (by name).

I’m getting the following;

[Info] Install/Update service client_secrets file
Traceback (most recent call last):
File “/”, line 10, in
from google.assistant.library.device_helpers import register_device
ImportError: No module named ‘google.assistant.library.device_helpers’

I’m assuming this has to do with the latest updates to the google assistant (multiple languages etc) that were just announced?